Bug 6367 - Hidden folders in MyDocs folder are listed twice
: Hidden folders in MyDocs folder are listed twice
Status: RESOLVED DUPLICATE of bug 5838
Product: Utilities
File manager
: 5.0/(1.2009.42-11)
: All Maemo
: Low normal (vote)
: ---
Assigned To: unassigned
: file-manager-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-27 16:19 UTC by mustali
Modified: 2009-12-01 17:54 UTC (History)
3 users (show)

See Also:


Attachments
File-Manager displaying hidden folders twice (35.57 KB, image/png)
2009-11-27 16:20 UTC, mustali
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description mustali (reporter) 2009-11-27 16:19:58 UTC
SOFTWARE VERSION:
42-11

EXACT STEPS LEADING TO PROBLEM: 
1. Open File Manager

EXPECTED OUTCOME:
Hidden folders like Audio, Camera, Document, Images, Video clips are listed
once

ACTUAL OUTCOME:
Hidden folders are listed twice

REPRODUCIBILITY:
always (in my case)

OTHER COMMENTS:
Until today, this was working fine. I don't know how this started. Reboot
doesn't fix it.

User-Agent:       Opera/9.80 (X11; Linux i686; U; en) Presto/2.2.15
Version/10.10
Comment 1 mustali (reporter) 2009-11-27 16:20:43 UTC
Created an attachment (id=1636) [details]
File-Manager displaying hidden folders twice
Comment 2 mustali (reporter) 2009-11-27 16:21:50 UTC
Nokia-N900-42-11:/home/user/MyDocs# ls -la
drwxrwxrwx   22 user     root        65536 Nov 27 15:09 .
drwxr-xr-x   63 user     users        4096 Nov 27 07:41 ..
drwxrwxrwx    5 user     root        65536 Nov 27 11:15 .Trash-1000
-rw-r--r--    1 user     root       217047 Oct  8 12:53 .VolumeIcon.icns
-rw-r--r--    1 user     root         4096 Oct  8 12:53 ._
drwxrwxrwx    3 user     root        65536 Nov 27 08:33 .apt-archive-cache
drwxrwxrwx    3 user     root        65536 Nov 27 09:53 .documents
drwxrwxrwx    5 user     root        65536 Nov 22 19:23 .images
drwxrwxrwx    2 user     root        65536 Oct 24 13:34 .map_tile_cache
-rw-r--r--    1 user     root        88377 Oct  8 12:53 .n900.ico
drwxrwxrwx    3 user     root        65536 Oct 13 22:44 .osm2go
-rw-r--r--    1 user     root          217 Oct  8 12:53 .qf
drwxrwxrwx    4 user     root        65536 Nov 19 19:34 .sounds
drwxrwxrwx    3 user     root        65536 Nov 13 20:36 .videos
-rw-r--r--    1 user     root          686 Nov 24 03:10 .volbak
drwxrwxrwx    2 user     root        65536 Nov  8 13:26 DCC Downloads
drwxrwxrwx    2 user     root        65536 Nov 27 11:01 DCIM
drwxrwxrwx    2 user     root        65536 Nov 12 10:39 Downloads
drwxrwxrwx   14 user     root        65536 Nov 23 23:18 Podcasts
-rw-r--r--    1 user     root        36592 Nov 17 21:28 agenda.pdf
-rw-r--r--    1 user     root           25 Oct  8 12:54 autorun.inf
drwxrwxrwx    3 user     root        65536 Nov 23 21:10 backups
drwxrwxrwx    4 user     root        65536 Oct  2 17:58 cities
-rw-r--r--    1 user     root       701133 Nov 17 21:45 copmap.png
drwxrwxrwx    8 user     root        65536 Oct 16 17:02 ebooks
drwxrwxrwx    3 user     root        65536 Nov 24 20:47 irreco
drwxrwxrwx    3 user     root        65536 Nov 11 14:35 qik
drwxrwxrwx    5 user     root        65536 Nov 24 07:55 qtirreco
-rw-r--r--    1 user     root        11264 Nov 24 18:51 quicknote.s3db
-rw-r--r--    1 user     root           21 Nov 25 21:08 resolv.conf
-rw-r--r--    1 user     root         2411 Nov 26 01:30 size_usr_lib.txt
-rw-r--r--    1 user     root      1141752 Oct 21 12:57 syslog.txt
drwxrwxrwx    5 user     root        65536 Nov 27 14:16 tmp
drwxrwxrwx    3 user     root        65536 Nov  8 18:55 vpn
Comment 3 Lucas Maneos 2009-11-28 03:46:03 UTC
That's weird.  Do the duplicate folders appear to contain the same files?  Can
you try checking/repairing the filesystem from another computer via USB or
on-device by unmounting and running dosfsck on it?
Comment 4 mustali (reporter) 2009-11-30 00:17:07 UTC
Yes. the folders contain the same files. This goes for subfolders too.

dosfsck didn't fix it. here is the output.

prmpt:~$ sudo dosfsck /dev/sdb 
dosfsck 3.0.3, 18 May 2009, FAT32, LFN
A new long file name starts within an old one.
1: Delete previous LFN
2: Leave it as it is.
? 2
Reclaimed 5270 unused clusters (345374720 bytes).
Free cluster summary wrong (398081 vs. really 403351)
1) Correct
2) Don't correct
? 1
Leaving file system unchanged.
/dev/sdb: 3771 files, 39026/442377 clusters

Is 1 the right answer to the first question?
Comment 5 Jeroen Wouters 2009-11-30 10:51:33 UTC
I can confirm this bug.
The two "folders" contain the same files.
Comment 6 Jeroen Wouters 2009-11-30 10:53:13 UTC
Also, this happens in all other file selection windows (e.g. in the Open dialog
for the PDF reader).
Comment 7 Andre Klapper maemo.org 2009-12-01 17:54:17 UTC
Thanks for reporting this.
This particular bug has already been reported into our bug tracking system, but
please feel free to report any further bugs you find. Also feel encouraged to
vote for the original bug report if interested.


*** This bug has been marked as a duplicate of bug 5838 ***