Bug 6363 - (int-149924) Date format should be defined by Regional Settings, not Device Language
(int-149924)
: Date format should be defined by Regional Settings, not Device Language
Status: RESOLVED FIXED
Product: UI Specification
General
: 5.0/(1.2009.42-11)
: All Linux
: Low normal with 13 votes (vote)
: Harmattan
Assigned To: Mikko Nurmi
: ui-specification-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-27 14:53 UTC by Loek Engels
Modified: 2010-09-08 12:13 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Loek Engels (reporter) 2009-11-27 14:53:26 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Open language & regioj
2. Set device language to English (USA)
3. Set regional settings to Dutch

EXPECTED OUTCOME:
The date format is specified according to the Dutch regional settings:
31-12-2009 instead of 12/31/2009.

ACTUAL OUTCOME:
The date is formatted using English USA regional settings.

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
Always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
The date formatting must use the regional settings (as the decimal and thousand
separator already do) instead of the device language. 

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.15)
Gecko/2009102814 Iceweasel/3.0.6 (Debian-3.0.6-3)
Comment 1 redex 2009-11-30 16:16:57 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 Andre Klapper maemo.org 2009-12-01 17:19:04 UTC
Thanks for reporting this!

> EXPECTED OUTCOME:
> The date format is specified according to the Dutch regional settings:
> 31-12-2009 instead of 12/31/2009.

This is missing one step:
Where exactly can this be seen?
Comment 3 Loek Engels (reporter) 2009-12-02 00:01:15 UTC
See Settings/Language & Region. 

The date format used by all the app on the N900 is displayed there and appears
to be related to device language as opposed to the regional settings what I
would have expected. 

The rationale behind this, is that although I live in the Netherlands, I still
would like to have my menus etc. appear in English, but the date format I would
like to have according the regional settings applicable in the Netherlands.
Comment 4 Andre Klapper maemo.org 2009-12-02 18:43:35 UTC
Ah, got it.

So you want the Date format to be part of "Regional settings" instead of
"Device language".
Comment 5 Loek Engels (reporter) 2009-12-02 20:38:21 UTC
Yes =)
Comment 6 Quim Gil nokia 2009-12-07 09:30:15 UTC
I think it makes sense to discuss this with the Fremantle program as a bug.
Comment 7 Neil MacLeod maemo.org 2009-12-07 14:41:34 UTC
I'm confused - isn't the date "user definable" as per comment 9 in bug 463?

Is the user now able to change the date format after choosing their
language/region? If not then bug 463 is not fixed in Fremantle.
Comment 8 Loek Engels (reporter) 2009-12-07 21:40:46 UTC
Neil, not in the Fremantle I am running (1.2009.42-11). 

I cannot overrule the date format using the regional settings that appears to
be enforce by the device language set. Furthermore I cannot overrule the date
format using the Date & Time menu settings.

I would like to use, e.g. the Dutch date format using an English device
language.
Comment 9 Neil MacLeod maemo.org 2009-12-07 21:50:47 UTC
Thanks Loek, in that case I'll reopen bug 463 if it hasn't been fixed as per
the comment. Apologies for barging into your bug!
Comment 10 Andre Klapper maemo.org 2010-01-15 18:27:15 UTC
*** Bug 8006 has been marked as a duplicate of this bug. ***
Comment 11 Andre Klapper maemo.org 2010-09-08 12:13:29 UTC
According to Nokia this is a WONTFIX for Maemo5.

For Harmattan (the version after Maemo5) "Region format setting is used for
selecting country/region which will affect the display format in date, time,
number, etc.".
Hence closing as FIXED for Harmattan.