Bug 6361 - (int-135249) 'base' and 'more' applications are visible sametime (messed)
(int-135249)
: 'base' and 'more' applications are visible sametime (messed)
Status: RESOLVED FIXED
Product: Desktop platform
Application Menu
: 5.0/(3.2010.02-8)
: N900 Maemo
: Low normal with 2 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: task-navigator-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-27 14:04 UTC by aapo.rantalainen
Modified: 2010-04-13 17:22 UTC (History)
14 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description aapo.rantalainen (reporter) 2009-11-27 14:04:58 UTC
SOFTWARE VERSION:
1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
I do not know. (Not related installing applications.) I just used application
menu to start application and next time it was messed.

EXPECTED OUTCOME:
Application menu has one display 'base'-applications and when I click
'More'-button, I get 'more'-applications (all other installed applications on
scrollable view)

ACTUAL OUTCOME:
http://img522.imageshack.us/i/screenshot2009112712145.png/
When I go to application menu it shows both 'base' and 'more' applications same
time overlaid. Only top of them (scrollable 'more') are clickable.
I can start and scroll 'more' applications. I can cancel application
menu. I can't reach 'base' applications at all. 

REPRODUCIBILITY:
I do not know what broke it, but now it is reproducible all the time.

OTHER COMMENTS:
I haven't yet booted, maybe it will fix this. Is there something I can / should
test before it?
Comment 1 Steve 2009-11-28 19:03:21 UTC
I have also seen this behaviour once before, I have no idea how it got into
this situation, I removed the battery and restarted and have not seen it again 

Rgds Steve
Comment 2 Andre Klapper maemo.org 2009-11-29 01:19:51 UTC
Confirming. Also seen this here (though not in the last weeks)
Comment 3 aapo.rantalainen (reporter) 2009-11-29 20:16:56 UTC
I installed some application from 'add applications' and it fixes application
menu.
Comment 4 Andre Klapper maemo.org 2009-12-05 02:13:51 UTC
*** Bug 6588 has been marked as a duplicate of this bug. ***
Comment 5 Robin Burchell 2009-12-05 23:25:56 UTC
Adding myself to CC. Saw this yesterday.
Comment 6 Andre Klapper maemo.org 2009-12-11 13:31:29 UTC
*** Bug 6854 has been marked as a duplicate of this bug. ***
Comment 7 Andre Klapper maemo.org 2009-12-18 13:44:12 UTC
This has been fixed in package
hildon-desktop 1:2.2.122-2+0m5
which is part of the internal build version
10.2009.51-8
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 8 Andre Klapper maemo.org 2010-01-14 13:40:39 UTC
(Fix not included in today's 2.2009.51-1 update => updating Version field)
Comment 9 Andre Klapper maemo.org 2010-01-21 23:07:42 UTC
*** Bug 8378 has been marked as a duplicate of this bug. ***
Comment 10 Andre Klapper maemo.org 2010-01-22 12:24:19 UTC
*** Bug 8384 has been marked as a duplicate of this bug. ***
Comment 11 Andre Klapper maemo.org 2010-01-22 18:50:49 UTC
*** Bug 8416 has been marked as a duplicate of this bug. ***
Comment 12 Lucas Maneos 2010-01-30 13:09:56 UTC
*** Bug 8687 has been marked as a duplicate of this bug. ***
Comment 13 Andre Klapper maemo.org 2010-02-06 15:17:09 UTC
*** Bug 8863 has been marked as a duplicate of this bug. ***
Comment 14 Andre Klapper maemo.org 2010-03-15 12:34:39 UTC
*** Bug 9548 has been marked as a duplicate of this bug. ***
Comment 15 Andre Klapper maemo.org 2010-03-15 20:54:09 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 16 Tomi R. 2010-04-13 17:22:12 UTC
I can also confirm this bug, happened to me today. I had installed MaStory (and
yesterday Chromium), but I seriously doubt that MaStory would've done this. My
version of Maemo 5 is PR 1.1.1, aka the latest one available, for now.

Also, killall hildon-desktop solved this for me. Just launch X-Terminal, if you
can that is (I have mine on the desktop as alias) and just enter that command,
press Enter and presto! The screen goes black for a moment, to relaunch the
hildon desktop.

That's all folks! :)