Bug 6358 - Release bug fixes now or soon, not later
: Release bug fixes now or soon, not later
Status: RESOLVED DUPLICATE of bug 5709
Product: Settings and Maintenance
Software updater
: 5.0/(1.2009.42-11)
: All All
: Low enhancement with 3 votes (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-27 11:00 UTC by Ville Reijonen
Modified: 2009-12-03 15:36 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ville Reijonen (reporter) 2009-11-27 11:00:35 UTC
SOFTWARE VERSION:
any

EXACT STEPS LEADING TO PROBLEM: 
A bug is fixed or important feature is added to source.

EXPECTED OUTCOME:
Release early, release often.

ACTUAL OUTCOME:
The fixes are kept in wraps and released only when Nokia decides to roll full
upgrade for the platform. That at least judging from the history happens about
twice a year.

REPRODUCIBILITY:
always

OTHER COMMENTS:
For example Modest in unusable for me. See bug 3762: "Performance is unusable
on IMAP accounts with a large number of messages in one or more folders (e.g.
INBOX)" -> https://bugs.maemo.org/show_bug.cgi?id=3762
Comment 1 Lucas Maneos 2009-11-27 12:01:46 UTC
(In reply to comment #0)
> EXPECTED OUTCOME:
> Release early, release often.

I agree with the sentiment, but I think I'll let this be confirmed by popular
vote :-)

> That at least judging from the history happens about twice a year.

In the case of Diablo there were at least 6 official releases in just over a
year.

> OTHER COMMENTS:
> For example Modest in unusable for me. See bug 3762: "Performance is unusable
> on IMAP accounts with a large number of messages in one or more folders (e.g.
> INBOX)" -> https://bugs.maemo.org/show_bug.cgi?id=3762

Well, it's an open source project so nothing prevents you from grabbing the
latest sources and building it yourself.  In this case it's just the usual
"fixed in CVS" problem all open source projects have at some point or other :-)
Comment 2 Andre Klapper maemo.org 2009-11-27 15:21:31 UTC
Thanks for reporting.
This is not a software bug but a question of Nokia's policies, hence out of
scope for this bugtracker.
Please see bug 5709 comment 1.

I wonder if a Brainstorm ticket about this would make sense to show Nokia that
many people (me included) are unhappy with the current situation of waiting
weeks or months for an update.
A potential idea could be to make a weekly internal (unstable) test image
available for those people that are willing to live on the edge and run into
even more problems with their devices. :-P
On the other hand Nokia probably does not want to make new features etc public
to early.
Just my guesses here...

*** This bug has been marked as a duplicate of bug 5709 ***
Comment 3 Ville Reijonen (reporter) 2009-12-03 14:07:02 UTC
> This is not a software bug but a question of Nokia's policies, hence out of
> scope for this bugtracker.

Unfortunately there is no external bugtracker for Nokia policies :)

> I wonder if a Brainstorm ticket about this would make sense to show Nokia that
> many people (me included) are unhappy with the current situation of waiting
> weeks or months for an update.

I wrote one brainstorm - feel free to get it through Nokians.
Comment 4 Andre Klapper maemo.org 2009-12-03 14:24:13 UTC
(In reply to comment #3)
> I wrote one brainstorm - feel free to get it through Nokians.

Exact URL, please. :)
Comment 5 Ville Reijonen (reporter) 2009-12-03 15:36:07 UTC
> > I wrote one brainstorm - feel free to get it through Nokians.
> Exact URL, please. :)

http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/

Yeah, I noticed the problem in finding too.  Brainstorm is such a mess :) ..