Bug 6357 - HildonPannableArea: Support arrow keys (in Image Viewer/Photos & RSS feed reader & MicroB)
: HildonPannableArea: Support arrow keys (in Image Viewer/Photos & RSS feed rea...
Status: RESOLVED WONTFIX
Product: UI Specification
General
: 5.0/(3.2010.02-8)
: N900 Maemo
: Medium enhancement with 51 votes (vote)
: ---
Assigned To: Mikko Nurmi
: ui-specification-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-27 09:36 UTC by Venomrush
Modified: 2012-03-24 11:41 UTC (History)
12 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Venomrush (reporter) 2009-11-27 09:36:42 UTC
SOFTWARE VERSION:
1.2009.42-11.203-2

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Navigate to Menu -> Photos
2. Tap Up or Down arrow

EXPECTED OUTCOME:
Screen to move up and down 

ACTUAL OUTCOME:
Screen does not response to command

REPRODUCIBILITY:
Always

OTHER COMMENTS:
The default images on the retail N900 is quite alot. Using the kinetic scroll
to move is just not the way of doing it.
Suggest to add a scrollbar on the right and implement arrow keys movement.
Comment 1 Andre Klapper maemo.org 2009-11-27 16:33:53 UTC
Thanks for reporting this!

(In reply to comment #0)
> SOFTWARE VERSION:
> 1.2009.42-11.203-2

What is "203-2"? Is that displayed under "Settings > About product" for you?

> EXACT STEPS LEADING TO PROBLEM: 
0. Have more than 15 photos.
> 1. Navigate to Menu -> Photos
> 2. Tap Up or Down arrow

Confirming.

Also, feel free to vote for this.
Comment 2 Venomrush (reporter) 2009-11-27 17:45:50 UTC
(In reply to comment #1)

> What is "203-2"? Is that displayed under "Settings > About product" for you?
Yes it shows the 203-2 for me.

Another areas found with Arrow keys not implemented are:
1. Settings
2. Extended Menu screen (Menu -> More..)
3. Application Manager
Comment 3 Andre Klapper maemo.org 2009-11-27 17:52:59 UTC
Reverting subject. One bug report per issue.
Comment 4 Lucas Maneos 2009-11-28 04:08:52 UTC
Hm, apologies if I'm talking nonsense but if the solution involves
HildonPannableArea handling keyboard input then this would be one issue for all
affected apps.
Comment 5 Andre Klapper maemo.org 2009-12-01 16:24:17 UTC
uh. Good point.
Comment 6 Tim Samoff maemo.org 2009-12-01 16:38:52 UTC
Yep. This also goes for images that arre zoomed in, as well as using left/right
arrows to go from iamge to image in "slide show" mode.
Comment 7 Alberto Garcia Gonzalez 2009-12-10 14:09:35 UTC
Support for arrow keys in the pannable area is purposely not supported.

See the Hildon 2.2 Widget UI specification, pages 26 and 29:

http://www.forum.nokia.com/info/sw.nokia.com/id/019c2b31-3777-49a0-9257-970d79580756/Hildon_2_2_Widget_UI_Specification.html

I think this is a wontfix.
Comment 8 gidyn 2009-12-10 16:00:24 UTC
Perhaps this bug should be reassigned against the style guidelines? Panning and
scrolling on Maemo 5 can be a right pain, particularly in lists - I frequently
end up interacting with a widget in a list while trying to scroll it. Allowing
arrow keys to pan/scroll would help to alleviate this.
Comment 9 Tim Samoff maemo.org 2009-12-10 16:25:11 UTC
(In reply to comment #8)
> Perhaps this bug should be reassigned against the style guidelines? Panning and
> scrolling on Maemo 5 can be a right pain, particularly in lists - I frequently
> end up interacting with a widget in a list while trying to scroll it. Allowing
> arrow keys to pan/scroll would help to alleviate this.
> 

Agreed. This is really a bug in overall UI consistency -- if one scrollable
window (e.g., Maemo Browser) scrolls via the arrow keys, shouldn't they all?
Or, maybe there's a more global interest for disallowing this functionality?
Comment 10 Alberto Garcia Gonzalez 2009-12-10 17:17:09 UTC
(In reply to comment #8)
> Perhaps this bug should be reassigned against the style guidelines?

That would be the way, yes, but I don't know if such a change would be
accepted.

> Panning and scrolling on Maemo 5 can be a right pain, particularly
> in lists - I frequently end up interacting with a widget in a list
> while trying to scroll it. Allowing arrow keys to pan/scroll would
> help to alleviate this.

I haven't had that problem, but that would be a bug in the pannable
area or tree view for activating elements too easily. Enabling support
for arrow keys would not fix the actual problem :)

But again, I honestly haven't had that problem.
Comment 11 gidyn 2009-12-10 17:26:28 UTC
(In reply to comment #10)
> (In reply to comment #8)
> > Perhaps this bug should be reassigned against the style guidelines?
> 
> That would be the way, yes, but I don't know if such a change would be
> accepted.

Whether the change would be accepted is a separate question from how would this
bug be most accurately filed :-)

> > Panning and scrolling on Maemo 5 can be a right pain, particularly
> > in lists - I frequently end up interacting with a widget in a list
> > while trying to scroll it. Allowing arrow keys to pan/scroll would
> > help to alleviate this.
> 
> I haven't had that problem, but that would be a bug in the pannable
> area or tree view for activating elements too easily. Enabling support
> for arrow keys would not fix the actual problem :)

This is not a specific implementation bug. A half-screen list doesn't give you
enough space to differentiate between element interaction and scrolling. For
example, the Settings -> Profiles list contains several sliders. Scrolling the
list over the sliders instead of dragging them is almost impossible. Allowing
the arrow keys to scroll would be an effective workaround.
Comment 12 Alberto Garcia Gonzalez 2009-12-10 17:29:47 UTC
(In reply to comment #11)
> > I haven't had that problem, but that would be a bug in the
> > pannable area or tree view for activating elements too
> > easily. Enabling support for arrow keys would not fix the actual
> > problem :)
> This is not a specific implementation bug. A half-screen list
> doesn't give you enough space to differentiate between element
> interaction and scrolling.

I think you've got a point. Feel free to reassign the bug, then.
Comment 13 Andre Klapper maemo.org 2009-12-10 20:01:30 UTC
*** Bug 6817 has been marked as a duplicate of this bug. ***
Comment 14 Alberto Garcia Gonzalez 2009-12-14 18:00:39 UTC
Reassigning to UI spec
Comment 15 Quim Gil nokia 2010-01-11 22:47:42 UTC
An enhancement request to the Maemo 5 UI spec will go nowhere in practice at
this point. Either you "sell" this as a bug and gets filed internally or the
enhancement as such will get framed in the Maemo 6 context.

However, you might want to wait for the PR 1.1 update since (if I recall
correctly) there were usability improvements in the scrolling and perhaps what
you find a relevant problem is not relevant anymore.
Comment 16 max 2010-01-11 23:33:23 UTC
(In reply to comment #15)
> An enhancement request to the Maemo 5 UI spec will go nowhere in practice at
> this point. Either you "sell" this as a bug and gets filed internally or the
> enhancement as such will get framed in the Maemo 6 context.
> 
> However, you might want to wait for the PR 1.1 update since (if I recall
> correctly) there were usability improvements in the scrolling and perhaps what
> you find a relevant problem is not relevant anymore.
> 

this request has 39 votes. Probably it is have sense to check with PR1.1 and if
it is not resolved change on Bug (normal priority)
Comment 17 Andre Klapper maemo.org 2010-01-11 23:43:38 UTC
The requested feature here is not included in internal version 2010.01-6 hence
it won't be in PR1.1 either.
Comment 18 Quim Gil nokia 2010-01-12 15:02:09 UTC
What I mean is that scrolling through a large amount of pics is easier in PR
1.1 (I believe, can't compare directly to PR 1.0 now) and therefore it can be
that a % of the 39 voters are happy enough.

Touching the framework at this level is delicate now. Specially when Maemo 6
framework is based on Qt and therefore and significant investment from Nokia's
side is going to be put there, unless it represents a real problem for current
Maemo 5 users.

I have hundreds of images and scrolling through all of them is ok-ish. If I'm
looking for something more concrete I use filters. The arrows wouldn't save you
the hassle of going through 100s images either.
Comment 19 Alberto Garcia Gonzalez 2010-01-12 15:29:44 UTC
(In reply to comment #18)
> What I mean is that scrolling through a large amount of pics is
> easier in PR 1.1

I think that the problem is different, see comment #11.

By the way, in PR 1.0 you can easily scroll through a large amount of
items. If you do the scroll gesture two or three times _quickly_ it
will accelerate A LOT.

This was done on purpose. We tested with lists of ~10000 items IIRC
and we could reach the bottom in very few taps.

But again, I don't think speed is the problem.
Comment 20 Quim Gil nokia 2010-01-12 17:20:08 UTC
(In reply to comment #11)
> This is not a specific implementation bug. A half-screen list doesn't give you
> enough space to differentiate between element interaction and scrolling. For
> example, the Settings -> Profiles list contains several sliders. Scrolling the
> list over the sliders instead of dragging them is almost impossible. Allowing
> the arrow keys to scroll would be an effective workaround.

Ah, now I understand.

Anyway, my original point stands. This is more a usability problem (a bug) than
a enhancement request, and the chances of it being analyzed in Maemo 5 at this
point go through filing a bug internally.
Comment 21 Jamil 2010-01-14 16:02:57 UTC
Hi everyone.

Please enable scolling in all applications - it is sometimes very difficult to
scroll through some lists. 

I have suggested in bug report 5555 that the right and left arrows could also
be used to jump many items at a time. For image lists, for example, the R and L
arrow keys could jump two screens at a time, a bit like the D-pad did on the
Nokia N95.

Thanks.
Comment 22 Venomrush (reporter) 2010-03-09 02:21:23 UTC
*** Bug 9465 has been marked as a duplicate of this bug. ***
Comment 23 Venomrush (reporter) 2010-03-09 02:21:30 UTC
*** Bug 9466 has been marked as a duplicate of this bug. ***
Comment 24 Venomrush (reporter) 2010-03-09 02:25:28 UTC
According to bug 9465 & bug 9466, this usability should be fixed for RSS &
MicroB as well.

"Using kinetic scrolling for going through long articles (e.g. maemo bug jars)
or long page (e.g. a bugzilla bug page with lot of messages) takes several
minutes of intensive finger sweeping. It is a real nonsense. Some quicker
scroll method is needed - like Fennec's plug-in called FastestScrollInTheWest"
- Roman Polach
Comment 25 redex 2010-03-16 12:06:01 UTC
Please don't forget. Many N900 models got no up and down key!

When you implement this, please use also the left key for up and the right key
for down when scrolling to left or right is not possible. (in lists at example)

The Image Application and the MicroB Webbrowser got the biggest problems (for
the application Manager a Filter by Name could fix it). At the Images the
Filter options does a good job. Perhaps, for the MicroB Webbrowser this
Brainstorm can give a good workaround:
http://maemo.org/community/brainstorm/view/microb_webbrowser-possibility_to_scroll_fast_in_long_websites/

Personally I would prefer Solution #2. ;-)

But yes, a Systemwide consistent solution would be even better.
Comment 26 Andre Klapper maemo.org 2012-03-24 11:41:30 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )