Bug 6300 - (int-148241) :/ in http:// is converted into an emoticon in some cases
(int-148241)
: :/ in http:// is converted into an emoticon in some cases
Status: VERIFIED FIXED
Product: Chat & Call & SMS
Messaging
: 5.0/(2.2009.51-1)
: All All
: Low minor with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: rtcomm@maemo.org
: im-chat-bugs
: http://›.ws/nokiaflagship
:
:
:
  Show dependency tree
 
Reported: 2009-11-23 17:02 UTC by timeless
Modified: 2010-05-27 15:11 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description timeless (reporter) 2009-11-23 17:02:27 UTC
EXACT STEPS LEADING TO PROBLEM: 
1. configure google talk on your n900
2. add a friend to google talk (i picked tuukka)
3. open the browser on your n900 to this bug
4. copy the url from this bug report
5. if you can't see the url bar, tap the screen and then tap bottom right
corner of your landscape view to show the urlbar
6. paste http://›.ws/nokiaflagship into the urlbar
7. note that it actually appears as expected
8. press <enter> on the hardware keyboard (this is to verify that the url is in
fact valid -- it's IDN)
9. open conversations
10. create a new IM (google talk) to your friend (e.g. tuukka)
11. paste the url
12. press the send button

EXPECTED OUTCOME:
http://›.ws/nokiaflagship should appear in the message area (it does for any
receiving client which isn't an n900)

ACTUAL OUTCOME:
http[FROWNISH-FACE]/›.ws/nokiaflagship

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
enus1 (tuukka tested without this, probably using fifi)
Comment 1 Andre Klapper maemo.org 2009-11-23 20:55:12 UTC
› is U+FE65

My idea was that this is because the parser expects [A-Z][a-z][0-9] directly
behind the http:// to not render emoticons, but http://.example is rendered
correctly without an emoticon.
Comment 2 timeless (reporter) 2009-11-23 22:09:24 UTC
I'd suggest that the parser never turn :// into a face. I don't know how
they've implemented their parser, but it really needs to avoid interfering with
urls.
Comment 3 Mikhail Zabaluev nokia 2009-11-27 14:58:18 UTC
(In reply to comment #1)
> › is U+FE65
> 
> My idea was that this is because the parser expects [A-Z][a-z][0-9] directly
> behind the http:// to not render emoticons, but http://.example is rendered
> correctly without an emoticon.

Correct. The pattern for URL is restricted to non-international DNS syntax.
It'd produce too many false matches if it wasn't.

(In reply to comment #0)
> 6. paste http://›.ws/nokiaflagship into the urlbar

Is this kind of URL any useful?
Comment 4 Mikhail Zabaluev nokia 2009-11-27 18:47:17 UTC
I was too quick to close this bug, it's actually about treating a corner case
in a less weird way. We'll implement this by not recognizing smileys in
something that looks like it may be an URL, but it's not a proper URL so as to
highlight it.
Comment 5 Andre Klapper maemo.org 2009-12-15 17:14:27 UTC
This has been fixed in package rtcom-messaging-ui 1.2.4-1.
Comment 6 Andre Klapper maemo.org 2010-01-14 13:40:45 UTC
(Fix not included in today's 2.2009.51-1 update => updating Version field)
Comment 7 Andre Klapper maemo.org 2010-03-15 20:51:59 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 8 timeless (reporter) 2010-05-27 15:11:47 UTC
verified it isn't making a smiley.