Bug 6286 - liblzo2-2 should be in an Apps / SSU repositories, not Tools
: liblzo2-2 should be in an Apps / SSU repositories, not Tools
Status: CLOSED FIXED
Product: Development platform
Tools
: 5.0-final
: N900 Maemo
: Low enhancement with 2 votes (vote)
: ---
Assigned To: integration
: sdk-tools-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-22 13:48 UTC by AB
Modified: 2011-07-23 00:45 UTC (History)
8 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description AB (reporter) 2009-11-22 13:48:23 UTC
SOFTWARE VERSION:
1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
1. Install openvpn from extras (devel)

EXPECTED OUTCOME:
Package installed

ACTUAL OUTCOME:
Missing liblzo2-2 dependency.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
liblzo2-2 is in the Tools repository, being required for crash-reporter.
Unfortunately, it is also necessary for openvpn and possibly many other
packages. Currently, the only solution is re-uploading liblzo to extras-devel
but this is far from elegant and could create problems in case both
repositories (tools and extras-devel) are enabled.
please consider moving it to the main Apps repository, if not directly on
flash.

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; it; rv:1.9.1.5)
Gecko/20091109 Ubuntu/9.10 (karmic) Firefox/3.5.5
Comment 1 Juha Kallioinen nokia 2009-11-25 12:41:22 UTC
I'm not sure what to feel about this. To me liblzo2 is just like an imaginary
library libfoobar that is needed as a dependency to an imaginary application
barfoo. If a dependency is needed for barfoo, then that dependency should be
found from the same repository where barfoo can be found.

Since liblzo2 is not on the device by default, why should it be in the main
Apps repository? libfoobar certainly isn't going to be there.
Comment 2 AB (reporter) 2009-11-25 12:47:52 UTC
(In reply to comment #1)

> Since liblzo2 is not on the device by default, why should it be in the main
> Apps repository? libfoobar certainly isn't going to be there.

Ok, I'll upload liblzo2-2 to extras-devel and we'll see what happens :-)
I feel it isn't smart to have the very same package in two different
repositories but as long as the dependencies are satisfied I'm ok.
Comment 3 AB (reporter) 2009-11-27 00:34:41 UTC
Here is the build-log:

-x-x-x-
[2009-11-26 23:25:11] Processing package lzo2 2.03-1maemo3. Uploader: aboaboit,
builder: builder1
[2009-11-26 23:25:17] Building lzo2 2.03-1maemo3 for target
'maemo-fremantle-armel-extras-devel'
[2009-11-26 23:55:42] OK
[2009-11-26 23:55:45] ERROR running /etc/buildme.d/check_build: Package lzo2
provides binary package liblzo2-2 which is also available on the device or
Nokia repository. Build of this package has been prevented. 
[2009-11-26 23:55:45] Building lzo2 2.03-1maemo3 for target
'maemo-fremantle-i386-extras-devel'
[2009-11-27 00:20:42] Signing build results
[2009-11-27 00:20:43] lzo2 2.03-1maemo3 has been queued for loading into
fremantle extras-devel repository
[2009-11-27 00:20:44] You can find more info about this build here:
https://garage.maemo.org/builder/fremantle/lzo2_2.03-1maemo3/
-x-x-x-

So... we can't have liblzo2-2 in "Extras" because it is already in the SDK
repository (according to the log above) and  we can't have dependencies in a
different repository (according to policy). Anybody else who thinks this
situation is weird?
Comment 4 Mikko Vartiainen 2009-11-27 02:16:15 UTC
(In reply to comment #3)
> [2009-11-26 23:55:45] ERROR running /etc/buildme.d/check_build: Package lzo2
> provides binary package liblzo2-2 which is also available on the device or
> Nokia repository. Build of this package has been prevented. 

It's because build system thinks that lzo2-2 is still available from
application repository, see http://maemo.org/packages/view/liblzo2-2/. So it's
another bug in autobuilder.
Comment 5 Niels Breet maemo.org 2009-12-07 15:08:44 UTC
I removed the entry in packages for liblzo2-2 in the device firmware
'repository', this was a bug in older pre-release firmware.

liblzo2-2 has also been pushed to extras-testing, so openvpn should be
installable.

Does this fix the issue for you now? Please reopen if there is still a problem.
Comment 6 AB (reporter) 2009-12-08 13:22:20 UTC
(In reply to comment #5)

> Does this fix the issue for you now? Please reopen if there is still a problem.

I forced a removal of openvpn and liblzo2-2, then cleared apt cache, enabled
"testing" instead of "devel", refreshed and tried installing: no go, "unmet
dependencies".
Comment 7 Niels Breet maemo.org 2009-12-08 14:13:04 UTC
This works for me with only extras-testing enabled:


# apt-get -Vsu install openvpn
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
   bash (2.05b-26osso7+0m5)
   liblzo2-2 (2.03-1maemo3)
Suggested packages:
   bash-doc ()
   resolvconf ()
The following NEW packages will be installed:
   bash (2.05b-26osso7+0m5)
   liblzo2-2 (2.03-1maemo3)
   openvpn (2.1~rc20-3maemo3)
0 upgraded, 3 newly installed, 0 to remove and 3 not upgraded.
Inst bash (2.05b-26osso7+0m5 downloads.maemo.nokia.com)
Inst liblzo2-2 (2.03-1maemo3 Extras-testing:fremantle)
Inst openvpn (5:2.1~rc20-3maemo3 Extras-testing:fremantle)
Conf bash (2.05b-26osso7+0m5 downloads.maemo.nokia.com)
Conf liblzo2-2 (2.03-1maemo3 Extras-testing:fremantle)
Conf openvpn (5:2.1~rc20-3maemo3 Extras-testing:fremantle)
Comment 8 AB (reporter) 2009-12-08 15:01:06 UTC
(In reply to comment #7)

> This works for me with only extras-testing enabled:

My sources:
-x-x-x-
Nokia-N900-42-11:~# cat /etc/apt/sources.list.d/hildon-application-manager.list
deb https://downloads.maemo.nokia.com/fremantle/apps/ ./
deb https://downloads.maemo.nokia.com/fremantle/mr0 ./
deb http://repository.maemo.org/extras-testing fremantle free non-free
-x-x-x-

Refreshed, then tried apt-get -Vsu like you did:
-x-x-x-
Nokia-N900-42-11:~# apt-get -Vsu install openvpn
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  openvpn: Depends: liblzo2-2 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a
solution).
-x-x-x-

No errors were reported during the cache refresh, either in the h.a.m. log or
on console for apt-get. Even a direct request for liblzo2-2 gives an error.

Puzzled, very puzzled.
Comment 9 Mikko Vartiainen 2009-12-08 15:39:19 UTC
(In reply to comment #8)
> You might want to run `apt-get -f install' to correct these:

Did you run `apt-get -f install'?
Comment 10 AB (reporter) 2009-12-08 15:52:48 UTC
Hmm, it seems I never properly understood what "apt-get -f" does until now.
I'll go hide in some corner, closing the bug on the way.
Comment 11 Marcell Lengyel maemo.org 2010-03-18 11:12:07 UTC
Closing