Bug 6275 - (int-148187) Alarm played through Nokia BH-102 Bluetooth headset instead of internal speakers
(int-148187)
: Alarm played through Nokia BH-102 Bluetooth headset instead of internal speakers
Status: RESOLVED FIXED
Product: Multimedia
Multimedia framework
: 5.0/(1.2009.42-11)
: N900 Maemo
: Low minor with 14 votes (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: multimedia-framework-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-22 00:18 UTC by Donn Morrison
Modified: 2010-01-18 17:57 UTC (History)
7 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Donn Morrison (reporter) 2009-11-22 00:18:36 UTC
SOFTWARE VERSION:

1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 

1. Pair a Bluetooth headset with the N900 (Status panel > Bluetooth > New ...)
2. Connect the headset to the N900 so sound is played through it (headphones
with microphone icon should appear in the status panel)
3. Open Clock & Alarms (Status panel > Clock & Alarms)
4. Set a new alarm for a minute or so on the future
5. Wait for the alarm to sound

EXPECTED OUTCOME:

Alarm is played through the N900 internal speakers.

ACTUAL OUTCOME:

Alarm is played through the Bluetooth headset.

REPRODUCIBILITY:

always

OTHER COMMENTS:

When headphones are connected through the headphone jack, the alarm is played
through the N900 internal speakers. It makes sense that this behaviour should
be the same for Bluetooth headsets.

I have fallen asleep with my Bluetooth headset connected while listening to a
podcast and did not hear the alarm in the morning because it didn't make any
noise.
Comment 1 Donn Morrison (reporter) 2009-11-22 00:49:54 UTC
I'd just like to add that the N800 and N810 both play the alarm sounds through
the internal speakers, not the BT headset, so this has changed since Maemo 4.1.
Comment 2 Andre Klapper maemo.org 2009-11-24 17:31:42 UTC
Which exact Bluetooth headset is this about?
Comment 3 Donn Morrison (reporter) 2009-11-24 17:37:54 UTC
(In reply to comment #2)
> Which exact Bluetooth headset is this about?

This is the Nokia BH-102:

http://europe.nokia.com/find-products/accessories/all-accessories/headsets/bluetooth-headsets/nokia-bluetooth-headset-bh-102
Comment 4 les_garten 2009-12-01 20:21:28 UTC
The routing of sound when using Bluetooth needs to be augmented.  If I have my
Bluetooth headset activated and don't have my headset on the phone may as well
be turned off.  I will hear no phone calls, no alerts, no alarms.  I've used
Bluetoth with a lot of other phones, they didn't work this way.  I usually hear
my phone ring and pick up the headset.  This is kind of a deal breaker for me. 
I also don't want to lay the phone down at night and not have it wake me up in
the morning since I use it as my alarm clock as well.  It's a minor problem
with a major impact on me.  My Bluetooth Headset was almost $200 and I can't
use it much now.
Comment 5 Johan Compagner 2009-12-03 15:03:27 UTC
i think it should be defined by the app where it wants the sound over.

For example a phone call and playing music should be bluetooth only
but clock alarms or ringing of the phone i want on the normal speakers or on
both

If the N900 gets route navigation i want to be able to tell in the navigation
software where the sound goes over. Because this is really different for
different people (i had this same problem with my E90)
If you have a build in bluetooth car system that goes over the radio speakers
then i guess you want the voice navigation over you bluetooth. But if you just
have an BT headset and i have that connected in my car so that i can take the
calls i dont want the voice navigation over my headset.. because i dont have
that headset in all the time, i have it just on standby for phone calls.
Comment 6 les_garten 2009-12-08 20:42:16 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 Tomas Walch 2009-12-11 15:43:35 UTC
PLEASE FIX THIS! A N900 is _heavy_ and bt headset is essential.

My first Nokia smartphone also had this design error. It was a 6600. It was a
long time ago. Next phone was a 6680 and it worked as expected, so did my
latest, a N73 -- and now Nokia makes a feature revert back to S60v1 times. I
know Maemo is a totally different platform, but this is a requirements issue.
If the phone parts of the N900 don't behave as expected by a modern smartphone
it will never make it, no matter how cool the computer parts are, imho.
Comment 8 Stian Jordet 2009-12-29 01:38:46 UTC
A good fix for this would be an frontend to pulse audio, where the user can
select what sounds to go where. This would also help for the instance where you
have the N900 connected to a car bluetooth handsfree, but still want the
mediaplayer output to go via the fm-transmitter :)
Comment 9 John Perez 2010-01-14 21:21:49 UTC
Seems to be fixed as of version 2.2009.51-1.002

May be related to:

Pulseaudio: Ringtone is heard from the loudspeaker if BT connected.
Comment 10 maemo 2010-01-18 16:54:37 UTC
Confirm fixed in 51.1 . Both alarms and ringing sound from both BT headset and
handset for me now.  Maybe we should tell the folks at Nokia?
Comment 11 Andre Klapper maemo.org 2010-01-18 17:57:51 UTC
Thanks for retesting! Closing as fixed.