Bug 6269 - (int-137861) Can't reuse the name of a bookmark that has been deleted
(int-137861)
: Can't reuse the name of a bookmark that has been deleted
Status: VERIFIED FIXED
Product: Browser
Bookmarks
: 5.0/(2.2009.51-1)
: All Linux
: Low normal with 3 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: Nagineni Sudarsana Babu
: browser-bookmarks-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-21 16:51 UTC by Alberto Garcia Gonzalez
Modified: 2010-06-07 20:25 UTC (History)
3 users (show)

See Also:


Attachments
Bookmarks file (9.36 KB, text/plain)
2009-11-21 16:59 UTC, Alberto Garcia Gonzalez
Details
"Ovi Store" present 5 times, one entry is deleted, the other 4 are not. None show up in Bookmarks. (7.33 KB, text/plain)
2010-01-19 03:23 UTC, Neil MacLeod
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Alberto Garcia Gonzalez (reporter) 2009-11-21 16:51:34 UTC
SOFTWARE VERSION:
42-11 (upgraded from 41-10)

EXACT STEPS LEADING TO PROBLEM:
1. Use the bookmarks file that I'm attaching
2. Open Facebook in the web browser (http://lite.facebook.com/)
3. Click on the '+' button to add a new bookmark
4. Reboot the device
5. Open the web app and observe the bookmark list

EXPECTED OUTCOME:
The Facebook bookmark is still there

ACTUAL OUTCOME:
The Facebook bookmark has disappeared

REPRODUCIBILITY:
always, but bookmarks other than Facebook appear to work fine

OTHER COMMENTS:
I'm attaching my bookmarks file (~/.bookmarks/MyBookmarks.xml)
Comment 1 Alberto Garcia Gonzalez (reporter) 2009-11-21 16:59:21 UTC
Created an attachment (id=1610) [details]
Bookmarks file

Here's my bookmarks file.

This looks like a problem parsing the XML file. As you can see, the
Facebook bookmark is present many times, but it never appears in the
application.

When I try to add it again, it appears for some time but after a few
hours or a reboot it disappears again.

One hint that may help to trace this problem: initially there was a
bookmark to http://facebook.com/ (I don't remember if it came by
default or if I added it myself), but then I wanted to replace it with
http://lite.facebook.com/

Probably at that point I had two different bookmarks with the same
name, and then I deleted the first one.
Comment 2 Alberto Garcia Gonzalez (reporter) 2009-11-21 17:05:43 UTC
(In reply to comment #1)
> Probably at that point I had two different bookmarks with the same
> name, and then I deleted the first one.

I've just deleted the first Facebook bookmark (the one pointing to
http://facebook.com/ and marked with <deleted>1</deleted>) and after
killing the browser the other Facebook bookmark finally appears.
Comment 3 Alberto Garcia Gonzalez (reporter) 2009-11-21 17:23:10 UTC
Okay, I've just renamed my "Google" bookmark to "Google Search". If
you look at my XML file you'll see that there was already a "Google
Search" bookmark but it is marked as deleted.

After restarting the browser it disappears.

So the correct name for this is:

"Can't reuse the name of a bookmark that has been deleted"

I'm updating the bug summary.
Comment 4 timeless 2009-11-21 22:59:25 UTC
oh. so....

i think the reason this feature exists is probably for 'operator bookmarks'.

basically if it were the case that an operator decided to force a bookmark on
you, we wanted to have a way for you to delete the bookmark. if we simply
remove the bookmark from the file, then if the operator bookmarks are updated,
the bookmark will be resurrected, and you'd be annoyed. (yes, you didn't buy an
operator sponsored device, someday we were hoping someone might.)

pretty much all of these things are no win states.

because of the way bookmarks have to work, we had to store deletions.

obviously the behavior you experienced sucks.

I think this is fixable by special casing adding a bookmark to remove the
deleted bookmark entry.
Comment 5 Andre Klapper maemo.org 2009-12-15 17:13:06 UTC
This has been fixed in package
osso-bookmark-engine 2:1.2.9-1.1+0m5
which is part of the internal build version
2009.50-7
(Note that 2009 is the year and the number after is the week.)

A future public update released with or after this build version will include
the fix. Please verify that the new version fixes the bug by marking this bug
report as VERIFIED after the public update has been released and if you have
some time. Note that Nokia does not announce release dates of public updates in
advance.
Comment 6 Neil MacLeod maemo.org 2010-01-19 03:23:02 UTC
Created an attachment (id=2040) [details]
"Ovi Store" present 5 times, one entry is deleted, the other 4 are not. None
show up in Bookmarks.

Andre, can you confirm what kind of fix made it into 2.2009.51-1, because I've
updated "Ovi Store" (store.ovi.mobi) about half a dozen times now, and each
time it disappears some time later. I think this bug needs to be reopened as
however it has been "fixed", it hasn't been fixed "properly".

I've attached my current ~/.bookmarks/MyBookmarks.xml, and within it I can see
that the original "Ovi Store" (http://link.ovi.mobi/n900ovistore, an operator
bookmark) is marked as deleted.

However I have now found myself in the situation where I can successfully add a
new "Ovi Store" bookmark (for store.ovi.mobi) which will remain visible in
Bookmarks for a while and thenk, at some point in the future, it will just
disappear (not sure what causes this, possibly terminating browserd).

So I add the "Ovi Store" bookmark again, and again - because you know, it's an
appropriate name for the Ovi Store bookmark - and now I have 4 instances of my
non-operator bookmark "Ovi Store", plus the original (deleted) "Ovi Store"!

And NONE of them are visible in Bookmarks!! :)

This needs fixing properly, because this is just an annoying heap of badly
designed nastiness.
Comment 7 Alberto Garcia Gonzalez (reporter) 2010-01-19 14:01:23 UTC
(In reply to comment #6)
> Andre, can you confirm what kind of fix made it into 2.2009.51-1

> This needs fixing properly, because this is just an annoying heap of
> badly designed nastiness.

Note that the fixed version has not been publicly released yet.

The 2009.51-1 release comes with osso-bookmark-engine 1.2.7-6
Comment 8 Neil MacLeod maemo.org 2010-01-19 14:27:41 UTC
(In reply to comment #7)
> Note that the fixed version has not been publicly released yet.
> 
> The 2009.51-1 release comes with osso-bookmark-engine 1.2.7-6
> 

Thanks Alberto, that would explain why this bug is still present in 51-1.

However Andre's comment 5 suggests it should have been included in any build
later than 50-7 - that may need to be checked (ie. why the most recent
osso-bookmark-engine didn't make it into 51-1, build process problem?)
Comment 9 timeless 2010-01-19 14:35:44 UTC
ah sorry. build numbers are random and should not be assumed to be
chronological. what ends up in your hands as a customer is what management
approves, which for reasons which are too complicated to describe or understand
can easily exclude something which someone thought was ready.
Comment 10 Andre Klapper maemo.org 2010-03-15 20:51:15 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 11 Alberto Garcia Gonzalez (reporter) 2010-06-07 20:25:14 UTC
Works fine now, verifying bug