Bug 6251 - Mail client is not usable with large inboxes
: Mail client is not usable with large inboxes
Status: RESOLVED DUPLICATE of bug 3762
Product: Email
General
: 5.0/(1.2009.42-11)
: N900 Maemo
: Low normal (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-19 11:57 UTC by Martin Grimme
Modified: 2009-11-19 12:43 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Martin Grimme (reporter) 2009-11-19 11:57:07 UTC
A typical Google Mail account has thousands of mails in its INBOX due to the
philosophy of Google Mail to not having to delete mails, ever.
Modest cannot handle this situation.

SOFTWARE VERSION:
OS 2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
Open an inbox folder with thousands of mails.
In my case of almost 8000 mails in the inbox, the Modest went off to download
11 megabytes of headers, not displaying any progress while downloading. After
several minutes with high CPU load (poor battery), the items in the inbox where
shown. Any attempt to scroll that list, however, resulted in Modest becoming
totally unresponsive with high CPU load, making me quit the application
forcefully. Due to this the inbox is not actually accessible.


EXPECTED OUTCOME:
First bunch of latest headers gets loaded within seconds, and presented to the
user. If the user scrolls down to the end of the list the next bunch gets
loaded, instead of listing all these thousands of headers at once.


ACTUAL OUTCOME:
Modest takes several minutes to load all headers at once, causing lots of
internet traffic, and falling into an unresponsive state with high CPU load.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
doesn't matter
Comment 1 Lucas Maneos 2009-11-19 12:43:01 UTC
Thanks for the bug report.  This particular issue has been reported before, see
bug 3762 which is FIXED (although not released yet) pretty much as you
describe.

*** This bug has been marked as a duplicate of bug 3762 ***