Bug 6233 - (int-155502) HildonPickerButton opens HildonPickerDialog dialog in landscape mode
(int-155502)
: HildonPickerButton opens HildonPickerDialog dialog in landscape mode
Status: RESOLVED FIXED
Product: Desktop platform
hildon-widgets
: 5.0/(3.2010.02-8)
: All Linux
: Low normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: Alberto Garcia Gonzalez
: hildon-libs-bugs
:
: patch
:
:
  Show dependency tree
 
Reported: 2009-11-18 10:42 UTC by mike morrison
Modified: 2010-03-15 20:54 UTC (History)
2 users (show)

See Also:


Attachments
Test case (2.79 KB, text/plain)
2010-02-03 13:08 UTC, Alberto Garcia Gonzalez
Details
Patch to add portrait support for HildonPickerDialog (565 bytes, patch)
2010-02-03 13:11 UTC, Alberto Garcia Gonzalez
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description mike morrison (reporter) 2009-11-18 10:42:54 UTC
SOFTWARE VERSION:
5.0 Final SDK

STEPS TO REPRODUCE THE PROBLEM:
1. create a program that has the HILDON_PORTRAIT_MODE_REQUEST and
HILDON_PORTRAIT_MODE_SUPPORT set on the hildon window
2. in the program set up a HildonPickerButton as in Example 7. of the
HildonPickerButton documentation.
3. compile and run the program in scratchbox
4. click on the HildonPickerButton


EXPECTED OUTCOME:
HildonPickerDialog opens in portrait mode

ACTUAL OUTCOME:
HildonPickerDialog switches screen to landscape mode


REPRODUCIBILITY:
always

OTHER COMMENTS:
This is just in scratchbox. I haven't tested this on the actual device. Maybe
there is a flag or setting somewhere that i'm missing? Other dialogs that I
create myself do stay in portrait mode.
Comment 1 Andre Klapper maemo.org 2009-11-18 15:53:42 UTC
(In reply to comment #0)
> 2. in the program set up a HildonPickerButton as in Example 7. of the
> HildonPickerButton documentation.

URL highly welcome, also a small testcase.
For general information see
http://wiki.maemo.org/Using_Fremantle_Widgets#Portrait_Mode .

I can imagine that this is not a bug but an enhancement request in case this is
simply not supported.
Comment 2 mike morrison (reporter) 2009-11-19 10:42:08 UTC
i did a bit more testing and found that this behavior only happens when the
HildonPickerButton is added to a HildonAppMenu. if i just add the button to the
main app window, the HildonPickerDialog opens like it should in portrait mode.
unfortunately i don't want the button in my main window.

so add a step 2.5 to my "steps to reproduce":

2.5. add the HildonPickerButton to the HildonAppMenu
Comment 3 Alberto Garcia Gonzalez 2010-02-03 11:43:38 UTC
Assigning to me
Comment 4 Alberto Garcia Gonzalez 2010-02-03 13:08:49 UTC
Created an attachment (id=2204) [details]
Test case
Comment 5 Alberto Garcia Gonzalez 2010-02-03 13:09:13 UTC
Confirmed, here's a test case
Comment 6 Alberto Garcia Gonzalez 2010-02-03 13:11:12 UTC
Created an attachment (id=2205) [details]
Patch to add portrait support for HildonPickerDialog

And here's the patch that fixes the problem
Comment 7 Alberto Garcia Gonzalez 2010-02-10 13:13:27 UTC
Patch committed:

http://maemo.gitorious.org/hildon/hildon/commit/756990da430b2bb8e0a54edf7597e1c913c11c75
Comment 8 Alberto Garcia Gonzalez 2010-02-18 11:14:47 UTC
This has been fixed internally and it will be available in a future release.

Thanks for reporting the problem
Comment 9 Andre Klapper maemo.org 2010-02-18 17:40:02 UTC
This has been fixed in package
libhildon 2.2.13-1+0m5
which is part of the internal build version
10.2010.07-6
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 10 Andre Klapper maemo.org 2010-03-15 20:54:07 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).