Bug 6219 - (int-148600) Modest doesn't take care of preferences for automatic update
(int-148600)
: Modest doesn't take care of preferences for automatic update
Status: VERIFIED FIXED
Product: Email
General
: 5.0/(1.2009.42-11)
: N900 Maemo
: Medium major with 3 votes (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-17 10:56 UTC by Benoît HERVIER
Modified: 2010-02-03 14:08 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Benoît HERVIER (reporter) 2009-11-17 10:56:02 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM:
Set auto update in Modest's parameters for Local Wifi Network only
Connect to the internet mobile connection (3G, or edge)

EXPECTED OUTCOME:
Modest keep quiet and doesn't try to update

ACTUAL OUTCOME:
Modest try to update, say that it cannot update (due to isp blocking imap), and
show windows account parameters.

REPRODUCIBILITY:
Everytime the tablet lost the connection, and reconnect on the mobile network

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.1.5)
Gecko/20091102 Firefox 3.5.3
Comment 1 Benoît HERVIER (reporter) 2009-11-17 11:14:33 UTC
It was working in firmware release 2009.41-10
Comment 2 Benoît HERVIER (reporter) 2009-11-17 20:11:34 UTC
Change priority as it s relly annoying
Comment 3 Andre Klapper maemo.org 2009-11-18 00:24:21 UTC
> STEPS TO REPRODUCE THE PROBLEM:
Please ALWAYS provide exact steps, click by click. Thanks!

Modest > Settings > Update automatically > Update when connected via: WLAN
Comment 4 Andre Klapper maemo.org 2009-11-26 20:49:11 UTC
> (due to isp blocking imap)

I need a mobile provider that blocks IMAP to reproduce this. :-P

Can you say which exact ISP this is about, please?

(Note to myself: This does not seem to be int-136358.)
Comment 5 Andre Klapper maemo.org 2009-11-27 19:06:35 UTC
This has been already fixed internally in the last weeks.
There was a problem in tinymail when switching connections.

Not exactly clear which release version the fix is included in, but it should
definitely be in a week48 release, most likely way earlier.

Any public update released with or after this week will include the fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 6 Andre Klapper maemo.org 2010-01-05 15:29:51 UTC
*** Bug 7664 has been marked as a duplicate of this bug. ***
Comment 7 Andre Klapper maemo.org 2010-01-14 12:28:21 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 8 Andre Klapper maemo.org 2010-01-19 16:39:10 UTC
A confirmation whether this works now in 2.2009.51-1 is highly welcome.
Comment 9 Benoît HERVIER (reporter) 2010-01-19 16:49:42 UTC
(In reply to comment #8)
> A confirmation whether this works now in 2.2009.51-1 is highly welcome.

Thx for remind me.
Works for me. I change the status to Verified.
Comment 10 Yves DESSERTINE 2010-01-19 16:51:19 UTC
*** Bug 8264 has been marked as a duplicate of this bug. ***
Comment 11 Yves DESSERTINE 2010-01-19 16:52:24 UTC
Can we reopen this bug?
Comment 12 Yves DESSERTINE 2010-01-19 16:52:40 UTC
*** This bug has been confirmed by popular vote. ***
Comment 13 Andre Klapper maemo.org 2010-02-03 14:08:25 UTC
Please note that this still does not always work correctly in 2.2009.51-1 - see
bug 6898 about it, as it is a different issue (codewise) than this report here.