Bug 6215 - Browser window redraws unnecessarily in task view when text entry widget has focus
: Browser window redraws unnecessarily in task view when text entry widget has ...
Status: RESOLVED DUPLICATE of bug 6669
Product: Browser
User interface
: 5.0/(1.2009.42-11)
: N900 Maemo
: Low minor (vote)
: ---
Assigned To: unassigned
: browser-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-17 00:06 UTC by Donn Morrison
Modified: 2009-12-14 17:06 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Donn Morrison (reporter) 2009-11-17 00:06:11 UTC
SOFTWARE VERSION:

1.2009.42-11

STEPS TO REPRODUCE THE PROBLEM:

1. Open the browser (Applications > Web)
2. Open a website that has a text entry widget (Google, Wikipedia, etc.)
3. Give the text entry widget focus by tapping on it so that the cursor appears
4. Switch to another application or the desktop using the task switcher
5. Activate the task switcher again from the other application
6. Repeat steps 4-5, switching between the application (not the browser) and
the task view

EXPECTED OUTCOME:

Windows in the task view shouldn't redraw unnecessarily.

ACTUAL OUTCOME:

The browser window is visibly redrawn each time the task view is activated.

REPRODUCIBILITY:

always (when a text entry widget has focus in the browser)
Comment 1 Andre Klapper maemo.org 2009-11-18 00:15:54 UTC
Thanks for reporting.

At least with the Google page that's listed in the default bookmarks I cannot
reproduce this in 2.2009.46-16.
Maybe already fixed, but could not find an internal ticket.

Would be great to get another non-/confirmation by a second user.

Also wondering whether this is a Browser issue or a Desktop/Application
Switcher issue...
Comment 2 mike morrison 2009-11-18 00:35:26 UTC
i was able to reproduce this as well. when the dashboard comes up you can see
the grid lines in the browser for a short time before the page is redrawn.
Comment 3 hqh 2009-12-08 18:12:33 UTC
(In reply to comment #1)
> Would be great to get another non-/confirmation by a second user.

Reproducible in 1.2009.42-11
Comment 4 Andre Klapper maemo.org 2009-12-14 17:06:31 UTC
This is covered by bug 6669.

*** This bug has been marked as a duplicate of bug 6669 ***