Bug 6201 - (int-148603) libnice violates Debian packaging policy for description of package "libnice0"
(int-148603)
: libnice violates Debian packaging policy for description of package "libnice0"
Status: RESOLVED FIXED
Product: Chat & Call & SMS
General
: 5.0/(2.2009.51-1)
: All All
: Low normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: rtcomm@maemo.org
: communication-bugs
: http://mxr.maemo.org/fremantle/source...
:
:
:
  Show dependency tree
 
Reported: 2009-11-15 23:03 UTC by timeless
Modified: 2010-03-15 20:51 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description timeless (reporter) 2009-11-15 23:03:28 UTC
http://www.debian.org/doc/debian-policy/ch-binary.html#s-synopsis
3.4.1 The single line synopsis

The single line synopsis should be kept brief - certainly under 80 characters.

Do not include the package name in the synopsis line. The display software
knows how to display this already, and you do not need to state it. Remember
that in many situations the user may only see the synopsis line - make it as
informative as you can. 

13 Package: libnice0
14 Section: libs
15 Architecture: any
16 Depends: ${shlibs:Depends}, ${misc:Depends}
17 Description: libnice
Comment 1 Andre Klapper maemo.org 2009-11-17 21:49:24 UTC
Upstream GIT at
http://git.collabora.co.uk/?p=libnice.git;a=blob;f=nice/nice.pc.in says
"Description: ICE library".

http://packages.debian.org/unstable/libnice0 also says "ICE library".
Looks like this is really an issue on the Maemo level.
Comment 2 Andre Klapper maemo.org 2009-12-30 20:48:22 UTC
Fixed in PR1.1.
Comment 3 Yves-Alexis 2010-01-14 12:09:21 UTC
It doesn't look fixed, just after updating to 2.2009.51-1.
Comment 4 Andre Klapper maemo.org 2010-01-14 12:28:38 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 5 Yves-Alexis 2010-01-14 14:00:41 UTC
(In reply to comment #4)
> The problem reported here should be fixed in the update released today for
> public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
> Please leave a comment if the problem is not fixed for you in this update
> version.
> 

As said above, it is _not_ fixed.

Cheers,
--
Yves-Alexis
Comment 6 Andre Klapper maemo.org 2010-01-14 14:02:45 UTC
Sorry, the internal comment
"The description was already fixed in the last release in fremantle."
was a bit "interpretable". So the master branch was meant, while at that time I
thought that the PR1.1 branch was meant...

Updating Target Milestone and Version.

Thanks for rechecking!
Comment 7 Andre Klapper maemo.org 2010-03-15 20:51:57 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).