Bug 6184 - (int-132419) Find on page causes page to reload
(int-132419)
: Find on page causes page to reload
Status: RESOLVED FIXED
Product: Browser
User interface
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low minor with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: browser-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-15 12:37 UTC by Donn Morrison
Modified: 2010-03-15 20:51 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Donn Morrison (reporter) 2009-11-15 12:37:53 UTC
SOFTWARE VERSION:

1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:

1. Open Browser (Applications > Web)
2. Load Wikipedia by tying (http://en.wikipedia.org/wiki/Main_Page)
3. Once page has loaded, press CTRL-F to find on page
4. Knowingly enter a search string that won't exist ("asdfasdfasdfasdf")
5. Press Enter on the keyboard

EXPECTED OUTCOME:

A banner is displayed saying the search term was not found, but the page should
not reload.

ACTUAL OUTCOME:

A banner is displayed saying the search term was not found, and the current
page reloads.

REPRODUCIBILITY:

always (on Wikipedia)

OTHER COMMENTS:

The page is actually being reloaded because the toolbar and address bar become
visible and the progress bar shows that the page is loading.

I've tried a few other websites (Google, bugs.maemo.org), and they do not seem
affected. Perhaps it is specific to Wikipedia.

If you enter a search term that does exist (Step 4), the search will eventually
wrap around to the top of the page (by user pressing Enter each time), and once
it wraps the page will be reloaded.
Comment 1 Lucas Maneos 2009-11-15 17:20:11 UTC
Reproduced also with other wikipedia pages, except that it doesn't reload the
already open page but /wiki/Main_Page.  Also happens with search strings that
do exist on the page (after the last match is found).
Comment 2 Andre Klapper maemo.org 2010-01-22 13:07:22 UTC
This has been fixed in the internal build version
2010.03-4
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 3 Andre Klapper maemo.org 2010-03-15 20:51:14 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).