Bug 6177 - (int-148489) Consider pushing sharing-dialog-dev to nokia-binaries to encourage developer usage of sharing dialog
(int-148489)
: Consider pushing sharing-dialog-dev to nokia-binaries to encourage developer ...
Status: RESOLVED FIXED
Product: Development platform
SDK
: 5.0-final
: All Linux
: Medium enhancement with 6 votes (vote)
: 5.0-update3
Assigned To: Soumya
: sdk-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-14 20:12 UTC by Carsten Munk
Modified: 2010-01-15 14:00 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Carsten Munk (reporter) maemo.org 2009-11-14 20:12:38 UTC
The sharing dialog, seen on
http://qwerty12.qole.org/Screenshot-20091114-175354.png is implemented in a lot
of Nokia applications but 3rd party applications have no way to use this
dialog. This is contradictive as sharing plugins can be written by 3rd party
developers but not used by 3rd party developers.

As sharing-dialog is already in nokia-binaries in SDK, consider pushing
sharing-dialog-dev to nokia-binaries to encourage 3rd party developers to
develop -and- use sharing plugins in their applications.

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.14)
Gecko/2009090216 Ubuntu/9.04 (jaunty) Firefox/3.0.14
Comment 1 Faheem Pervez maemo.org 2009-11-14 20:16:26 UTC
http://qwerty12.qole.org/Screenshot-20091114-175354.png is, BTW, done by
dlopen()ing libsharingdialog.0.0 so it can be done using dubious methods. So,
really, by not releasing the headers, you are just putting yourselves [Nokia]
in a bad light.
Comment 2 Faheem Pervez maemo.org 2009-11-14 23:17:20 UTC
No good having a screenshot if I can't back it up with code:
http://qwerty12.qole.org/sharing-dialog-example.c
Comment 3 Andre Klapper maemo.org 2009-11-30 19:58:27 UTC
This is currently considered. (Note to myself: int-132261#c18)
Comment 4 Alexander Bokovoy 2009-12-07 15:33:54 UTC
This bug is fixed internally by including sharing-dialog-dev into next update.
Please see int-148489 for details, if you can (Andre, I can't update Alias
field myself). Soumya, please do not forget to add this package in the next SDK
update. :)

Faheem and Carsten, once updated SDK is available, could you please rebuild
your code with it? The we could consider this bug solved.
Comment 5 Andre Klapper maemo.org 2009-12-07 16:12:22 UTC
(In reply to comment #4)
> (Andre, I can't update Alias field myself).

Now you should be able to. :)
Comment 6 Andre Klapper maemo.org 2010-01-14 12:32:53 UTC
Today Nokia released the Maemo5 update version 2.2009.51-1 for public (also
called "PR1.1" sometimes).
If you have some time we kindly ask you to test again if the problem reported
here still happens in this new version - just leave a comment (and feel free to
update the "Version" field to the new version if it's still a problem).
Comment 7 Faheem Pervez maemo.org 2010-01-15 09:23:46 UTC
This bug should be closed.

Thanks to all involved - sharing-dialog-dev is now, indeed, in the Nokia
Binaries repository and I can confirm that it is the "real deal".
I won't be updating Petrovich, however, due to #5300 being fixed and the
Extras-devel importer being down.