Bug 6171 - Cannot establish received call via SIP with Google Voice
: Cannot establish received call via SIP with Google Voice
Status: RESOLVED DUPLICATE of bug 5505
Product: Chat & Call & SMS
SIP
: 5.0/(1.2009.41-10)
: All Maemo
: Low normal (vote)
: ---
Assigned To: rtcomm@maemo.org
: sip-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2009-11-14 00:40 UTC by kimitake
Modified: 2009-11-18 14:01 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description kimitake (reporter) 2009-11-14 00:40:17 UTC
SOFTWARE VERSION:
2009.42-11

STEPS TO REPRODUCE THE PROBLEM:
preparation:
- obtain gizmo5 account
- obtain google voice account
- register gizmo5 SIP number to Google voice
- register gizmo5 SIP account as N900's VoIP SIP account
Note: SIP account should be set as GizmoID@proxy01.sipphone.com on N900
GizmoID is your gizmo5 account, and make sure the VoIP is enabled

steps to reproduce:
- call Google voice number, so it rings gizmo5 SIP number
- N900 will get the call and Phone app will be displayed
- receive the call

EXPECTED OUTCOME:
Google voice requires pushing number 1 to establish the calll, so need to show
dial pad, and click number 1 button, and then become to be able to use.

ACTUAL OUTCOME:
can show dial pad, but before pushing 1 button, Google Voice goes to voice
mail, so missing the call.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
n/a

OTHER COMMENTS:
If I call mobile phone # instead of SIP via Google voice, I can establish the
call. So when receiving the call via SIP, dial pad may not work.

When calling to somewhere from Google voice and selecting SIP as caller, Google
voice calls SIP at first, and then call receiver. In this case, I don't need to
push number 1 button, so I can call somewhere.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US)
AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.32 Safari/532.0
Comment 1 Lucas Maneos 2009-11-14 11:13:44 UTC
Thanks for the bug report.  Your problem is caused by DTMF not being sent (bug
5505), which is fixed internally but not yet released.

*** This bug has been marked as a duplicate of bug 5505 ***
Comment 2 Mikhail Zabaluev nokia 2009-11-17 17:05:36 UTC
Wait, this one is different: the user doesn't even have a chance to use DTMF
before the call is routed elsewhere.

I suspect the real problem is in SIPphone connection. Please open your SIP
account settings and make sure the transport is set to UDP.
Please also fill in the STUN server (uncheck the autodetect checkbox) to e.g.
"stun01.sipphone.com".
Please report if the problem persists with these settings.
Comment 3 kimitake (reporter) 2009-11-17 23:34:24 UTC
(In reply to comment #2)
> Wait, this one is different: the user doesn't even have a chance to use DTMF
> before the call is routed elsewhere.
I think this bug is same as bug 5505.
In my case, Google Voice server calls my SIP number and
I can connect to the service first.
The server requires "1" button pushing, it means I need send DTMF tone.

And if the service gets the tone, it calls the peer.

But I cannot send the DTMF tone to the Google Voice service,
so it does not call the peer and goes to voice mail instead.

> I suspect the real problem is in SIPphone connection. Please open your SIP
> account settings and make sure the transport is set to UDP.
> Please also fill in the STUN server (uncheck the autodetect checkbox) to e.g.
> "stun01.sipphone.com".
> Please report if the problem persists with these settings.
I just tried to change the STUN server but it is same.
Comment 4 Mikhail Zabaluev nokia 2009-11-18 14:01:14 UTC
(In reply to comment #3)
> I think this bug is same as bug 5505.

As you say; thanks for clarifying. Feel free to reopen this bug if the fix to
bug #5505 does not solve your problem.

*** This bug has been marked as a duplicate of bug 5505 ***