Bug 6140 - MfE synchronizes data with server after initial setup fails and is canceled
: MfE synchronizes data with server after initial setup fails and is canceled
Status: RESOLVED WORKSFORME
Product: Synchronization
Mail for Exchange
: 5.0/(1.2009.41-10)
: N900 Maemo
: Low enhancement with 4 votes (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: activesync-bugs
:
: moreinfo
: 6343
:
  Show dependency tree
 
Reported: 2009-11-12 17:17 UTC by Stephen Gadsby
Modified: 2010-09-27 13:01 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Stephen Gadsby (reporter) maemo.org 2009-11-12 17:17:04 UTC
SOFTWARE VERSION:
Maemo 5 1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
Note: I suspect the actual end problem depends specifically on any given
setting below, but I'm providing the exact settings I've used on my N900 in
case it helps determine the problem.

1. Launch "Settings".
2. Tap "Mail for Exchange".
3. In the Mail for Exchange wizard that opens, tap "Next".
4. In the "Credentials" step of the wizard:
     a. In the "E-mail address" field, enter a valid GMail username.
(user@gmail.com)
     b. In the "User name" field, enter the same valid GMail username as in
step "a" above.
     c. In the "Password" field, enter the valid password for the GMail account
used in steps "a" and "b".
     d. Leave the "Domain" field blank.
     e. Tap the "Next" button.
5. In the "Server settings" step of the wizard:
     a. In the "Server" field, enter "m.google.com".
     b. Leave the "Port" field set to "443".
     c. Leave "Secure connection" checked.
     d. Tap the "Next" button.
6. In the "Synchronization content" stop of the wizard:
     a. Uncheck "Synchronize e-mail".
     b. Leave "Synchronize calendar and tasks" checked.
     c. Leave "Synchronize contacts" checked.
     d. Leave "First synchronization" set to "Keep items on device".
     e. Tap the "Next" button.
7. A message warning against using both PC Suite and Mail for Exchange will
appear. Tap it to dismiss it.
8. In the "Start synchronization" step of the wizard:
     a. Tap the "Advanced settings" button.
     b. In the "Mail for Exchange settings" dialog that opens:
          i. Leave "Peak start time" set to "08:00".
          ii. Leave "Peak end time" set to "16:00".
          iii. Leave "Peak days" set to "Mon, Tue, Web, Thu, Fri".
          iv. Set "Peak schedule" to "Every 4 hours".
          v. Set "Off-peak schedule" to "Every 12 hours".
          vi. Leave all other settings as they are.
          vii. Tap the "Save" button.
     c. Tap the "Next" button.
9. The wizard will move to the "First synchronization" step. Wait as Mail for
Exchange works on synchronizing data. In my case:
     a. The "Initializing synchronization..." progress bar fills quickly.
     b. The "Calendar and tasks" progress bar fills very quickly until just
before the bar is filled. Mail for Exchange sits processing with the final,
thin sliver of the progress bar unfilled for several minutes. Then the bar
finally fills.
     c. The "Contacts" progress bar fills to approximately 40% quickly and then
stops. Mail for Exchange sits for several more minutes.
     d. Finally, a yellow banner briefly appears to report the Exchange server
is not responding.
10. The only available control within Mail for Exchange is the "Previous"
button. Optionally, you may use it to back up, adjust settings, and retry the
process, but this does not avoid the error.
11. Tap outside the "Mail for Exchange" wizard.
12. A dialog will appear. The text within it reads: "Cancel initial
synchronization? Account setup will be lost." Tap the "Yes" button to dismiss
the dialog and quit the Mail for Exchange wizard.
13. Wait several hours.

EXPECTED OUTCOME:
As the Mail for Exchange wizard was canceled, and account setup was said to be
lost, no synchronization with Google should take place.

ACTUAL OUTCOME:
Calendar and contact data on the N900 is synchronized with Google.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
I'm not disappointed that my data is being synchronized. After all, that was my
goal. However, the "Account setup will be lost" warning is clearly wrong.
Either the warning should be changed or account setup data should truly be
cleared upon the wizard being canceled.

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US;
rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Comment 1 Andre Klapper maemo.org 2009-11-13 16:59:30 UTC
Sounds a bit similar to bug 5597. Not sure if it's the same issue though.
Comment 2 Stephen Gadsby (reporter) maemo.org 2009-11-13 18:44:35 UTC
(In reply to comment #1)
> Sounds a bit similar to bug 5597. Not sure if it's the same issue though.

Hmm. Yes, this may be duplicate, depending upon how you see issues being split.
Both bugs say "Initial sync always fails." The difference between the bugs then
becomes:
- 5597 is saying, "Make initial sync work!" (I fully support that, by the way.)
- 6140 is saying, "If the initial sync fails and you tell the user canceling
will discard the sync configuration info, then you can't go saving the
configuration info and using it. Either discard the info as you said you would
or change the text of the cancel dialog to be truthful."
Comment 3 Kyle Cronan 2009-11-24 04:55:36 UTC
To the original reporter: Do you have an MfE profile created after this
happens?  Ie, you can go back into the settings and it shows you the account
info you previously entered?  When I try to set up MfE with Google Sync the
initial sync always fails for me too, but the message saying that the account
data will be discarded is accurate in my case.

(In reply to comment #2)
> Hmm. Yes, this may be duplicate, depending upon how you see issues being split.
> Both bugs say "Initial sync always fails." The difference between the bugs then
> becomes:
> - 5597 is saying, "Make initial sync work!" (I fully support that, by the way.)
> - 6140 is saying, "If the initial sync fails and you tell the user canceling
> will discard the sync configuration info, then you can't go saving the
> configuration info and using it. Either discard the info as you said you would
> or change the text of the cancel dialog to be truthful."

Is 5597 just for problems with Exchange 2003 or does it apply to the problems
with Google also?  I assume that Google has made their own ActiveSync
implementation, although perhaps it is being affected by the same bug as
Exchange 2003.
Comment 4 Stephen Gadsby (reporter) maemo.org 2009-11-24 05:15:20 UTC
(In reply to comment #3)
> To the original reporter: Do you have an MfE profile created after this
> happens?  Ie, you can go back into the settings and it shows you the account
> info you previously entered?

No. Anytime I hit Mail for Exchange from Settings, it's as though I'm doing so
for the first time. I'm led through the first time setup wizard again, and none
of the fields are prefilled from previous times through.

MfE is syncing all the same.
Comment 5 Kyle Cronan 2009-11-24 05:38:16 UTC
(In reply to comment #4)
> 
> No. Anytime I hit Mail for Exchange from Settings, it's as though I'm doing so
> for the first time. I'm led through the first time setup wizard again, and none
> of the fields are prefilled from previous times through.
> 
> MfE is syncing all the same.
> 

Weird.  What happens if you try to sync email also?  Does it pretend to fail
but then still make a new mailbox for you in the email app?

I was able to get my initial sync to complete successfully once, but only by
choosing to sync just the calendar (which only had 6 items on it).  I was then
able to go into the settings and add the email sync option.  It ran the sync
again after the settings change and then a new mailbox appeared for me.  But
when I sent myself a test message it didn't work.  I got a notification for the
new email (which was empty) but then received an error message from the email
app saying that it couldn't retrieve the message from the server.
Comment 6 Stephen Gadsby (reporter) maemo.org 2009-11-24 15:46:41 UTC
(In reply to comment #5)
> Weird.  What happens if you try to sync email also?

I haven't tried MfE for email. Google's setup instructions indicate their
servers don't support email syncing, and I'm happy with IMAP for that in any
case.
Comment 7 Kyle Cronan 2009-11-25 00:31:30 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > Weird.  What happens if you try to sync email also?
> 
> I haven't tried MfE for email. Google's setup instructions indicate their
> servers don't support email syncing, and I'm happy with IMAP for that in any
> case.

They say that?  Are you sure you're not thinking of tasks?  I thought Google
Sync was supposed to be the only way to get push email working with
gmail/GAFYD.

Anyway, I'm getting off topic.  I've followed your steps exactly and I'll see
if I can confirm that my calendar and contacts sync even after a supposed setup
failure.  I do see the error message just the same as you described: it says
server is not responding after the initial sync gets stuck for a long time
about half way through the "Contacts" step.
Comment 8 Kyle Cronan 2009-11-25 09:25:09 UTC
I can confirm this.  I got a message about an MfE sync happening several hours
after the settings page told me that it had canceled out my changes.

The sync still didn't actually transfer the test event that I had created in my
calendar, but I think that's another issue.
Comment 9 Andre Klapper maemo.org 2009-11-26 18:33:07 UTC
Note that usage of Google with Mail for Exchange is currently NOT officially
supported.
Comment 10 Stephen Gadsby (reporter) maemo.org 2009-11-27 07:22:50 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > (In reply to comment #5)
> > > Weird.  What happens if you try to sync email also?
> > 
> > I haven't tried MfE for email. Google's setup instructions indicate their
> > servers don't support email syncing, and I'm happy with IMAP for that in any
> > case.
> 
> They say that?

Agreed that this has drifted off-topic, but as a (possible) quick conclusion
please see:
http://www.google.com/support/mobile/bin/answer.py?answer=147951&cbid=-1qae9yja4oqnj&src=cb&lev=answer
Anything further we should take to, say, talk.maemo.org.

Andre, thanks for clarifying that synchronization with Google isn't supported.
Even so, I'm still eager to see if anyone else can reproduce this bug. It may
be that Google is the quick path to triggering it, but that it is not a
Google-specific problem.
Comment 11 Alex Smirnoff 2009-12-03 07:39:59 UTC
1) data ere not fully synchronized, just partially
2) i get a lot of duplicates if i had my contact data synced before
Comment 12 Mikko Ohtamaa 2010-01-11 13:39:04 UTC
*** This bug has been confirmed by popular vote. ***
Comment 13 Andre Klapper maemo.org 2010-01-19 19:50:43 UTC
Hi, this bug was reported against 1.2009.41-10 and there have been two software
updates since then.

Can anybody try/report if the issue reported here still happens in version
2.2009.51-1?
Comment 14 Stephen Gadsby (reporter) maemo.org 2010-01-20 18:44:34 UTC
(In reply to comment #13)
> Can anybody try/report if the issue reported here still happens in version
> 2.2009.51-1?

Unfortunately (for testing the bug, fortunately for me, I suppose), MfE in 51-1
now synchronizes with Google successfully for me. Therefore, I'm no longer able
to trigger this bug via the steps I originally provided.

I'm currently trying methods of forcing an initial sync to fail in hopes of
retesting this secondary bug.
Comment 15 Andre Klapper maemo.org 2010-01-21 19:54:52 UTC
Okay, waiting for more feedback from other 2.2009.51-1 then. :)
Comment 16 Andre Klapper maemo.org 2010-02-02 21:18:02 UTC
As long as
http://maemo.org/community/brainstorm/view/google_calendar-contacts_synchronization/
is not fixed (which was bug 6343), this is also an enhancement. Hence changing
severity.
Comment 17 Andre Klapper maemo.org 2010-06-28 10:22:26 UTC
Anybody still having this problem in 10.2010.19-1?
Comment 18 Andre Klapper maemo.org 2010-09-27 13:01:19 UTC
(In reply to comment #14)
> Unfortunately (for testing the bug, fortunately for me, I suppose), MfE in 51-1
> now synchronizes with Google successfully for me. Therefore, I'm no longer able
> to trigger this bug via the steps I originally provided.

Closing as WORKSFORME.