Bug 6100 - (int-140187) The menu item "copy" in the browser menu does not work
(int-140187)
: The menu item "copy" in the browser menu does not work
Status: CLOSED FIXED
Product: Browser
User interface
: 5.0/(1.2009.42-11)
: N900 Maemo
: Low normal (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: browser-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-09 20:29 UTC by Uwe Kaminski
Modified: 2010-01-14 12:30 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Uwe Kaminski (reporter) 2009-11-09 20:29:40 UTC
STEPS TO REPRODUCE THE PROBLEM:
0. open an the note taking application (or an other application to paste some
text in)
1. Open the browser go to a website and mark text using the manipulation mode
like described on this page:
http://maemo.nokia.com/features/maemo-browser/gestures/ to select text on the
website.
2. Go into the browsers menu and select the menu item "copy"
3. Switch to the (notes) application opened in step 0.
4. Use Ctrl + v to paste the selected text.

EXPECTED OUTCOME:
The text selected in step 1. is pasted

ACTUAL OUTCOME:
Nothing or something what was in the clip board before step 1. happens will be
pasted.

REPRODUCIBILITY:
always
Comment 1 timeless 2009-11-10 01:43:07 UTC
so. your use case is bogus :)

if you use ctrl-v to paste, surely you can use ctrl-c to copy. It should work.

I'm told that getting the menu items to behave remotely well is incredibly
hard. this isn't just a browser problem.

wrt browser bugs, we apparently have bugs where people say copy/paste either
<always appear> or <never appear>.
Comment 2 Uwe Kaminski (reporter) 2009-11-10 11:51:16 UTC
But you are agree a solution for this issue would be nice, aren't you? :)
Comment 3 timeless 2009-11-10 13:39:55 UTC
oh yeah.

sadly, the simplest solution (and the one that i'd probably go with) is simply
to remove the menu items, since it seems like trying to get them right is going
to cost us way too much time and effort (and quite likely not work right
anyway).

if i actually didn't agree the bug was valid, i'd have marked it as such :).

i'm just pointing out that if you want to provide steps, it's a good idea to be
consistent about modalities or whatever... personally, whenever i look in that
menu, i never see those items, so i was in the "we don't ever show those
buttons" bucket (and i'm pretty sure i'd seen a bug about that).

we'll definitely try to do /something/, but given how apparently hard it is,
I'm certainly not making any promises about what. :(
Comment 4 Andre Klapper maemo.org 2009-11-11 21:31:35 UTC
Hi Uwe,

> EXPECTED OUTCOME:
> The text selected in step 1. is pasted

This works fine for me in 46-5.

Would be very cool if you could test this again once the final version is out
(soon) as I cannot reproduce the bug.
Comment 5 Donn Morrison 2009-11-18 01:37:47 UTC
This works for me in 1.2009.42-11. I successfully copied text using the menu
item and pasted it into Notes using CTRL-V. The only problem is that no banner
is displayed saying that the text was copied.
Comment 6 Andre Klapper maemo.org 2009-11-20 13:02:53 UTC
Uwe: Is this still an issue in 42-11?
Comment 7 Uwe Kaminski (reporter) 2009-11-20 17:23:05 UTC
(In reply to comment #6)
> Uwe: Is this still an issue in 42-11?

I checked it again, and yes it is still an issue:

1. open browser
2. go to: https://bugs.maemo.org
3. mark text using the manipulation mode
like described on this page:
http://maemo.nokia.com/features/maemo-browser/gestures/ to select text on the
website.
4. tap the Icon in the lower right corner to disable the full screen
5. tap to the title bar to bring up the menu
6. tap copy in the menu bar
7. tap into the url input area on the bottom of the browser
8. open keyboard and press Ctrl + v

RESULT: Nothing happens.
Comment 8 Andre Klapper maemo.org 2009-11-24 16:08:22 UTC
This has been fixed in package
microb-eal 2.5.11.4-1+0m5
which is part of the internal build version
2.2009.46-2
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 9 Uwe Kaminski (reporter) 2009-12-26 02:25:26 UTC
Verified for Firmware PR 1.1
Comment 10 Andre Klapper maemo.org 2010-01-14 12:30:05 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.