Bug 6088 - (int-147025) Very low touchscreen sensivitivity in the area near the left edge of the screen
(int-147025)
: Very low touchscreen sensivitivity in the area near the left edge of the screen
Status: RESOLVED FIXED
Product: Core
X Server
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: x-server-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-08 23:39 UTC by Lucas Maneos
Modified: 2010-04-21 15:06 UTC (History)
7 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Lucas Maneos (reporter) 2009-11-08 23:39:45 UTC
SOFTWARE VERSION:
1.2009.41-10 on pre-production N900 lent at the Amsterdam summit.

STEPS TO REPRODUCE THE PROBLEM:
1. Start Sketch.
2. Create a new document (Menu -> New).
3. Extend the new document so that it feels the screen (Menu -> Canvas size ->
Add to left).
4. Select the brush tool (first icon from the left on the toolbar).
5. Select Fine or Thin width (6th icon from the left on the toolbar).
6. Scribble around the middle of the screen using the stylus to get a feel of
the appropriate pressure needed.
7. Now try the same at the left edge of the screen.

EXPECTED OUTCOME:
Equal sensitivity in all parts of the screen.

ACTUAL OUTCOME:
The area near the left edge of the screen has very low to no pressure
sensitivity.  Even when applying pressure levels that I would consider
dangerous there are still parts that I cannot draw on.

REPRODUCIBILITY:
Always.

OTHER COMMENTS:
This manifests in other ways, such as the "hover mode" activation gesture in
the browser not working more often than not.

The right side is fine.  Top & bottom seem ok in general usage, but can't be
tested in the same way since Sketch doesn't have a full-screen mode.

Running the screen calibration tool several times made no difference.

Not sure what the right component is, but this smells like a hardware defect
(similar to bug 1069 on the N800).  Here's hoping it's just this particular
pre-production device...
Comment 1 Andre Klapper maemo.org 2009-11-16 15:47:55 UTC
Hmm...
Eero, do you by any chance know anything about this for the preproduction
devices (F5)?
Comment 2 Lucas Maneos (reporter) 2009-11-16 16:03:54 UTC
In case it helps, sysinfo-tool reports the following:

/component/product: RX-51
/component/hw-build: 2101
/component/nolo: 1.4.13
/certs/npc/variant_id: 0582645A
/certs/ccc/id: 0582645A
/device/sw-release-ver: RX-51_2009SE_1.2009.42-11_PR_MR0
/device/hw-version: 2101
/device/production-sn: MUM219190
/device/product-code: 0582645
/device/order-number:  (blank)
/device/basic-product-code: 0558710
Comment 3 Andre Klapper maemo.org 2009-11-16 21:23:10 UTC
I wonder if int-145074 is related...
Comment 4 Eero Tamminen nokia 2009-11-17 12:27:52 UTC
(In reply to comment #3)
> I wonder if int-145074 is related...

Could be.  But that's seems more about positioning (that moves when one presses
screen more on the edges and due to the screen frame & flexing of the screen)
than pressure sensitivity.

Might be better to create a separate internal bug about this.
Comment 5 Janne Pänkälä 2009-11-20 14:35:57 UTC
I do not experience touchscreen problems ATM and I have same data as above with
exception of.

/device/product-code: 0582645
Comment 6 Lucas Maneos (reporter) 2009-11-28 13:38:00 UTC
(In reply to comment #5)
> I do not experience touchscreen problems ATM and I have same data as above with
> exception of.
> 
> /device/product-code: 0582645

That's the same too, maybe I just got lucky I guess ;-)
Comment 7 Luca Franchi 2009-12-12 22:36:10 UTC
I have similar problem.
I don't speak english very well and i have upload a video to demostrate
The problem reproduce at 40 sec
http://www.youtube.com/watch?v=XzpdHHhH4Hw
Thanks for any help you can give me
Comment 8 taril 2009-12-13 12:48:57 UTC
Ive just tested it and this exested at all the 4 corners, not only on the lesf
side!!!

And I tested this on the desktop, the same, it is an overall weakness over the
whole system, not just in the sketch application.

Ive tested these on three different N900 with the latest stable official FW, so
dont tell me this is not existed! Thanks!
Comment 9 Michael Ashley 2010-01-20 03:58:43 UTC
I can confirm this problem on a recently purchased n900. There is a region of
between 0.5 and 1mm width on the left of the screen that I can't activate. This
makes "hover" mode very difficult to enter - fortunately there is a region at
the bottom left that does work.

Also, I note that the pointer position doesn't match the screen precisely,
despite careful calibration. It is OK in the centre, but is between 0.1 and 1mm
out (in the sense that the pointer is further from the centre than the
activated pixel on the screen) on the extreme left and right edges. Same with
up/down, although it is more difficult to see due to the smaller length.
Overall this is a scale error of between 1 and 2%, which makes a noticeable
difference in everyday use. I will file a bug report on this.
Comment 10 taril 2010-01-20 09:54:51 UTC
I checked this issue on Samsung GT-i8000, it is existed too. At the end of the
screen sides, the sensitivity is really low, you have to push the screen
stronger.

I think this is because of the touch panel fastening, the flexibility of the
panel is very low at the sides.v
Comment 11 Andre Klapper maemo.org 2010-01-28 14:26:33 UTC
This has been fixed in package
xorg-server 2:1.6.99.1-0osso20090208.106+0m5
which is part of the internal build version
2010.04-9
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 12 Andre Klapper maemo.org 2010-03-15 20:53:48 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 13 Thomas Tanner 2010-04-21 15:06:37 UTC
If you can't wait till PR1.2 (i.e. forever) maybe this package can help you:
http://maemo.org/packages/package_instance/view/fremantle_extras-testing_free_armel/osso-applet-screencalibration-fix/1.12-6/