Bug 6060 - (int-145690) Application manager finishing an installation in background blocks keyboard input
(int-145690)
: Application manager finishing an installation in background blocks keyboard i...
Status: RESOLVED FIXED
Product: Desktop platform
window-manager
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low minor (vote)
: 5.0/(10.2010.19-1)
Assigned To: Tapani Pälli
: window-manager-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-06 12:57 UTC by Jeroen Wouters
Modified: 2010-03-15 20:54 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jeroen Wouters (reporter) 2009-11-06 12:57:15 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Install an application with Application manager
2. While downloading/installing, switch to a terminal window
3. When the Application manager is done installing, keyboard input to the
terminal is blocked

EXPECTED OUTCOME:
Keep being able to type in the terminal, no matter what the Application manager
is doing in the background.

ACTUAL OUTCOME:
The keyboard input to the terminal is temporarily blocked, until you go to the
package manager, acknowledge the pop-up that says the application has been
succesfully installed and return to the terminal window.

REPRODUCIBILITY:
always

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.9.0.15)
Gecko/2009102815 Ubuntu/9.04 (jaunty) Firefox/3.0.15
Comment 1 Andre Klapper maemo.org 2009-11-06 15:52:22 UTC
Confirming in 45-14.
I think I saw a small popup *at the bottom* (uh?).
Comment 2 Jeroen Wouters (reporter) 2009-11-09 11:58:56 UTC
Some more observations: this also happens with keyboard input to other apps
(witnessed in FBreader).

Also I noticed the following:
1. send an email in modest
2. start writing another email
3. make a text selection in the new mail
4. when the first mail is sent, a pop-up informs you about this
5. afterwards, the selection is gone

So it seems pop-ups in general disturb text input.
Comment 3 Jeroen Wouters (reporter) 2009-11-09 12:11:46 UTC
I seem to be mistaken about modest, please disregard that remark.
Another note: with the application manager popup, it suffices to switch to the
window selection view and back to the same app, i.e. the popup doesn't have to
be acknowledged to regain keyboard input.
Comment 4 Darren Long 2009-11-26 13:24:18 UTC
App Manager also steals keybd focus from the browser.  My normal workaround is
to reselect the browser window in the task switcher.
Comment 5 Andre Klapper maemo.org 2009-12-18 13:50:33 UTC
This has been fixed in package
matchbox-window-manager-2 0.2.84-1+0m5
which is part of the internal build version
2009.51-8
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 6 Aniello Del Sorbo 2009-12-26 16:30:23 UTC
I tried installing Conky and then went to Terminal and pressed enter until I
heard the bip that HAM finished installing.

While installing a popup appeared saying "updating icon cache" on top of
terminal. Then Terminal lost the focus of the keyboard (cursor became 'empty').
Tapping in the terminal does not restore focus.
Only opening the menu or switching to other app and come back (and possible
other similar workarounds) brought the focus back.

So I think this should be reopen?
Comment 7 Aniello Del Sorbo 2009-12-26 16:34:04 UTC
I can reproduce this even if no popup appears when installing apps.
As soon as you hear the BIP that HAM has finished installing the Terminal (and
I think other apps then) lose its focus and no text can be entered until you
give the focus back to it.
Comment 8 Andre Klapper maemo.org 2009-12-28 14:01:45 UTC
Anidel: Do you use version 2009.51-8 or why did you reopen this?
Comment 9 Aniello Del Sorbo 2009-12-28 15:55:31 UTC
Sorry I forgot to add that I have re-tested this in 2.2009.51-1 and I didn't
noticed it was fixed in 51-8.
My fault.
Comment 10 Andre Klapper maemo.org 2010-01-14 13:40:56 UTC
(Fix not included in today's 2.2009.51-1 update => updating Version field)
Comment 11 Andre Klapper maemo.org 2010-01-14 18:18:02 UTC
*** Bug 7960 has been marked as a duplicate of this bug. ***
Comment 12 Lucas Maneos 2010-03-03 13:20:44 UTC
*** Bug 9373 has been marked as a duplicate of this bug. ***
Comment 13 Andre Klapper maemo.org 2010-03-15 20:54:00 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).