Bug 6048 - (int-134194) Volume hardware key works only once; afterwards "Unable to zoom" in list of mail accounts, list of mail folders, New Mail editor
(int-134194)
: Volume hardware key works only once; afterwards "Unable to zoom" in list of m...
Status: VERIFIED FIXED
Product: Email
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal with 5 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: modest-bugs
:
:
:
: 6347
  Show dependency tree
 
Reported: 2009-11-05 21:36 UTC by Uwe Kaminski
Modified: 2010-06-03 19:02 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Uwe Kaminski (reporter) 2009-11-05 21:36:23 UTC
STEPS TO REPRODUCE THE PROBLEM:
Pre configuration: Make sure that at least one mail account is available in the
email application.

1. start playing music using the media player
2. start email application --> you will see a list of email accounts available
3. press the volume up or volume down key on the top of the device

EXPECTED OUTCOME:
global volume level will incease or decrease

ACTUAL OUTCOME:
a message comes up: "Can't change font size" (in german: "Groesse kann nicht
geaendert werden")

REPRODUCIBILITY:
always

OTHER COMMENTS:
Exactly the same happens in a folder list of modest or in message lists.
In the mail creation windown the volume keys work in the expected way?
Comment 1 Andre Klapper maemo.org 2009-11-06 15:49:29 UTC
Meesage in 45-14 says "Unable to zoom" in the list of email accounts.
There's only one functionality of the zoom/volume key per app and that this
cannot be handled on a per-view basis, hence INVALID, sorry. :-/
Comment 2 Uwe Kaminski (reporter) 2009-11-06 19:09:25 UTC
(In reply to comment #1)
> Meesage in 45-14 says "Unable to zoom" in the list of email accounts.

Okay, but how I can zoom in these dialogues? If I try to use this keys I get
the message "Unable to zoom".

> There's only one functionality of the zoom/volume key per app and that this
> cannot be handled on a per-view basis, hence INVALID, sorry. :-/

And why I can manipulate volume leven in the create a new mail dialogue (same
application)?
Comment 3 Andre Klapper maemo.org 2009-11-09 19:06:09 UTC
Ah, good point & thanks for testing! :-)

Behaviour in 45-14:
Pushing the hardware zoom/volume button for the first time in the Modest
account list window I get the volume slider. Second time I get "Unable to
zoom". Seems like a conflict here.
This behaviour happens in the list of mail accounts, list of mail folders in
one account, and the New Mail editor.

Adjusting summary.
Comment 4 Andre Klapper maemo.org 2009-12-08 15:57:14 UTC
*** Bug 6508 has been marked as a duplicate of this bug. ***
Comment 5 Andre Klapper maemo.org 2009-12-10 21:53:38 UTC
*** Bug 6820 has been marked as a duplicate of this bug. ***
Comment 6 Neil MacLeod maemo.org 2009-12-10 22:14:14 UTC
(In reply to comment #3)
> This behaviour happens in the list of mail accounts, list of mail folders in
> one account, and the New Mail editor.
> 
> Adjusting summary.
> 

You can add "email reader" window to that list as well (see bug 6820 for
details) and this bug is present whether media player is in use or not.
Comment 7 Cornelius Hald 2009-12-23 18:54:18 UTC
Behavior is still the same as described in comment #3 using (prerelease)
2.2009.51-1
Comment 8 Andre Klapper maemo.org 2010-01-19 12:30:55 UTC
This has been fixed in
modest-3-2 (PR1.2): 3ef4d7de3547cfe9fc7d08e91385e58a847c5666

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 9 Andre Klapper maemo.org 2010-02-02 13:27:01 UTC
This has been fixed in
modest 3.2.11-2+0m5
which is part of the internal build version
2010.05-4.
Comment 10 Andre Klapper maemo.org 2010-03-15 20:56:17 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).