Bug 6039 - (int-142324) Hanging application menu requires system reboot
(int-142324)
: Hanging application menu requires system reboot
Status: RESOLVED FIXED
Product: Desktop platform
Home
: 5.0/(1.2009.42-11)
: N900 Maemo
: Low normal (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: home-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-04 21:49 UTC by luarvique
Modified: 2010-01-18 16:36 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description luarvique (reporter) 2009-11-04 21:49:48 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
Reproduce bug #5524 (https://bugs.maemo.org/show_bug.cgi?id=5524) and when the
application hangs in its own application menu, try the following:

1. Go into task switcher by pressing Ctrl+Backspace.
2. Kill the application by confirming the "Application not responding, kill
it?" dialog.
3. Kill the application by clicking "Kill current application" from the status
bar menu.

EXPECTED OUTCOME:
All these should work.

ACTUAL OUTCOME:
None of them work.

REPRODUCIBILITY:
always

COMMENTS:
It appears that the application menus are global and take precedence over every
other dialog, including system dialogs ("application not responding") and the
task switcher. Instead, the application menu should have top priority for all
dialogs inside that application, but not globally.
Comment 1 Urho Konttori 2009-11-05 09:26:30 UTC
Cross linked bug in internal bugzilla can be found with title:  UI freezes with
HildonAppMenu opened and Close non-responsive dialog appearing

Target to fix for the first update release. Setting TM 5.0+
Comment 2 Kimmo Hämäläinen nokia 2009-11-05 14:23:27 UTC
fixed it git master, except for the first trick (ctrl-backspace) because you
can't go to switcher when you have a system-modal dialog/note displayed.
Comment 3 luarvique (reporter) 2009-11-05 14:51:38 UTC
(In reply to comment #2)
> fixed it git master, except for the first trick (ctrl-backspace) because you
> can't go to switcher when you have a system-modal dialog/note displayed.
Thanks! =) Any reason why application menu should be system-modal?
Comment 4 Andre Klapper maemo.org 2009-11-05 14:54:50 UTC
(In reply to comment #1)
> Cross linked bug in internal bugzilla

Thanks, Urho! Setting Alias.
Also see http://wiki.maemo.org/Bugs:Cloning if interested...

I prefer closing bugs after they have been integrated internally, hence
reopening until I can post the week release it's included in.
Comment 5 Kimmo Hämäläinen nokia 2009-11-05 15:46:10 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > fixed it git master, except for the first trick (ctrl-backspace) because you
> > can't go to switcher when you have a system-modal dialog/note displayed.
> Thanks! =) Any reason why application menu should be system-modal?

The menu is not a problem since it can be (normally) closed. But the
"application is not responding" dialog is system modal in this case.
Comment 6 Andre Klapper maemo.org 2009-11-10 12:17:14 UTC
This has been fixed in package
hildon-desktop 1:2.2.114-1+0m5
which is part of the internal build version
2009.46-5
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 7 Andre Klapper maemo.org 2010-01-14 12:28:58 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 8 johnborg 2010-01-18 15:59:26 UTC
(In reply to comment #7)
> The problem reported here should be fixed in the update released today for
> public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
> Please leave a comment if the problem is not fixed for you in this update
> version.

I have updated my device to version 2.2009.51-1, but still i get the error
Hildon-home is not responding. Close application ?

I am unable to access the desktop menu to modify
>
Comment 9 Andre Klapper maemo.org 2010-01-18 16:03:27 UTC
johnborg: Please provide exact steps to reproduce by filing a new bug report.
Comment 10 Kimmo Hämäläinen nokia 2010-01-18 16:36:52 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > The problem reported here should be fixed in the update released today for
> > public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
> > Please leave a comment if the problem is not fixed for you in this update
> > version.
> 
> I have updated my device to version 2.2009.51-1, but still i get the error
> Hildon-home is not responding. Close application ?
> 
> I am unable to access the desktop menu to modify

if hildon-home is jammed, it's probably some 3rd-party Home applet that is at
fault.  You can try disabling applets one-by-one until you find the broken one.