Bug 6017 - (int-145902) Clicking the dashboard icon highlights it but does not open the dashboard
(int-145902)
: Clicking the dashboard icon highlights it but does not open the dashboard
Status: RESOLVED FIXED
Product: Desktop platform
Application Switcher
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: dashboard-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-03 04:00 UTC by mike morrison
Modified: 2010-03-15 20:53 UTC (History)
1 user (show)

See Also:


Attachments
stuck dashboard icon (563.09 KB, image/png)
2009-11-04 18:53 UTC, mike morrison
Details
stuck application menu icon (561.77 KB, image/png)
2009-11-04 18:55 UTC, mike morrison
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description mike morrison (reporter) 2009-11-03 04:00:43 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. from the desktop, click on the dashboard icon

EXPECTED OUTCOME:
dashboard opens

ACTUAL OUTCOME:
dashboard icon turns blue(highlighted), but the dashboard does not open.

REPRODUCIBILITY:
not often

OTHER COMMENTS:
i see this at most a couple times a day but haven't yet figured out how to
reproduce it. i will keep trying...
Comment 1 Andre Klapper maemo.org 2009-11-03 12:18:53 UTC
Definitely more information needed, for example how many applications you are
already running (otherwise you will not see the dashboard)... :-)
Comment 2 mike morrison (reporter) 2009-11-04 00:42:21 UTC
ok, i've done a bit more testing and i can now reproduce it maybe 1 in 10
tries.

it does not matter how many apps are running. if you aren't running any apps,
it will also happen with the application menu icon. furthermore, it may not be
limited to just these buttons. i was able to get the task button in ovi maps to
display the same behavior.

so here are my updated steps:

go to the desktop and use your thumb to touch the dashboard icon (or
application menu icon). when pressing, try to make as much of your thumb
contact the screen as possible. at first the interpreted click may be below the
button so keep moving your thumb up in tiny increments and then try clicking
again. eventually you will get to the point where the button will actually
highlight but by the time you release it will not be registered as a click.
this seems to be the zone that most often causes the bug to occur.
Comment 3 Andre Klapper maemo.org 2009-11-04 13:31:38 UTC
Tried a few times but didn't manage it. :-(
Having a second person confirming this here would be cool.
Comment 4 mike morrison (reporter) 2009-11-04 18:53:15 UTC
Created an attachment (id=1535) [details]
stuck dashboard icon

screenshot showing the stuck dashboard icon
Comment 5 mike morrison (reporter) 2009-11-04 18:55:36 UTC
Created an attachment (id=1536) [details]
stuck application menu icon

screenshot showing the stuck application menu icon
Comment 6 Alex 2009-11-23 09:22:45 UTC
Just had this happen to me also a little while ago trying to go into
Applications. Second click on the button worked.
Comment 7 Andre Klapper maemo.org 2009-12-18 13:44:37 UTC
This has been fixed in package
clutter 0.8.2-0maemo61+0m5
which is part of the internal build version
2009.51-8
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 8 Andre Klapper maemo.org 2010-01-14 13:41:03 UTC
(Fix not included in today's 2.2009.51-1 update => updating Version field)
Comment 9 Andre Klapper maemo.org 2010-03-15 20:53:59 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).