Bug 6016 - (int132094/int-150534) Can't see the number an SMS was sent to
(int132094/int-150534)
: Can't see the number an SMS was sent to
Status: RESOLVED FIXED
Product: Chat & Call & SMS
Messaging
: 5.0:(10.2010.19-1)
: N900 Maemo
: Low normal with 15 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: rtcomm@maemo.org
: im-chat-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-03 03:49 UTC by mike morrison
Modified: 2010-05-28 18:00 UTC (History)
11 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description mike morrison (reporter) 2009-11-03 03:49:52 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. send an SMS to a person in your contact list
2. open conversations and click on the thread you just started
3. click on the SMS you sent so you can see the detailed view

EXPECTED OUTCOME:
a field that shows the number the SMS was sent to

ACTUAL OUTCOME:
the detail screen shows the name, date, and message. it does not show a number.

REPRODUCIBILITY:
always

OTHER COMMENTS:
this would be nice to have for contacts with several numbers. if i send an SMS
to one of the numbers, then later forget which number i sent it to, i have no
way (that i know of) of figuring out which number i sent it to.
Comment 1 Mikhail Zabaluev nokia 2009-12-01 14:33:34 UTC
Thanks for reporting your concern. We're working on an improvement.
Comment 2 redex 2009-12-15 11:48:18 UTC
I also can't see the Number a SMS was send from! 

I have acutally a strange bug with mixed contact names in the Conversations and
it is hard to reproduce it without seeing the Number a SMS was send from.
Comment 3 Andre Klapper maemo.org 2009-12-15 13:11:16 UTC
(In reply to comment #2)
> I also can't see the Number a SMS was send from! 

@redex: And there is NO need to add a comment here about this, as this report
is already confirmed & obviously being worked on. It just triggers useless
bugmail.
Comment 4 Mahmoud Kassem 2010-02-13 09:56:51 UTC
*** Bug 9038 has been marked as a duplicate of this bug. ***
Comment 5 Mahmoud Kassem 2010-02-13 10:00:09 UTC
Adding content of bug 9038:

SOFTWARE VERSION: 2009.51-1.003

EXACT STEPS LEADING TO PROBLEM: 
1. Have a contact with 2 mobile numbers saved
2. Receive a sms from the that contact
3. Try to identify which number that SMS was sent from by clicking on the
contact avatar/photo

EXPECTED OUTCOME:
As in the phone app, I expect that clicking on the avatar would show the number
used and then another click on the avatar would show all data
ACTUAL OUTCOME:
All the contact numbers and details appear from the first click and you can not
identify which number the SMS was sent from.
Comment 6 Karsten Br├Ąckelmann 2010-03-25 19:23:27 UTC
*** Bug 9659 has been marked as a duplicate of this bug. ***
Comment 7 Andre Klapper maemo.org 2010-04-27 12:54:32 UTC
This will be fixed in the next public release (called "PR1.2" internally).

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 8 Venomrush 2010-05-25 18:25:56 UTC
*** Bug 7052 has been marked as a duplicate of this bug. ***
Comment 9 Venomrush 2010-05-25 18:26:07 UTC
Still can't tell which number was sent from.
Comment 10 Neil MacLeod maemo.org 2010-05-26 20:41:39 UTC
Confirmed, not fixed in PR1.2 (10.2010.19-1, reflash).
Comment 11 Mikhail Zabaluev nokia 2010-05-27 13:30:15 UTC
(In reply to comment #9)
> Still can't tell which number was sent from.

Sorry, an explanation of the fix was not made here: you can click on the avatar
to open the contact card, and the field corresponding to the number should be
highlighted.
Comment 12 Neil MacLeod maemo.org 2010-05-27 18:13:17 UTC
(In reply to comment #11)
> (In reply to comment #9)
> > Still can't tell which number was sent from.
> 
> Sorry, an explanation of the fix was not made here: you can click on the avatar
> to open the contact card, and the field corresponding to the number should be
> highlighted.
> 

Eh? How is that meant to work?

When I receive an SMS from someone who isn't in my Conctact list, I tap on the
blue/default Avatar and I'm faced with having to create a new contact in order
just to view the number?

And when the SMS is from someone that is in my Contacts list, I'm shown their
contact card with ALL of their phone numbers, and I still don't know which
phone number was used to send a specific SMS!

This issue is not resolved, the implemented solution is just bizarre. At the
very least, the phone number could/should be shown when you click on an SMS
message and the window with the Delete/Copy/Forward buttons is opened.

The way in which this solution is implemented I still cannot tell or see which
number has been used to send the SMS when the sender is in my contact list, and
when the sender is not in my contact list having to click on "New Contact" is
just bad design.
Comment 13 Dawid Lorenz 2010-05-27 18:19:37 UTC
(In reply to comment #12)
> When I receive an SMS from someone who isn't in my Conctact list, I tap on the
> blue/default Avatar and I'm faced with having to create a new contact in order
> just to view the number?

When you get an SMS from someone that you don't have in Contacts yet, then you
should see his/her number straight away, shouldn't you?

> And when the SMS is from someone that is in my Contacts list, I'm shown their
> contact card with ALL of their phone numbers, and I still don't know which
> phone number was used to send a specific SMS!

That will be the one highlighted blue.

I agree, this is very bizzare solution, but generally it has been fixed (at
least for me).
Comment 14 Neil MacLeod maemo.org 2010-05-27 18:25:14 UTC
(In reply to comment #13)
> 
> When you get an SMS from someone that you don't have in Contacts yet, then you
> should see his/her number straight away, shouldn't you?
> 

Some seem to have names rather than numbers. Maybe this is a quirk of the SMS
system.

> That will be the one highlighted blue.
> 

Trouble is, I have three that are highlighted blue - Mobile (phone), SMS and
Skype. OK, all are for the same number but what a bizarre and unfriendly
solution! :)

> I agree, this is very bizzare solution, but generally it has been fixed (at
> least for me).
> 

Surely adding the number to the "detail" view (along with the datestamps) would
have been soooo much simpler. Shrugs.
Comment 15 Dawid Lorenz 2010-05-27 18:30:26 UTC
(In reply to comment #14)
> Some seem to have names rather than numbers. Maybe this is a quirk of the SMS
> system.

That's not a quirk, you can actually send a text message with non-numeric
string in "from" field. Of course, all mobile phones won't allow that, but
generally SMS messages are allowed to have raw text in that field.

> Trouble is, I have three that are highlighted blue - Mobile (phone), SMS and
> Skype. OK, all are for the same number but what a bizarre and unfriendly
> solution! :)

Yes, it is. :)

> Surely adding the number to the "detail" view (along with the datestamps) would
> have been soooo much simpler. Shrugs.

Couldn't agree more.

Let's just mark this entry as RESOLVED FIXED and potentially file another one
with improvement suggestion. For me, case is closed.
Comment 16 Neil MacLeod maemo.org 2010-05-27 18:37:17 UTC
(In reply to comment #15)
> Couldn't agree more.
> 
> Let's just mark this entry as RESOLVED FIXED and potentially file another one
> with improvement suggestion. For me, case is closed.
> 

OK agreed, although unfortunately adding the number to the detail screen is
*exactly* what the bug reporter requested so what hope is there of getting it
added with another, identical, bug report when cack handed solutions with poor
usability are preferred?

I'm betting that adding the number to the detail screen would have required a
change of UI specification which was too much work, so instead we get a crap
solution simply because it was the easiest to implement. Arghhhh....
Comment 17 Marco Barisione 2010-05-28 16:46:55 UTC
(In reply to comment #15)
> > Trouble is, I have three that are highlighted blue - Mobile (phone), SMS and
> > Skype. OK, all are for the same number but what a bizarre and unfriendly
> > solution! :)
> 
> Yes, it is. :)

The UI designers thought that the implemented solution was way better for
usability and consistency so the chances to get other changes are almost
non-existent.
Comment 18 Neil MacLeod maemo.org 2010-05-28 18:00:44 UTC
Maybe if they take user feedback into consideration they will think again.

Perhaps if I only ever had one number against a contact I could consider it a
usable solution, but with so many numbers it's just a mess.

The message "detail" window seems an ideal place to show this kind of
information, I'm at a loss why it isn't used to show it.

As you say chances of a change to such cr@p decisions are non-existant, which
is why Nokia have little chance of succeeding in the longer term. Little
details like this are what end users like, or in Nokias case, hate.