Bug 5949 - H264 ipod 16:9 video doesn't playback on N900 maemo media player
: H264 ipod 16:9 video doesn't playback on N900 maemo media player
Status: RESOLVED WORKSFORME
Product: Media player
General
: 5.0/(1.2009.41-10)
: N900 All
: Medium normal (vote)
: ---
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-30 23:22 UTC by kevin van
Modified: 2009-11-09 12:48 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description kevin van (reporter) 2009-10-30 23:22:55 UTC
iPod H264 16:9 (640 x 360) video do not playback on the N900 maemo Media
player.  A similar iPod format H264 video at 4:3 aspect ratio (640 x 480)  will
playback fine on the N900 maemo media player.  



SOFTWARE VERSION:  2.2009.42-9


STEPS TO REPRODUCE THE PROBLEM:

1. Take attached folder containing two H264 video files in .mp4 format (please
contact kevin@elgato.com for such video files_ it appears your bug database
does not have attachments.  Alternatively you can create iPod sized H264 file
using QuickTime to reproduce the problem)

2. Sync or drag to the phone --> video folder using mass storage device.

3. On the N900, navigate to Media player, Video section.  Locate and try to
playback video called "XXXX 4:3".  It plays back fine on the N900 without any
problems.  Now attempt to playback the file called "XXXX_HD_16x9" on the N900.


EXPECTED OUTCOME:

Plays back H264 at the 16x9 size video.  The file that fails to playback is
H264 video 640 x 360 resolution size, 16:9 aspect ratio.  The first file that
successfully played back is a very similar file, H264, 640 x 480 resolution,
4:3 aspect ratio.

ACTUAL OUTCOME:


Playback fails.  You get the message "Unsupported Video format". 


REPRODUCIBILITY:  (always)


OTHER COMMENTS:  

Once you try to playback a file on the meamo player that fails, you need to
reboot the phone in order to get *any* video file to playback again.  Writing
that up as a separate bug.



------------------------we logged this bug in the nokia database with the
following response:




-------- 2009-10-30 06:14:00.0 GMT Balakrishna -------- 
Dear Developer,
   Thank you for submitting this issue, it has been placed in a queue for
further investigations. Please be aware that this is a channel solely for the
purpose of reporting S60 software issues and requesting technical feedback for
the issues is not recommended. Any solutions or workarounds identified will be
published  in Forum Nokia’s Technical Library without prior notification.

Kind Regards,
Forum Nokia – Professional Support

-------- 2009-10-30 08:46:00.0 GMT Balakrishna -------- 
Hi Adam,

Unfortunately, we cannot process this entry any further as we currently accept
only Symbian related bugs on this channel. We suggest you to report this bug at
Maemo Bugzilla(https://bugs.maemo.org/).

As there is nothing more that can be done from our side, this bug report will
be closed shortly.

Best regards,
Forum Nokia Professional Support.
Comment 1 Andre Klapper maemo.org 2009-11-01 19:07:37 UTC
Hi & thanks for reporting!
You can create attachments here (see "Create a New Attachment" link), but only
up to 2500KB. So either feel free to attach a small example video here, or to
send it to my email address. :-)
Comment 2 zaheer merali 2009-11-04 17:05:00 UTC
if you could post up the file somewhere, i can help you
Comment 3 zaheer merali 2009-11-07 19:04:04 UTC
I am running 1.2009.41-10 and the file plays back fine in my N900's media
player. I checked with the debugging and it shows it only used the plugins that
come with the device not any extras I have downloaded myself.
Comment 4 Andre Klapper maemo.org 2009-11-09 12:48:43 UTC
> I am running 1.2009.41-10 and the file plays back fine in my N900's media
> player. I checked with the debugging and it shows it only used the plugins that
> come with the device not any extras I have downloaded myself.

Both videos also work for me running internal 45-14 on the N900.

Closing as WORKSFORME after two people could not reproduce it.

Kevin, if this still happens for you after receiving the first Software Update
for Maemo5, can you please reopen this? Thanks!