Bug 5945 - (int-142740) URL proposals in browser disappear after some hours
(int-142740)
: URL proposals in browser disappear after some hours
Status: VERIFIED FIXED
Product: Browser
User interface
: 5.0/(2.2009.51-1)
: All Linux
: Low normal with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: browser-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-30 18:14 UTC by Alberto Garcia Gonzalez
Modified: 2010-08-25 14:59 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Alberto Garcia Gonzalez (reporter) 2009-10-30 18:14:42 UTC
SOFTWARE VERSION:
2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Open Web from the task launcher
2. Type something in the address bar

EXPECTED OUTCOME:
A list of previously opened URLs plus "Search in Google" pops up.

ACTUAL OUTCOME:
The list doesn't appear at all. I have to kill browserd for it to
appear again.

REPRODUCIBILITY:
Unfortunately I don't have detailed steps on how to reproduce this
again, I just noticed the problem a few times times in these last two
weeks, while using the N900 normally. In all cases it happened after
several hours (or even days) without rebooting the device.
Comment 1 Andre Klapper maemo.org 2009-10-30 19:56:11 UTC
Heja,

so "disappears after some hours" means after some hours of using the N900
normally, I guess.
Because when reading the summary I thought "Enter stuff in the browser URL
field, get the proposals popup, wait for a few hours, see that it's not there
anymore". :-D
Comment 2 Alberto Garcia Gonzalez (reporter) 2009-10-30 19:58:49 UTC
(In reply to comment #1)
> so "disappears after some hours" means after some hours of using the
> N900 normally, I guess.

Yeah, exactly :-D
Comment 3 Andre Klapper maemo.org 2009-11-02 16:21:50 UTC
Do you have some user created bookmark folders present in device?
(If so, this is a dup of int-142740.)
Comment 4 Alberto Garcia Gonzalez (reporter) 2009-11-02 17:42:42 UTC
Yes, I had created a bookmarks folder, but I haven't touched the
bookmark list for weeks.

In fact IIRC I had problems adding _new_ bookmarks at some point. I
think I tried to add a bookmark to Facebook and it eventually
disappeared.
Comment 5 Bartosz Taudul 2009-12-09 00:05:44 UTC
I confirm this bug in 1.2009.42-11. Not only proposals are no longer shown, but
also the google search for entered term.
Additionaly I have noticed that the "down arrow" icon on the right side of the
address entry box was not working.
At the same time I was unable to use virtual keyboard (system wide). Rebooting
the phone "fixed" all these problems for the time beign (it's not the first
time I've lost virtual keyboard).
Comment 6 Andre Klapper maemo.org 2009-12-14 19:41:52 UTC
This has been fixed in package
tablet-browser-ui 1.8.11-1.3+0m5
which is part of the internal build version
2009.50-7
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Note that Nokia does not announce release dates of public updates in advance.
Comment 7 Andre Klapper maemo.org 2010-01-14 13:41:13 UTC
(Fix not included in today's 2.2009.51-1 update => updating Version field)
Comment 8 Andre Klapper maemo.org 2010-03-15 20:51:12 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 9 Alberto Garcia Gonzalez (reporter) 2010-06-07 20:55:40 UTC
I haven't had this problems since I upgraded to PR1.2
Comment 10 Alberto Garcia Gonzalez (reporter) 2010-08-24 15:30:53 UTC
I'm afraid I've just reproduced this right now, with the 10.2010.19-1 image

Should I reopen this bug or file a new one?
Comment 11 timeless 2010-08-24 16:10:33 UTC
new bug, please
Comment 12 Alberto Garcia Gonzalez (reporter) 2010-08-25 14:59:23 UTC
(In reply to comment #11)
> new bug, please

Done: bug 11192

Thanks