Bug 5911 - (int-144813) Shaking device switches between landscape and portrait modes
(int-144813)
: Shaking device switches between landscape and portrait modes
Status: VERIFIED FIXED
Product: System software
dsme
: 5.0/(1.2009.42-11)
: N900 Maemo
: Low minor with 1 vote (vote)
: 5.0/(2.2009.51-1)
Assigned To: rtcomm@maemo.org
: dsme-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-30 03:23 UTC by Donn Morrison
Modified: 2010-01-15 17:37 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Donn Morrison (reporter) 2009-10-30 03:23:24 UTC
STEPS TO REPRODUCE THE PROBLEM:

1. Open the telephone application (Applications > Telephone)
2. Set the rotation to Automatic (Menu > Rotation Settings >  Screen
Orientation > Automatic) (translated from French so may not be exact)
3. Shake the phone horizontally (from left to right)

EXPECTED OUTCOME:

The screen orientation shouldn't be so easily confused.

ACTUAL OUTCOME:

The screen orientation seems to be too sensitive and changes between landscape
and portrait, even though the device actually remains in the same physical
orientation.

REPRODUCIBILITY:

always

OTHER COMMENTS:

Shaking is an extreme case, but I've noticed that sometimes the orientation is
changed simply by moving the N900 too quickly to one side, say when you're
moving around a bit. (Bug summary could possibly be updated to reflect this
generality).

This could possibly be fixed by smoothing over several samplings of the
sensor(s) that determine the device orientation, although this might be to the
detriment of the snappiness of a valid orientation change.
Comment 1 Kasper Souren 2009-11-02 02:33:09 UTC
This shaking has actually been causing me to loose phone calls!  This shouldn't
happen to end-users buying this phone...

My situation: The phone is ringing, I take it out of my pocket, I try to accept
the call, but the orientation is changing, and I tempted to change the position
again, but the button is disappearing and I'm not in time to answer the phone
call.

So I propose that the orientation is never changed during an incoming call, or
at least make it possible to accept phone calls while the orientation is
switched.
Comment 2 Andre Klapper maemo.org 2009-11-19 15:58:44 UTC
This has been fixed in package
mce 1.8.100+0m5
which is part of the internal build version
2.2009.47-9
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 3 Andre Klapper maemo.org 2010-01-14 12:25:54 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.