Bug 5905 - (int-153182) ovi maps brings up "Select connection" dialog relentlessly
(int-153182)
: ovi maps brings up "Select connection" dialog relentlessly
Status: RESOLVED FIXED
Product: Map
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal with 5 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: map-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-29 21:05 UTC by mike morrison
Modified: 2010-03-15 20:55 UTC (History)
11 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description mike morrison (reporter) 2009-10-29 21:05:37 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. in internet connection settings, change connect automatically to "always
ask" or go to a place where you have no saved connections.
2. disconnect from the internet
3. load maps

EXPECTED OUTCOME:
gps fix established, show position on map etc, let me browse around etc

ACTUAL OUTCOME:
the "Select connection" dialog pops up over and over again! it seems to pop up,
you dismiss it, and it pops up again right away. once you dismiss it the second
or third (or sometimes even forth!) time you'll have a short delay before then
next onslaught of connection dialogs.

REPRODUCIBILITY:
always

OTHER COMMENTS:
it is so very frustrating when you are just trying to browse around the map. 

perhaps allow the user the option to not require an internet connection to use
ovi maps.


User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4)
Gecko/20091016 Firefox/3.5.4 (.NET CLR 3.5.30729)
Comment 1 Donn Morrison 2009-10-30 02:28:08 UTC
Confirming. This behaviour is very irritating.

The preferences dialog in Maps is sparse (only two settings - measurement units
and time format), why not add another toggle to allow the user to suppress the
connection dialog (an offline mode perhaps).
Comment 2 Lucas Maneos 2009-10-30 11:50:38 UTC
This is probably a duplicate of either bug 5336 or bug 5337, depending on
whether maps wants a connection in order to download maps or to get GPS supl
data.
Comment 3 Andre Klapper maemo.org 2009-11-01 17:43:29 UTC
Assuming that this is a duplicate of bug 5337.

*** This bug has been marked as a duplicate of bug 5337 ***
Comment 4 mike morrison (reporter) 2009-11-02 05:03:14 UTC
i don't think this is a duplicate of either of those bugs. they may be related
but they are not the same. 

this bug specifically talks about the connection dialog popping up over and
over again no matter how many times you dismiss it and i fear this important
detail may be lost if marked as a dup.
Comment 5 Lucas Maneos 2009-11-02 05:30:37 UTC
(In reply to comment #4)
> this bug specifically talks about the connection dialog popping up over and
> over again no matter how many times you dismiss it and i fear this important
> detail may be lost if marked as a dup.

Right, sorry for missing the point (reopening).

Sounds like the same issue as bug 5368 then.  I'm guessing that the connection
requests come from the location framework regardless of which running app
requests location info.  Andre, anything relevant in int-137629?
Comment 6 Andre Klapper maemo.org 2009-11-26 21:07:23 UTC
(In reply to comment #5)
> Andre, anything relevant in int-137629?

Oops, somehow I missed this. Sorry. :-/
I have answered this in bug 5368 now.

So I currently expect bug 5368, bug 5905 and bug 5761 to have the same
underlying root issue in location-proxy having a broken passing of the user
decision to click "No". This is just my uneducated guess though.
Comment 7 EC 2009-12-20 15:19:46 UTC
I confirm this bug, it's very annoying! Maps can't even imagine that you may
want to use the gps without a network connection, very frustrating...
Comment 8 Andre Klapper maemo.org 2010-01-14 12:32:46 UTC
Today Nokia released the Maemo5 update version 2.2009.51-1 for public (also
called "PR1.1" sometimes).
If you have some time we kindly ask you to test again if the problem reported
here still happens in this new version - just leave a comment (and feel free to
update the "Version" field to the new version if it's still a problem).
Comment 9 EC 2010-01-14 13:05:36 UTC
With assisted GPS activated, bug still present in PR1.1 (just tested). The
dialog pops up itself continuously. I've not the power to change the version
field.
Comment 10 Andre Klapper maemo.org 2010-01-14 13:30:04 UTC
Thanks for retesting!
Comment 11 Quim Gil nokia 2010-02-03 10:51:44 UTC
A fix is in its way...
Comment 12 Flandry 2010-02-06 18:13:46 UTC
Glad to hear that, Quim. Is this a fix in the location framework, maps, or
both?
Comment 13 Quim Gil nokia 2010-02-08 10:09:28 UTC
Only in the application since the framework already offers API to handle such
situation properly.
Comment 14 Andre Klapper maemo.org 2010-02-12 16:59:45 UTC
*** Bug 9026 has been marked as a duplicate of this bug. ***
Comment 15 Venomrush 2010-02-12 19:45:01 UTC
Similar bug but for camera with geotagging enabled, camera will brings up
"Select connection" dialog relentlessly too - Bug 9029
Comment 16 Andre Klapper maemo.org 2010-02-13 01:36:22 UTC
(Data connection is completely unrelated to GPS satellite reception, hence
Lucas removed the dependency bug again.)
Comment 17 Flandry 2010-02-27 22:29:32 UTC
Seems much better now (since the mid February update). An unobtrusive "One or
more network connections are no longer available." banner pops up once in a
while if you start out on a network and leave, otherwise it asks once. Then it
stays out of your face.
Comment 18 Andre Klapper maemo.org 2010-03-15 20:55:11 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).