Bug 5897 - Phone: Hardware volume control inconsistent between Portrait and Landscape Modes
: Phone: Hardware volume control inconsistent between Portrait and Landscape Modes
Status: RESOLVED WONTFIX
Product: UI Specification
General
: 5.0/(1.2009.41-10)
: N900 Linux
: Medium normal with 4 votes (vote)
: ---
Assigned To: Mikko Nurmi
: ui-specification-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-29 15:22 UTC by Sanjeev Visvanatha
Modified: 2010-02-17 14:12 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Sanjeev Visvanatha (reporter) 2009-10-29 15:22:26 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Open the Phone application by launching it from the application menu. 
Ensure that the device orientation is in Landscape Mode
2. Once the Phone is open, increase the volume by pressing the right side of
the rocker switch that is on top of the device above the "Nokia" label.
3. Switch the device orientation to Portrait mode by rotating 90 degrees so
that the phone's earpiece is up, and the microphone is down (rotate clockwise)
4. Press the right side of the rocker switch that is on top of the device above
the "Nokia" label.

EXPECTED OUTCOME:
Volume increases in both scenarios listed above

ACTUAL OUTCOME:
In landscape mode, a right press of the volume rocker increases the volume.
In portrait mode, a right press of the volume rocker decreases the volume.

REPRODUCIBILITY:
(always/sometimes/once)
Always

EXTRA SOFTWARE INSTALLED:
The only relevant things are: SIM card, SIP and Google Talk accounts that make
use of the phone application.

OTHER COMMENTS:
The inconsistent volume control is annoying - a right press should increase
things like zoom and volume, whereas a left press should decrease it.  If the
orientation changes, then the function of the button should not change, IMO.  

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8)
Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4
Comment 1 Mikko Vartiainen 2009-10-29 16:22:16 UTC
This clearly a designed feature and I like it much better the way it is.
Comment 2 Andre Klapper maemo.org 2009-10-29 17:13:11 UTC
This has definitely been a design choice and I must also say that I like it.
There are no plans to change this currently.
Comment 3 Sanjeev Visvanatha (reporter) 2009-10-29 17:58:01 UTC
Thanks Andre.  The usage case in which I noticed the distinctly different
behaviour was as follows:

1. Was browsing in landscape mode while on a call with the speakerphone active.
2. Turned speakerphone off and initiated volume increase while still in
landscape mode (volume slider showing volume was increasing)
3. Put phone to ear (in portrait mode now), while still increasing volume using
the right side of the rocker button
4. Unbeknownst to me, when the phone app changed orientation, my intended push
of the right side of the rocker now was decreasing the volume.

I think this is really a 'corner case', so perhaps the design intent is fine. 
It just left me as an ordinary user a little confused.
Comment 4 Mikko Vartiainen 2010-02-05 04:36:43 UTC
*** Bug 8842 has been marked as a duplicate of this bug. ***
Comment 5 David Ward 2010-02-05 09:22:46 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 David Ward 2010-02-05 09:25:15 UTC
This change makes the auto switching of the orientation option for the phone
app useless.

I have worked around this and set the phone app to always be in portrait mode
now, so whilst on the phone, the volume buttons won't keep swapping around as I
move around [and have no way to know which it which with it pressed to your
head].

Problem now, is if I use a headset/speaker etc, like in my car with the phone
in landscape in its holder, phone calls sit side on and I need to turn my head
to read and use whilst driving. Annoying I must say.
Comment 7 Andre Klapper maemo.org 2010-02-17 14:12:43 UTC
*** Bug 9092 has been marked as a duplicate of this bug. ***