Bug 5879 - (int-134231) Media player track search only matches the beginning of title/artist
(int-134231)
: Media player track search only matches the beginning of title/artist
Status: CLOSED FIXED
Product: Media player
General
: 5.0/(1.2009.42-11)
: N900 Linux
: Low normal with 2 votes (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-28 22:01 UTC by Thomas Perl
Modified: 2010-01-14 12:48 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Thomas Perl (reporter) 2009-10-28 22:01:43 UTC
SOFTWARE VERSION:

1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:

1. Open media player
2. Touch "Music"
3. Make sure the view mode is "All songs"
4. Search for a middle part of the song title
   (e.g. "Bedroom" for the song "Original Bedroom Rockers")

EXPECTED OUTCOME:

The song is found and "Bedroom" is highlighted.

ACTUAL OUTCOME:

No song is found, as the search function only matches the beginning.

REPRODUCIBILITY:

always

OTHER COMMENTS:

Use cases where I would not be able to find a song I'm searching for:

*) The song title (errorneously) contains the track number
   => "03 Walking on sunshine" (search for "Walking")
*) I only know one artist of a song with multiple artists
   => "Kruder & Dorfmeister" (search for "Dorfmeister")
*) I know the remixer, but not the artist/song title
   => "Loser (Fatboy Slim Remix)" (search for "Fatboy")
Comment 1 Andre Klapper maemo.org 2009-10-30 19:09:44 UTC
This has been fixed in package
mediaplayer 1.1-1+0m5
which is part of the internal build version
2009.42-9
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 2 Andre Klapper maemo.org 2009-11-16 14:03:46 UTC
Please note that the fix for this issue is NOT included in the final Maemo5
version 1.2009.42-11 that was released today.
The fix will be included in the next update after 1.2009.42-11.
Comment 3 Thomas Perl (reporter) 2009-12-23 16:48:14 UTC
I confirm that this has been fixed in 2.2009.51-1. Thanks!
Comment 4 Andre Klapper maemo.org 2010-01-13 14:01:55 UTC
*** Bug 7898 has been marked as a duplicate of this bug. ***
Comment 5 Andre Klapper maemo.org 2010-01-14 12:27:02 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 6 amitkankani 2010-01-14 12:41:06 UTC
Confirmed to be fixed in the PR1.1 :)

it even searches for substrings, not only beginning of next words, so its a
good experience.

Can I mark the bug as closed, or I guess Thomas should do it once he verifies
it :)