Bug 5870 - (int-114468) Long emails can't be read - distorted output on screen after scrolling
(int-114468)
: Long emails can't be read - distorted output on screen after scrolling
Status: RESOLVED FIXED
Product: Email
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal with 2 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-28 13:53 UTC by Marko Vertainen
Modified: 2010-05-26 16:19 UTC (History)
6 users (show)

See Also:


Attachments
Screenshot showing this problem (64.36 KB, image/png)
2009-10-28 13:55 UTC, Marko Vertainen
Details
distorted email message occuring after pr1.1 (as before) update (55.99 KB, image/png)
2010-01-19 06:37 UTC, toni.laroma
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Marko Vertainen (reporter) 2009-10-28 13:53:12 UTC
SOFTWARE VERSION:

N900: 1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:

1. Define some imap email account on N900 (gmail, ovi etc..)
2. Send an email containing about 2000 lines of text (like batched
maemo-developers mailing-list messages) to that account.
3. Open email and see message: maximum number of characters reached
4. Start to scroll down the screen at such a speed that you can read the
messages. (too quick scroll doesn't seem to trigger this bug).
5. After a while text is not readable. See attachment for an example outcome.

EXPECTED OUTCOME:

Whole long mail can be read with Email application.

ACTUAL OUTCOME:

Text is scattered in screen and can't be read. See attachment.

REPRODUCIBILITY:

Almost always.

EXTRA SOFTWARE INSTALLED:

Many from extras testing.

OTHER COMMENTS:

I have seen this same functionality on N810 every now and then also.
Comment 1 Marko Vertainen (reporter) 2009-10-28 13:55:06 UTC
Created an attachment (id=1516) [details]
Screenshot showing this problem
Comment 2 Andre Klapper maemo.org 2009-10-28 17:36:47 UTC
Thanks for reporting this.
Confirming.
Comment 3 Mikko Vartiainen 2009-10-29 16:29:53 UTC
Probably doesn't help, but the very same thing happened constantly in Diablo
too.
Comment 4 Lucas Maneos 2009-10-29 21:21:44 UTC
The message is truncated at 1024 lines, according to a quick test with:

perl -le 'print "Line $_" foreach (1..2000);' | mail -s "many lines" me@dom.ain

and a quick grep at the source shows this:

./src/modest-formatter.c:#define MAX_BODY_LINES 1024

Also, when trying to reply to such a message the compose window's scrolling is
extremely slow and CPU-heavy (which sounds a lot like bug 5455).
Comment 5 Andre Klapper maemo.org 2009-12-14 11:45:09 UTC
This has been fixed in package
modest 3.2.3-1+0m5
which is part of the internal build version
2009.50-7 
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Please note that Nokia does not announce release dates of public updates in
advance.
Comment 6 Andre Klapper maemo.org 2010-01-14 13:41:20 UTC
(Fix not included in today's 2.2009.51-1 update => updating Version field)
Comment 7 toni.laroma 2010-01-19 06:33:24 UTC
this problem ia atill occuring after pr1.1 update
Comment 8 toni.laroma 2010-01-19 06:37:57 UTC
Created an attachment (id=2041) [details]
distorted email message occuring after pr1.1 (as before) update

Message distorts same way after pr1.1 update as before it.
Comment 9 Andre Klapper maemo.org 2010-01-19 12:52:05 UTC
Toni Laroma: Of course it is, that's why the Version field says that it still
happens in 2.2009.51-1. No need to add another comment about it...
Comment 10 Lucas Maneos 2010-02-02 21:49:03 UTC
*** Bug 8789 has been marked as a duplicate of this bug. ***
Comment 11 Michael Cronenworth 2010-02-02 22:09:59 UTC
(In reply to comment #9)
> Toni Laroma: Of course it is, that's why the Version field says that it still
> happens in 2.2009.51-1. No need to add another comment about it...
> 

Why is this still marked as fixed then? I couldn't find it otherwise I would
not have created a dupe bug. If it's been included in a newer internal release,
then could you please announce which version? Thanks.
Comment 12 Andre Klapper maemo.org 2010-02-02 22:14:55 UTC
(In reply to comment #11)
> Why is this still marked as fixed then?

As written in comment 5, this has been fixed in the internal version 2009.50-7
(and I was wrong about "any future version").
Unfortunately it's not included in 2.2009.51-1, but it will be included in a
public future update (called "PR1.2" internally).
Comment 13 Andre Klapper maemo.org 2010-03-15 20:56:14 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 14 Michael Cronenworth 2010-05-26 16:19:19 UTC
It seems the limit was increased with PR1.2 but text e-mails that are ~70k in
size have the last 10% or so cut off and the message of "Maximum number of
characters has been reached" is still displayed. Is there a technical reason
why this limit was increased from 32k to only 64k instead of around 1MB?