Bug 5869 - (int-98535) Chess game over dialog button is unreadable in some themes
(int-98535)
: Chess game over dialog button is unreadable in some themes
Status: RESOLVED FIXED
Product: Games
Chess
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low minor (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: chess-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-28 10:35 UTC by Donn Morrison
Modified: 2010-03-15 21:10 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Donn Morrison (reporter) 2009-10-28 10:35:37 UTC
STEPS TO REPRODUCE THE PROBLEM:

1. Launch Chess (Applications > Others > Chess)
2. Start a new game
3. Play until game is over

EXPECTED OUTCOME:

Game over dialog should conform to the rest of the Maemo 5 UI.

ACTUAL OUTCOME:

The "Finish" button in the dialog contains dark text on a dark background
making  it difficult to read.

REPRODUCIBILITY:

always

OTHER COMMENTS:

I'm unsure of the exact English text in the dialog button because my language
is set to French. In French the button reads "Terminer".
Comment 1 Andre Klapper maemo.org 2009-10-28 16:30:30 UTC
Thanks for reporting this bug.

Actually here it is impossible to read with the "Digital Nature" theme.
Which theme do you use?
Comment 2 Donn Morrison (reporter) 2009-10-28 17:01:01 UTC
(In reply to comment #1)
> Actually here it is impossible to read with the "Digital Nature" theme.
> Which theme do you use?

I'm using the Nokia NSeries theme, so while it is difficult to read due to dark
text on a black button, it is still readable.
Comment 3 Andre Klapper maemo.org 2010-01-18 12:57:54 UTC
This has been fixed in package
osso-chess-ui 1.8.3-1+0m5
which is part of the internal build version
2010.02-6
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 4 Andre Klapper maemo.org 2010-03-15 21:10:39 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).