Bug 5868 - (int-120015) Games do not respect master volume ("sound effects" enabled though)
(int-120015)
: Games do not respect master volume ("sound effects" enabled though)
Status: VERIFIED FIXED
Product: Games
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low minor with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: games-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-28 10:25 UTC by Donn Morrison
Modified: 2010-05-26 18:40 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Donn Morrison (reporter) 2009-10-28 10:25:55 UTC
STEPS TO REPRODUCE THE PROBLEM:

1. Set master volume to a low volume (even completely off) by tapping on the
status icons at the top of screen and moving the volume slider to the left
2. Open Chess (Applications > Others > Chess)
3. Start a new game (with sound effects enabled)
4. Move a chess piece on the board (normal game play)

EXPECTED OUTCOME:

Chess should respect the master volume level.

ACTUAL OUTCOME:

Chess plays sound effects quite loudly, not respecting the master volume level.

REPRODUCIBILITY:

always

OTHER COMMENTS:

This caught me by surprise when I attempted to pass some time playing chess
during a dull period in a quiet language class. I had explicitly set the master
volume to off before launching the game but failed to notice the "Sound
effects" checkbox on the main screen of Chess. Even if I had seen this game
setting, I would have expected Chess to respect the master volume level.
Comment 1 Andre Klapper maemo.org 2009-10-28 16:37:07 UTC
Confirming.
Comment 2 Andre Klapper maemo.org 2009-10-29 17:19:27 UTC
Also applies for Mahjongg, hence moving to General subcomponent
Comment 3 Andre Klapper maemo.org 2009-10-29 17:19:33 UTC
*** Bug 5892 has been marked as a duplicate of this bug. ***
Comment 4 Bartosz Taudul 2009-12-08 21:20:05 UTC
(In reply to comment #1 from bug 5892)
> "Silent" profile only refers to Phone/IM.
> What you want is the Master volume level instead. :-)
Muting application sounds when silent profile is enabled is a requirement (or
at least a strong suggestion) in Symbian and N-Gage certification, so I'm
rather surprised it's not the same on Maemo.
Comment 5 HoX 2009-12-09 17:35:54 UTC
(In reply to comment #4)
> (In reply to comment #1 from bug 5892)
> > "Silent" profile only refers to Phone/IM.
> > What you want is the Master volume level instead. :-)
> Muting application sounds when silent profile is enabled is a requirement (or
> at least a strong suggestion) in Symbian and N-Gage certification, so I'm
> rather surprised it's not the same on Maemo.
> 

More then this, I'm surprised it doesn't do it automatically... on the computer
you don't need to take care of the current volume status because "someone else"
(ALSA, Pulseaudio) do it for you.
Why isn't this possible on the phone?
Comment 6 Andre Klapper maemo.org 2009-12-09 19:50:33 UTC
(In reply to comment #5)
> Why isn't this possible on the phone?

Because nobody has written that code yet I guess. Time's limited sometimes...
Comment 7 HoX 2009-12-09 23:10:34 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > Why isn't this possible on the phone?
> 
> Because nobody has written that code yet I guess. Time's limited sometimes...
> 

But the phone already uses ALSA and PulseAudio, then the code should be the
same of the computer, or a little modification of it.
I really doubt that a software will be written to bypass ALSA and write
directly on the DSP and, even if it does, /dev/dsp is managed by the kernel
which dialogs with the ALSA modules... therefore I really don't understand how
it could be possible
Comment 8 Andre Klapper maemo.org 2009-12-17 14:02:17 UTC
This has been fixed in packages
osso-mahjong 1.7.49-1+0m5
osso-chess-ui 1.7.49-1+0m5
which is part of the internal build version
2009.51-5
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal exists at
  
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 9 Andre Klapper maemo.org 2010-01-14 13:41:25 UTC
(Fix not included in today's 2.2009.51-1 update => updating Version field)
Comment 10 Andre Klapper maemo.org 2010-03-15 21:10:38 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).