Bug 5839 - (int-144430) Modest gets stuck updating POP3 mailboxes
(int-144430)
: Modest gets stuck updating POP3 mailboxes
Status: RESOLVED DUPLICATE of bug 5836
Product: Email
General
: 5.0/(1.2009.41-10)
: N900 Maemo
: Low normal with 2 votes (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-27 15:12 UTC by luarvique
Modified: 2010-05-16 13:01 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description luarvique (reporter) 2009-10-27 15:12:51 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
Add a pop3-based email account to Modest, set it for periodic updates.

EXPECTED OUTCOME:
Modest regularly checks pop3 mailbox and gets email headers. Opening Modest UI
allows you to view the pop3 mailbox.

ACTUAL OUTCOME:
After several successful mailbox checks, Modest background process gets
"stuck". It no longer updates the mailbox state. Any attempt to check such a
pop3 mailbox from the Modest UI ends with Modest indeifnitely trying to update
the mailbox state. During this time, Modest shows three folders: Drafts,
Outbox, Sent, but no Inbox folder.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
The pop3 server runs:
  QPopper 4.0.9 (non-standalone)
  Inetd
  FreeBSD 5.4-RELEASE
Comment 1 luarvique (reporter) 2009-10-27 15:24:35 UTC
Additional info: "killall modest" briefly restores pop3 functionality, until it
gets broken again. A second "killall modest" is sometimes required to kill the
background copy of Modest left after the first killall and consuming 100% CPU.
Comment 2 Lucas Maneos 2009-11-17 06:08:25 UTC
I wonder if this is related to bug 5836...  Could you provide some debug output
(see <https://wiki.maemo.org/Bugs:Stock_answers#Modest>) and/or server logs?
Comment 3 luarvique (reporter) 2009-11-17 07:35:13 UTC
(In reply to comment #2)
> I wonder if this is related to bug 5836...  Could you provide some debug output
> (see <https://wiki.maemo.org/Bugs:Stock_answers#Modest>) and/or server logs?   
Yes, it should be related in some way (I have trouble reading mail on the
server, with PINE, when Modest is checking mail). But I doubt it is the same
bug.
Comment 4 Lucas Maneos 2009-11-17 14:37:13 UTC
Sorry, I should have been more verbose.  I was thinking of a scenario where
modest opens two or more POP-3 connections to the server and manages to
deadlock itself, which is why I requested logs.
Comment 5 Sergio Villar Senin 2009-11-26 19:39:31 UTC
This is the same as 5836

*** This bug has been marked as a duplicate of bug 5836 ***
Comment 6 beaugetcom 2010-02-02 03:19:02 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 beaugetcom 2010-05-16 13:01:11 UTC
I know that is not a forum.
But is this bug going to be fixed!

It has been 5 months that I have this device, five months that I have not got
my mail properly, I must reboot 4-5 times a day my device!
Waiting three months since the update, still nothing.
I am willing to be patient, I'm tired. The unit will leave in for repair.
After 10 years of loyalty, bye Nokia.