Bug 5838 - (int-104238) Certain directory entries are duplicated (listed twice / doubled)
(int-104238)
: Certain directory entries are duplicated (listed twice / doubled)
Status: RESOLVED FIXED
Product: Desktop platform
File System UI
: 5.0/(3.2010.02-8)
: N900 Maemo
: Low normal with 44 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: Marius Vollmer
: file-system-ui-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-27 15:02 UTC by luarvique
Modified: 2010-08-31 07:46 UTC (History)
26 users (show)

See Also:


Attachments
pupnik pr 1.1 osso-product-info (403 bytes, text/plain)
2010-01-20 06:16 UTC, arnim sauerbier
Details
pupnik pr 1.1 mount info (1.22 KB, text/plain)
2010-01-20 06:18 UTC, arnim sauerbier
Details
pupnik pr 1.1 hal-device |grep mmc (6.50 KB, text/plain)
2010-01-20 06:19 UTC, arnim sauerbier
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description luarvique (reporter) 2009-10-27 15:02:52 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
Open File Manager or any file selector.

EXPECTED OUTCOME:
All files/directories have different names.

ACTUAL OUTCOME:
Certain virtual "directory" names are duplicated: "Audio clips", "Camera",
"Documents", "Images", "Video clips"

REPRODUCIBILITY:
always
Comment 1 Daniel Martin Yerga 2009-10-27 15:12:22 UTC
Confirming.

It happened to me in one of the previous firmwares. Didn't can reproduce it. It
isn't fixed rebooting the device.
Comment 2 Andre Klapper maemo.org 2009-10-27 15:54:03 UTC
luarvique, can you please provide:
* explicate steps to reproduce 
* attach syslog
* output from command  $mount
* output from command  $hal-device |grep mmc
as the internal ticket (int-104238) is currently closed as "cannot reproduce".

Thanks!
Comment 3 luarvique (reporter) 2009-10-27 16:15:41 UTC
(In reply to comment #2)
> * explicate steps to reproduce 
The explicate steps to reproduce are provided in the "STEPS TO REPRODUCE THE
PROBLEM" section of the original bug report. Yes, it is really that simple.

> * attach syslog
Syslog of what? 

> * output from command  $mount
rootfs on / type rootfs (rw)
ubi0:rootfs on / type ubifs (rw,bulk_read,no_chk_data_crc)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
tmpfs on /tmp type tmpfs (rw,noatime,size=1024k)
tmpfs on /var/run type tmpfs (rw,nosuid,noatime,size=256k,mode=755)
none on /dev type tmpfs (rw,noatime,size=10240k,mode=755)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev,noatime,size=65536k)
/dev/mmcblk0p2 on /home type ext3
(rw,noatime,errors=continue,commit=1,data=writeback)
/dev/mmcblk0p1 on /home/user/MyDocs type vfat 
(rw,noauto,nodev,noexec,nosuid,noatime,nodiratime,utf8,uid=29999,shortname=mixed,dmask=000,fmask=0133,rodir)

> * output from command  $hal-device |grep mmc
  block.storage_device =
'/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1_mmc_host_mmc_card_rca1_storage_mmc_sd_mmc' 
(string)
  block.device = '/dev/mmcblk0p3'  (string)
  linux.sysfs_path = '/sys/block/mmcblk0/mmcblk0p3'  (string)
  info.parent =
'/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1_mmc_host_mmc_card_rca1_storage_mmc_sd_mmc' 
(string)
  block.storage_device =
'/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1_mmc_host_mmc_card_rca1_storage_mmc_sd_mmc' 
(string)
  block.device = '/dev/mmcblk0p2'  (string)
  linux.sysfs_path = '/sys/block/mmcblk0/mmcblk0p2'  (string)
  info.parent =
'/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1_mmc_host_mmc_card_rca1_storage_mmc_sd_mmc' 
(string)
  block.storage_device =
'/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1_mmc_host_mmc_card_rca1_storage_mmc_sd_mmc' 
(string)
  block.device = '/dev/mmcblk0p1'  (string)
  linux.sysfs_path = '/sys/block/mmcblk0/mmcblk0p1'  (string)
  info.parent =
'/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1_mmc_host_mmc_card_rca1_storage_mmc_sd_mmc' 
(string)
3: udi =
'/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1_mmc_host_mmc_card_rca1_storage_mmc_sd_mmc'
  storage.drive_type = 'sd_mmc'  (string)
  storage.originating_device =
'/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1_mmc_host_mmc_card_rca1'  
(string)
  linux.sysfs_path = '/sys/block/mmcblk0'  (string)
  info.parent =
'/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1_mmc_host_mmc_card_rca1'  
(string)
  block.storage_device =
'/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1_mmc_host_mmc_card_rca1_storage_mmc_sd_mmc' 
(string)
  info.udi =
'/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1_mmc_host_mmc_card_rca1_storage_mmc_sd_mmc' 
(string)
  block.device = '/dev/mmcblk0'  (string)
  storage.bus = 'mmc'  (string)
20: udi =
'/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1_mmc_host_mmc_card_rca1'
  mmc.vendor = 'Unknown (17)'  (string)
  mmc.oem = 'Unknown (256)'  (string)
  mmc.date = '04/2009'  (string)
  mmc.hwrev = 0  (0x0)  (int)
  mmc.fwrev = 0  (0x0)  (int)
  mmc.serial = 202598331  (0xc1367bb)  (int)
  linux.sysfs_path = '/sys/class/mmc_host/mmc1/mmc1:0001'  (string)
  info.parent = '/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1_mmc_host'
 (string)
  info.linux.driver = 'mmcblk'  (string)
  linux.subsystem = 'mmc'  (string)
  info.subsystem = 'mmc'  (string)
  info.udi =
'/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1_mmc_host_mmc_card_rca1'  
(string)
  mmc.rca = 1  (0x1)  (int)
  mmc.cid = '1101004d4d43333247010c1367bb4cc5'  (string)
  mmc.csd = '900e00320f5903ffffffffe79640005b'  (string)
  mmc.type = 'MMC'  (string)
21: udi = '/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1_mmc_host'
  info.category = 'mmc_host'  (string)
  linux.sysfs_path = '/sys/class/mmc_host/mmc1'  (string)
  info.parent = '/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1'  
(string)
  linux.subsystem = 'mmc_host'  (string)
  info.capabilities = { 'mmc_host' } (string list)
  info.subsystem = 'mmc_host'  (string)
  info.udi = '/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1_mmc_host' 
(string)
  mmc_host.host = 1  (0x1)  (int)
  mmc_host.slot_name = 'internal'  (string)
22: udi = '/org/freedesktop/Hal/devices/platform_mmci_omap_hs_0_mmc_host'
  info.category = 'mmc_host'  (string)
  linux.sysfs_path = '/sys/class/mmc_host/mmc0'  (string)
  info.parent = '/org/freedesktop/Hal/devices/platform_mmci_omap_hs_0'  
(string)
  info.addons = { 'hald-addon-mmc' } (string list)
  linux.subsystem = 'mmc_host'  (string)
  info.capabilities = { 'mmc_host', 'button' } (string list)
  info.subsystem = 'mmc_host'  (string)
  info.udi = '/org/freedesktop/Hal/devices/platform_mmci_omap_hs_0_mmc_host' 
(string)
  mmc_host.host = 0  (0x0)  (int)
  mmc_host.slot_name = 'external'  (string)
66: udi = '/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1'
  linux.sysfs_path = '/sys/devices/platform/mmci-omap-hs.1'  (string)
  info.linux.driver = 'mmci-omap-hs'  (string)
  platform.id = 'mmci-omap-hs.1'  (string)
  info.product = 'Platform Device (mmci-omap-hs.1)'  (string)
  info.udi = '/org/freedesktop/Hal/devices/platform_mmci_omap_hs_1'  
(string)
67: udi = '/org/freedesktop/Hal/devices/platform_mmci_omap_hs_0'
  linux.sysfs_path = '/sys/devices/platform/mmci-omap-hs.0'  (string)
  info.linux.driver = 'mmci-omap-hs'  (string)
  platform.id = 'mmci-omap-hs.0'  (string)
  info.product = 'Platform Device (mmci-omap-hs.0)'  (string)
  info.udi = '/org/freedesktop/Hal/devices/platform_mmci_omap_hs_0'  
(string)
Comment 4 Andre Klapper maemo.org 2009-10-27 16:30:17 UTC
Thanks. Actually I just forwarded the questions in the internal ticket.
Comment 5 Andre Klapper maemo.org 2009-12-01 17:54:17 UTC
*** Bug 6367 has been marked as a duplicate of this bug. ***
Comment 6 mustali 2009-12-07 10:58:59 UTC
The issue may be one of these files:
/home/user/MyDocs/.volbak
/home/user/MyDocs/.VolumeIcons.icns

I routinely rsync the MyDocs folder to my computer in order to restore it after
a full flash (fw + eMMC). When I restore the MyDocs folder after a full flash,
the problem reappears. Today, I removed the .volbak and .VolumeIcons.icns files
before the rsync and the problem is gone. The File-Manager does not duplicate
the hidden folders any more.

Unfortunately, I deleted the files instead of moving them out of the folder so
I can't duplicate it anymore. But I am fairly certain this is the issue.
Comment 7 Darren Long 2009-12-07 14:21:13 UTC
I have this problem as well.  Furthermore, it seems that every time I plug the
device into my Mac and allow the media to be mounted then unmounted, additional
new copies of these same directories are now visible in File Manager.

I'm not even sure how or why these directories are presented in the file
manager, as I can't find them in the shell.

--

Software version: 1.2009.42_11.203.2

Steps to Reproduce the problem:
1) Plug device into Mac OS X computer (10.6.1) and let it mount the device
media
2) Unmount the device media in Mac OS X and then unplug the device to Mac USB
connection
3) Open file manager and observe the number of instances of the directories
visible, specifically those mentioned in the initial bug report.

Expected Outcome:
There should be only 1 instance of each of the mentioned directories visible.

Actual Outcome:
There will be n+1 instances of each of the mentioned directories, where n is
the number of instances observed last time this process was carried out.

Reproducibility:
For me, 100% consistent, and furthermore, the affects are cumulative.  I've had
n up to 4 so far.  After a reboot, n seems to reduce to 2.
Comment 8 Andre Klapper maemo.org 2009-12-07 14:29:35 UTC
(In reply to comment #7)

Thanks, appreciated!

> I'm not even sure how or why these directories are presented in the file
> manager, as I can't find them in the shell.

They should be under /home/user/MyDocs . Some of them will start with a . which
makes them hidden. Also see the output of "ls -l" in that directory.
Comment 9 arnim sauerbier 2009-12-11 22:03:50 UTC
Confirmed:
Comment 10 Lari Tuononen 2009-12-13 22:35:57 UTC
I got the same problem also, the folders were duplicated. Removing the
.VolumeIcons.icns as mustali suggested, fixed the problem.
Comment 11 Andre Klapper maemo.org 2009-12-14 19:37:47 UTC
If you have this bug, can you attach your file
/home/user/.config/user-dirs.dirs, and check with the terminal if you have the
directories, and if the content matches what you see in the File Manager?
Comment 12 Darren Long 2009-12-14 19:57:57 UTC
Nokia-N900-42-11:~# cat /home/user/.config/user-dirs.dirs
XDG_DOCUMENTS_DIR="$HOME/MyDocs/.documents"
XDG_MUSIC_DIR="$HOME/MyDocs/.sounds"
XDG_PICTURES_DIR="$HOME/MyDocs/.images"
XDG_VIDEOS_DIR="$HOME/MyDocs/.videos"
NOKIA_CAMERA_DIR="$HOME/MyDocs/DCIM"
NOKIA_MMC_CAMERA_DIR="/media/mmc1/DCIM"
--
I've confirmed that the duplicate folders shown in File Manager contain the
same content as the hidden directories referenced in the file listing above.

At this time, I only have one set of duplicate entries shown in file manager.
Comment 13 Andreas Behr 2009-12-16 13:16:55 UTC
I see, that somebody else watching this bug has a Mac. 
I used a sync software to upload my music to the N900. Could there be a
connection?

Has everbody with this bug a Mac?
Comment 14 Martin Grimme 2009-12-16 13:25:56 UTC
I sometimes experience this not only with the default folders but also with
regular files and folders on the MicroSD card.
Comment 15 mustali 2009-12-22 16:48:31 UTC
Nokia-N900-42-11:/home/user/MyDocs# cat /home/user/.config/user-dirs.dirs
XDG_DOCUMENTS_DIR="$HOME/MyDocs/.documents"
XDG_MUSIC_DIR="$HOME/MyDocs/.sounds"
XDG_PICTURES_DIR="$HOME/MyDocs/.images"
XDG_VIDEOS_DIR="$HOME/MyDocs/.videos"
NOKIA_CAMERA_DIR="$HOME/MyDocs/DCIM"
NOKIA_MMC_CAMERA_DIR="/media/mmc1/DCIM"

this matched what is shown in the File-Manager except that the folders were
duplicated.
Comment 16 mustali 2009-12-22 16:51:46 UTC
The duplicated folders started showing up last week after I copied over 3GB of
video files. After doing some routine clean up of MyDocs, deleting some
unwanted files, the duplicated entries are now gone.

Nokia-N900-42-11:/home/user/MyDocs# ls -l
drwxrwxrwx    2 user     root        65536 Nov  8 13:26 DCC Downloads
drwxrwxrwx    2 user     root        65536 Dec 22 14:19 DCIM
drwxrwxrwx    2 user     root        65536 Nov 12 10:39 Downloads
drwxrwxrwx    2 user     root        65536 Dec 21 23:06 MooBox
drwxrwxrwx    3 user     root        65536 Dec 11 23:16 My downloads
drwxrwxrwx    6 user     root        65536 Dec 15 14:57 Podcasts
-rw-r--r--    1 user     root           25 Oct  8 12:54 autorun.inf
drwxrwxrwx    3 user     root        65536 Nov 23 21:10 backups
drwxrwxrwx    3 user     root        65536 Dec 15 07:58 cities
drwxrwxrwx    3 user     root        65536 Dec 22 15:41 dvd
drwxrwxrwx    8 user     root        65536 Oct 16 17:02 ebooks
drwxrwxrwx    3 user     root        65536 Nov 11 14:35 qik
-rw-r--r--    1 user     root           21 Nov 25 21:08 resolv.conf
drwxrwxrwx    7 user     root        65536 Dec 22 15:43 tmp
drwxrwxrwx    3 user     root        65536 Nov  8 18:55 vpn
Comment 17 Andre Klapper maemo.org 2010-01-04 16:35:07 UTC
*** Bug 7632 has been marked as a duplicate of this bug. ***
Comment 18 Simon 2010-01-16 23:15:27 UTC
I repoduced this bug (as did other people with the norwegian version of the
phone that I have talked to) after firmware upgrade in january. in addition my
mediaplayer and photo album can't find any media in my folders.
Comment 19 gerrymoth 2010-01-18 17:34:47 UTC
(In reply to comment #6)
> The issue may be one of these files:
> /home/user/MyDocs/.volbak
> /home/user/MyDocs/.VolumeIcons.icns

I'm getting dupplicate folders, but don't seem to have these files to actually
delete?
Comment 20 mustali 2010-01-18 17:44:15 UTC
issue still there after PR1.1 without the .volbak and .VolumeIcons.icns files

~/.config $ osso-product-info
OSSO_PRODUCT_HARDWARE='RX-51'
OSSO_PRODUCT_NAME='N900'
OSSO_PRODUCT_FULL_NAME='Nokia N900'
OSSO_PRODUCT_RELEASE_NAME='Maemo 5'
OSSO_PRODUCT_RELEASE_FULL_NAME='Maemo 5'
OSSO_PRODUCT_RELEASE_VERSION='2.2009.51-1'
OSSO_PRODUCT_WLAN_CHANNEL='fcc/us'
OSSO_PRODUCT_KEYBOARD='English, Dutch'
OSSO_PRODUCT_REGION='Netherlands'
OSSO_PRODUCT_SHORT_NAME='Nokia N900'
OSSO_VERSION='RX-51_2009SE_2.2009.51-1_PR_MR0'

~/.config $ cat user-dirs.dirs 
XDG_DOCUMENTS_DIR="$HOME/MyDocs/.documents"
XDG_MUSIC_DIR="$HOME/MyDocs/.sounds"
XDG_PICTURES_DIR="$HOME/MyDocs/.images"
XDG_VIDEOS_DIR="$HOME/MyDocs/.videos"
NOKIA_CAMERA_DIR="$HOME/MyDocs/DCIM"
NOKIA_MMC_CAMERA_DIR="/media/mmc1/DCIM"
Comment 21 Neil MacLeod maemo.org 2010-01-19 13:10:47 UTC
*** Bug 8263 has been marked as a duplicate of this bug. ***
Comment 22 arnim sauerbier 2010-01-20 06:16:43 UTC
Created an attachment (id=2058) [details]
pupnik pr 1.1 osso-product-info
Comment 23 arnim sauerbier 2010-01-20 06:18:38 UTC
Created an attachment (id=2059) [details]
pupnik pr 1.1 mount info
Comment 24 arnim sauerbier 2010-01-20 06:19:31 UTC
Created an attachment (id=2060) [details]
pupnik pr 1.1 hal-device |grep mmc
Comment 25 Tom Waelti 2010-01-20 12:07:45 UTC
You can probably reproduce this bug when using my "recaller" widget
(extras-devel). After recording something (dictaphone, voice call) and stopping
the recording, open the File Manager and look at your "N900" folder (MyDocs).
You might well see double folders.
In addition, the recording does not show up with the proper filename. However,
if you open X-Term, cd to /home/user/MyDocs and do a ls, you will see it with
the correct filename. Also, if you open the recording (opens it in Media
Player), the filename is properly shown, too.
What mechanism is used in File Manager to display the contents of MyDocs?
Something with tracker?
Comment 26 Darin Burris nokia 2010-01-23 00:16:06 UTC
I attempted to delete a duplicate folder that was empty, and both folders, the
original as well as the duplicate, were deleted.
Comment 27 Venomrush 2010-01-25 19:33:45 UTC
> You can probably reproduce this bug when using my "recaller" widget
> (extras-devel). 

After I installed 'recaller' I experienced double folder as well.
Comment 28 Venomrush 2010-01-25 19:38:08 UTC
I've seemed to fixed the issue by removing pretty much all the random files.

In my /home/user/MyDocs/ I now only have the following files:

.n900.ico
autorun.inf
Nokia_N900_UG_en.pdf
quicknote.s3db

Before when the issue exists, among .VolumeIcons.icns I noticed a random .-
file among another strange looking file.
Comment 29 Andre Klapper maemo.org 2010-01-27 15:58:53 UTC
(Adding a few words to the summary so it's easier to find)
Comment 30 Andre Klapper maemo.org 2010-01-27 15:59:02 UTC
*** Bug 8571 has been marked as a duplicate of this bug. ***
Comment 31 tratrafe2 2010-01-27 21:39:39 UTC
i just followed Comment #28 from Venomrush way to resolve this bug, and after a
reboot it was just fine :)
Comment 32 Simon 2010-01-29 14:52:25 UTC
(In reply to comment #31)
> i just followed Comment #28 from Venomrush way to resolve this bug, and after a
> reboot it was just fine :)
> 

I have the same problem.. and see you have fixed yours, excuse my ignorance but
how do you actually do this? I can't find that path in file manager, do I have
to use xterm? and if so how do I do this as I really don't know.

Any help is appreciated.

Simon
Comment 33 tratrafe2 2010-01-29 14:57:59 UTC
(In reply to comment #32)
> (In reply to comment #31)
> > i just followed Comment #28 from Venomrush way to resolve this bug, and after a
> > reboot it was just fine :)
> > 
> 
> I have the same problem.. and see you have fixed yours, excuse my ignorance but
> how do you actually do this? I can't find that path in file manager, do I have
> to use xterm? and if so how do I do this as I really don't know.
> 
> Any help is appreciated.
> 
> Simon
> 

connect it on your pc, windows linux, whatever and search for the files;p
Comment 34 Uwe Kaminski 2010-01-29 15:07:31 UTC
If it is that easy may a step by step description would be nice. If I would
delete all files in ~/MyDocs but the 4 files in commen 28 I think I would loose
important stuff too. I would love to know how to solve this issue because then
I get the chance to see what happens before it appears again.

But I also know that this bug tracker is not the right place for that. Please
use:
http://wiki.maemo.org/Bug_5838
for that. Thanks, Uwe
Comment 35 tratrafe2 2010-01-29 15:11:03 UTC
listen what i did...

i moved all the files but i kept
.n900.ico
autorun.inf
Nokia_N900_UG_en.pdf
quicknote.s3db
and all the folders
 in a new folder at my pcs desktop 
i disconnected my phone from the pc
i reconnected it
i moved all the files back to the phone
and i reboot N900

that worked for me :)
Comment 36 Venomrush 2010-01-29 15:41:52 UTC
(In reply to comment #34)
> If it is that easy may a step by step description would be nice. If I would
> delete all files in ~/MyDocs but the 4 files in commen 28 I think I would loose
> important stuff too. 

You move the files you keep to a different folder ie MyDocs/backup...
Comment 37 Venomrush 2010-01-29 15:42:50 UTC
*want to keep to a different location, then move it back after it's fixed
Comment 38 Simon 2010-01-29 15:56:06 UTC
(In reply to comment #37)
> *want to keep to a different location, then move it back after it's fixed
> 

Thanks for the help and super quick responses. I have tried following the steps
above and I still have duplicate folders. I am sure it is something I am or am
not doing but I can't figure it out.

I copied all the 
._
.qf
.Volumeicon.icns
.900.icon
autorun files

to a folder on the pc then deleted them off the N900. Disconnected phone from
PC (did not reboot now) re connected and copied files back except the
.Volume.icns.

Then disconnected and rebooted phone. Still have duplicate folders.

If you can please tell me what I am doing wrong.

Simon
Comment 39 Andre Klapper maemo.org 2010-01-29 15:58:28 UTC
Folks, can you please move this to a forum or to provide email and just poist
the final result here? Thanks!
Comment 40 tratrafe2 2010-01-29 16:09:49 UTC
try this:
after you have the files on your pc and removed from your n900 (except:
.n900.ico
autorun.inf
Nokia_N900_UG_en.pdf
quicknote.s3db
and all the folders)
try a reboot... i didnt try this and i dont know if this will brick your
phone...but Comment #28 from Venomrush tryied the same thing and he was ok.
i dont want to take any responsibilities :)
Comment 41 Lucas Maneos 2010-01-29 19:25:54 UTC
Got this too now, no idea how (I don't use the filemanager that often) but
there was definitely no Mac involved and recaller is not installed either.

There were no problems found by dosfsck and moving ._? & .VolumeIcon.icns out
of the way and rebooting has made no difference.

The only duplicated ("only" 2x each) directories are the ones listed under
/home/user/MyDocs in /home/user/.config/user-dirs.dirs, namely:

/home/user/MyDocs/.documents ("Documents")
/home/user/MyDocs/.sounds ("Audio clips")
/home/user/MyDocs/.images ("Images")
/home/user/MyDocs/.videos ("Video clips")
/home/user/MyDocs/DCIM ("Camera")

However /media/mmc1/DCIM is *not* affected.

(In reply to comment #34)
> But I also know that this bug tracker is not the right place for that. Please
> use: http://wiki.maemo.org/Bug_5838

Gone now :-(
Comment 42 Lucas Maneos 2010-01-31 19:23:46 UTC
I moved everything in /home/user/MyDocs into a subdirectory (problem gone) and
started moving them back one by one until the problem recurred.  Apparently
it's not specific to any one file but happens when the number of directory
entries (including hidden ones) reaches 32:

~/MyDocs $ ls -1a | wc -l # no problem at this state yet
31
~/MyDocs $ touch foo # (or .foo, mkdir, whatever) problem reappears

No reboot required for testing, but filemanager needs to be closed and
re-launched.

Note that apart from the ossofilemanager this affects all file dialogs (eg in
notes, pdf viewer etc) so the bug is likely in libhildonfm2.
Comment 43 Konstantin Starodubtsev 2010-01-31 22:23:07 UTC
Confirming comment #42. Reducing number of entries in /home/user/MyDocs
resolves folder doubling problem.
Comment 44 Simon 2010-02-01 01:32:08 UTC
i just tried method from comment #42 and can confirm its working :)
Comment 45 Simon 2010-02-01 12:17:51 UTC
(In reply to comment #42)
> I moved everything in /home/user/MyDocs into a subdirectory (problem gone) and
> started moving them back one by one until the problem recurred.  Apparently
> it's not specific to any one file but happens when the number of directory
> entries (including hidden ones) reaches 32:
> 
> ~/MyDocs $ ls -1a | wc -l # no problem at this state yet
> 31
> ~/MyDocs $ touch foo # (or .foo, mkdir, whatever) problem reappears
> 
> No reboot required for testing, but filemanager needs to be closed and
> re-launched.
> 
> Note that apart from the ossofilemanager this affects all file dialogs (eg in
> notes, pdf viewer etc) so the bug is likely in libhildonfm2.
> 


Can also confirm this is working. Thanks to all for help...
Comment 46 David Ward 2010-02-27 06:00:52 UTC
(In reply to comment #44)
> i just tried method from comment #42 and can confirm its working :)
> 

I can confirm this DOES NOT work in my case.
Comment 47 Andre Klapper maemo.org 2010-03-05 12:28:14 UTC
This has been fixed in package
libhildonfm 1:2.28.17+0m5
which is part of the internal build version
10.2010.08-19
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 48 Andre Klapper maemo.org 2010-03-15 20:53:54 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 49 Kang Yu 2010-04-18 00:57:43 UTC
reduce the number of file in the folder resolved the problem for me too.