Bug 5835 - Mail for Exchange does not Sync all Information for Google Contacts
: Mail for Exchange does not Sync all Information for Google Contacts
Status: RESOLVED WONTFIX
Product: Synchronization
Mail for Exchange
: 5.0/(1.2009.41-10)
: All Linux
: Unspecified enhancement with 54 votes (vote)
: Harmattan
Assigned To: unassigned
: activesync-bugs
:
:
: 6343
:
  Show dependency tree
 
Reported: 2009-10-27 14:27 UTC by Sanjeev Visvanatha
Modified: 2012-03-24 11:41 UTC (History)
14 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Sanjeev Visvanatha (reporter) 2009-10-27 14:27:16 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
Set up Google Contact Sync with Mail for Exchange.

EXPECTED OUTCOME:
Contact information such as phone and address get synced between Google and the
N900.  Changes to either the N900 contact information or the Google Account
causes an update to occur when Mail for Exchange synchronizes.

ACTUAL OUTCOME:
-The address, phone and other fields in the Google Account do not populate to
the N900.  
-For instance, enter a phone number in a contact card within the Google
account, begin a sync from the N900, and then view that Contact within the N900
- the phone number does not update.
-Or, enter phone number for a contact within the N900, begin a sync from the
N900, and then view that contact within the Google account.  The phone number
does not update.


REPRODUCIBILITY:
(always/sometimes/once)
always

EXTRA SOFTWARE INSTALLED:
none that affects this.

OTHER COMMENTS:
Jaffa proposed the following three possibilities for why this is not working:

   1. Mail for Exchange doesn't support it. 
   2. Google's Exchange server doesn't support it.
   3. ActiveSync doesn't support it.


User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8)
Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4
Comment 1 Andre Klapper maemo.org 2009-10-27 19:12:33 UTC
(In reply to comment #0)
> STEPS TO REPRODUCE THE PROBLEM:
> Set up Google Contact Sync with Mail for Exchange.

For future reference exact steps are welcome here. :)
Comment 2 Sanjeev Visvanatha (reporter) 2009-10-27 21:55:17 UTC
These are the instructions I used to setup Mail for Exchange:

STEPS TO REPRODUCE THE PROBLEM:
-Set up Google Contact Sync with Mail for Exchange using the following
tutorial:
http://www.google.com/support/mobile/bin/answer.py?hl=en&answer=147951
- Sync from the N900 after making a change in the contact card on either the
N900 or from the Google Account.
Comment 3 Mihai Capotă 2009-10-28 13:06:34 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Andre Klapper maemo.org 2009-11-26 18:32:44 UTC
Note that usage of Google with Mail for Exchange is currently NOT officially
supported.
Comment 5 hex 2009-12-02 10:59:50 UTC
(In reply to comment #4)
> Note that usage of Google with Mail for Exchange is currently NOT officially
> supported.
> 

First, I confirm that this bug is a bug.

Regarding the above statement, that's like saying it doesn't support any entity
'officially'. Really makes no sense. Google has licensed the same software from
MSFT as we use in our day-to-day work (sans BB users). There are over 100 EAS
policies and nearly as many ways to configure server-side. However, Google's
setup is loose, just doesn't synch email or tasks right now. I've had this
working with Google on several devices both with native EAS clients and 3P
clients (e.g. RoadSync on S60 and Android, and TouchDown). N900's EAS client is
the only one I've had trouble with.

Without another way to integrate with Google, the N900 MfE (least desirable)
needs to support Google OR implement a much leaner way to synch with Google
using their open APIs like others do (much more desirable for a few reasons).

There's always an option of even getting OVI to synch :-) but that should be a
user-decided option.
Comment 6 Peter Antoniac 2009-12-02 11:14:08 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Note that usage of Google with Mail for Exchange is currently NOT officially
> > supported.
> Without another way to integrate with Google, the N900 MfE (least desirable)
> needs to support Google OR implement a much leaner way to synch with Google
> using their open APIs like others do (much more desirable for a few reasons).

For me this is a show stopper for N900. I have it, I like it, but I cannot sync
the contacts. It use to work ~nicely in the S60, why not on this? You don't
have to support it, but at least check what seems to have caused the problem.
There are very few options to sync. I am a 100% linux user. I have no M$
computers around that I could sync with and that MfE with Google seem to have
been to most reasonable OTA solution. The OVI has issues on S60 even. So,
unless you provide with alternatives that you support and that are
cross-platform and OTA, I don't see a way forward with the N900...

Thanks,
Peter
Comment 7 hex 2009-12-05 23:26:55 UTC
I spent a few hours last night to do some specific testing on this against both
Google and my corporate account on Exchange 2007 both using activesync.

For testing various aspects (mail, contacts, calendar) I set MfE to synch all,
then each individually. I found major issues with both calendar and contacts
and some minor (but livable) with mail. Obviously, for this, I'll stick with
contacts.

When I say 'never', take that as 'doesn't make it' since it may attempt to, but
not properly so just using the term for lack of a more appropriate/better one.

Here is what I found is true for both Google and corp exch07:

- Any updates or deletes to contacts on the N900 that were pulled over from the
server are never synch'd back to the server even if the 'details' log shows
that they were (not granular, but will show high level an update or delete was
synch'd).

- Any contact merges (update + delete: or add + two deletes ultimately) are
never synch'd back to the server.

- Contacts created on the N900 DO synch to the server and is added to address
book.

- Edit contacts that were created on the N900 and already synch'd - the updates
do synch to the server.

- Delete a contact that was created on the N900 and the delete is synch'd
properly with the server.

- Contacts pulled from server: all fields are not pulled. Never more than 3
numbers, 3 emails (which are random and changes between full mfe reset), notes
are never pulled over and only 1 IM address, which is random if there are
multiple (I have contacts with 3 or 4). For personal stuff (probably more
google specific), the number of fields need to increase A LOT.

- Line items by itself to emphasize: Notes are NEVER pulled over or synch'd.

Missing notes and not properly synching them is a big one.

Field limitation is another big one. Contacts with more than 3 numbers and I
need a number that is not synch'd is a problem - especially when I find out
after flying somewhere and looking to contact someone (one example). Also, my
own contact information - I keep 7 numbers in there. Must have on phone. I know
this is not only a show stopper, but a non-starter for many people I know/work
with.

I've had to create multiple entries for myself on the N900 since it doesn't
bring over all the information, but I absolutely need it. Plus I have to
manually create the notes.

I've been on devices for so many years that do this fine, I can't remember not
having this information available w/out thinking about it. Sometimes have had
to use 3P software (S60, Android at first), but that doesn't exist for Maemo.

I didn't test some of the more granular things such as: is it really random, or
does it just appear that way? Or, if I create a contact with 7 numbers and 4
email addresses, does it all land on the server? I wanted to provide more
things to be reviewed from a bit of a higher level, which should lead down the
road of answer the other questions. Of course, if anyone wants to help by
picking some more testing up, great.

I'm sure I don't have to mention that it is very important to pay attention to
Google and integration with them. MfE needs it since a lot of
companies/gubmints have moved, in the process of moving or evaluating. However,
I think we need a synchml integration (w/out having to rely on an untrusted 3P)
as well since many companies/gubmints won't, but it is very popular for people
to use for personal. This saves MfE for corp integration. Not trying to preach,
but based on the 'not officially supported' comment, want to make sure the
focus is appropriate and I agree with Peter - this could be a limiting factor
for the N900. Android devices aren't taking off because they are the best, much
(if any) cheaper or look cool. Course, the N900 is a bit fat and overweight :-)
Comment 8 Vitaly Repin 2009-12-06 10:35:17 UTC
(In reply to comment #7)
At first, thanks a lot for meaningful and very detailed comment.
Let me ask you additional questions.

> Here is what I found is true for both Google and corp exch07:
> 
> - Any updates or deletes to contacts on the N900 that were pulled over from the
> server are never synch'd back to the server even if the 'details' log shows
> that they were (not granular, but will show high level an update or delete was
> synch'd).

Could you explain it a little bit more?  The contact from the server had
appeared in your address book, you have changed it in the address book and you
can not see the updated fields in the server.  Have I got you right?

What modifications were you doing with the contact in address book?  Was it
editing of the fields, adding new fields?  What fields were you using?

> - Any contact merges (update + delete: or add + two deletes ultimately) are
> never synch'd back to the server.

Yes.  This is not a bug but rather a feature.

> - Contacts pulled from server: all fields are not pulled. Never more than 3
> numbers, 

Yes.  MfE protocol limitation.

> 3 emails (which are random and changes between full mfe reset),

Could you provide more details about this?  Do you mean that the contact is the
same on the server (is not modified), you are doing "full resync" and different
e-mals of the same contact are synced to the device?

> notes are never pulled over 

Calendar notes or contact notes? Calendar notes are not synced.

> and only 1 IM address, which is random if there are
> multiple (I have contacts with 3 or 4).

IM address is synced????  It shall not.  Will check it out.

> For personal stuff (probably more
> google specific), the number of fields need to increase A LOT.

Ask MS to do this.

> Field limitation is another big one. Contacts with more than 3 numbers and I
> need a number that is not synch'd is a problem - especially when I find out
> after flying somewhere and looking to contact someone (one example). Also, my
> own contact information - I keep 7 numbers in there. Must have on phone. I know
> this is not only a show stopper, but a non-starter for many people I know/work
> with.

Hm.  Do they have this functionality on any other phone???  MS ActiveSync
protocol has certain limitations regarding the fields which can be synced.  In
fact in development time we have created a possibility to store EVERYTHING in
one of the contact's text fields.  But this is a hack.
Comment 9 Alex Smirnoff 2009-12-06 15:28:45 UTC
From pure practical, yet not quite consistent point of view, i'd prefer to
have:

google contacts as more-or-less accurate copy of on-device contacts, any vice
versa sync should be made extremely carefully to avoid breaking contact records
on the device (as n900 addressbook is more "advanced" and counts as "primary")

on-device calendars as more-or-less accurate copy of Google calendars, as both
are pretty basic and there are multiple calendars, it is up to user to choose
precedence, but google side is more handy.

So it is highly desirable to have precedence setting to be granular (for
addressbook and for any given calendar, not just all of them)
Comment 10 James Dempsey 2009-12-07 00:04:05 UTC
I'm not sure what the underlying data structures are, but even for the Name
fields, not all of the data is sync'd.  Let me give you an example.  I have a
contact on Google with the name "Acton Boxborough Regional High School
Attendance Line".  On the N900, this shows up as "Acton Line".  The other data
is completely dropped.

It appears it uses the first token as the first name and the last token as the
last name and completely ignores everything in between.  To me, this is
unacceptable.

This means that if I have two contacts "Tom A. Jones" and "Tom B. Jones" they
will both show up as "Tom Jones" with no way to distinguish them

It also means (though I haven't tried this) that if I have a contact called
"Thomas Jones IV" it will show up as "Thomas IV".

Must be fixed.
Comment 11 Peter Antoniac 2009-12-07 10:22:05 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > For personal stuff (probably more
> > google specific), the number of fields need to increase A LOT.
> 
> Ask MS to do this.

LOL!

On the other hand, I managed to do better syncs by using the services of Nueva
Sync (as per their testing request here:
http://forum.nuevasync.com/forum/posts/list/324.page#1988) and I managed to get
some sort of consistency between syncs. I am still investigating, but their AS
might be more friendlier than the google's one :(

Hope this help debuging... also confirms that it might be something in google
as well.

Cheers,
Peter
Comment 12 Andre Klapper maemo.org 2010-02-02 21:17:56 UTC
As long as
http://maemo.org/community/brainstorm/view/google_calendar-contacts_synchronization/
is not fixed (which was bug 6343), this is also an enhancement. Hence changing
severity.
Comment 13 Jeff Mitchell 2010-03-22 14:49:11 UTC
(In reply to comment #4)
> Note that usage of Google with Mail for Exchange is currently NOT officially
> supported.
> 

It's funny -- Google with MfE is not officially supported, but if you search
for "Exchange" on the Maemo bug tracker, it seems that Google is the only thing
that people are (trying to) use MfE for in the first place (or alternately
NuevaSync, but only if they couldn't make it work directly with Google).
Comment 14 Andre Klapper maemo.org 2010-04-15 18:16:13 UTC
(In reply to comment #13)
> It's funny -- Google with MfE is not officially supported, but if you search
> for "Exchange" on the Maemo bug tracker, it seems that Google is the only thing
> that people are (trying to) use MfE for in the first place (or alternately
> NuevaSync, but only if they couldn't make it work directly with Google).

No, it's the thing that's most buggy (as it was never tested). The number of
bug reports does not necessarily tell you anything about the amount of users.
;-)
Comment 15 Andre Klapper maemo.org 2011-01-20 15:08:24 UTC
It currently looks to me (int-215880) that this might be available for
Harmattan (the software version after Maemo5), hence setting tentative Target
Milestone.

[Followup disclaimer: This report is NOT a place to ask Harmattan questions.]
Comment 16 Andre Klapper maemo.org 2012-03-24 11:41:53 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )