Bug 5829 - (int-144432) "Select user name" dialog not finger friendly
(int-144432)
: "Select user name" dialog not finger friendly
Status: VERIFIED FIXED
Product: Browser
User interface
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low minor with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: Nagineni Sudarsana Babu
: browser-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-27 10:30 UTC by Uwe Kaminski
Modified: 2010-06-03 19:00 UTC (History)
2 users (show)

See Also:


Attachments
Screenshot (84.06 KB, image/png)
2009-10-27 19:34 UTC, Andre Klapper
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Uwe Kaminski (reporter) 2009-10-27 10:30:42 UTC
SOFTWARE VERSION:
see above.

STEPS TO REPRODUCE THE PROBLEM:
1. Open the mivrob browser
2. Go to https://df-h.de/squirrelmail
3. optional: if you use this url for the first time a certivicate dialogue will
come up. Accept the certificate.
4. enter the following credentials:
   account: modestbug@ju-key.de
   password: modestbug
   login!
5. Let the browser store the password!
6. Log out using the link "Abmelden" in the right upper corner of the
squirrelmail web interface.
7. follow the link "Klicken Sie hier, um sich wieder anzumelden." --> you will
be redirected to the login page again.
8. enter the following credentials:
   account: modestbug2@ju-key.de
   password: modestbug
   login!
9. Let the browser store the password for this account too!
10. Log out using the link "Abmelden" in the right upper corner of the
squirrelmail web interface.
11. follow the link "Klicken Sie hier, um sich wieder anzumelden." --> you will
be redirected to the login page again.

EXPECTED OUTCOME:
A finger friendly dialogue to select the account for these website is shown.

ACTUAL OUTCOME:
Dialogue is not finger friendly. The font is to small. Other browser dialogues
are using a bigger font (e.g. if you tip on a drop down menu).

REPRODUCIBILITY:
always

OTHER COMMENTS:
User-Agent:       Mozilla/5.0 (X11; U; Linux armv7l; de-DE; rv:1.9.2a1pre)
Gecko/20090928 Firefox/3.5 Maemo Browser 1.4.1.15 RX-51 N900
Comment 1 timeless 2009-10-27 18:50:20 UTC
ctrl-shift-p lets you create screen shots, they're saved in
~/MyDocs/.images/Screenshots/ (and they appear automatically in the Image
Viewer ["Photos"]).

For bugs where you experience a visual glitch, please "Create a New Attachment"
<https://bugs.maemo.org/attachment.cgi?bugid=5829&action=enter> containing a
picture of what you see.

Even if it should be reproducible for everyone, it's always a good idea.
Comment 2 Andre Klapper maemo.org 2009-10-27 19:34:01 UTC
Created an attachment (id=1512) [details]
Screenshot

Tested with two GMX mail accounts.
This is WEB-DIA223 and according to the Spec it looks like a bug.
Comment 3 timeless 2009-10-27 20:25:19 UTC
Thanks for the bug report. We didn't seem to notice this while testing :(...

It should be easy to fix. Sadly, my attempts to demo that this bug didn't
require the password manager failed [bug 5855], so i've decided it really is
limited to the password manager :(
Comment 4 Uwe Kaminski (reporter) 2009-11-14 20:13:28 UTC
Not fixed in 1.2009.42-11
Comment 5 timeless 2009-11-14 22:48:22 UTC
Since we haven't claimed the bug is fixed, that's hardly a surprise. please do
us a favor and don't make such comments in other bugs.

Note that the browser is long since frozen for the first service release, so
don't expect this or most other bugs to be fixed in it either.
Comment 6 Andre Klapper maemo.org 2010-01-13 18:24:54 UTC
This has been fixed in package
tablet-browser-controls
which is part of the internal build version
2010.02-5
(Note: 2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Andre Klapper maemo.org 2010-03-15 20:51:10 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).