Bug 5799 - RSS reader not well hildonized
: RSS reader not well hildonized
Status: RESOLVED DUPLICATE of bug 5625
Product: RSS feed reader
General
: 5.0/(1.2009.41-10)
: N900 Linux
: Low enhancement (vote)
: ---
Assigned To: unassigned
: rss-feed-reader-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-26 14:45 UTC by pancake
Modified: 2009-10-26 18:03 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description pancake (reporter) 2009-10-26 14:45:26 UTC
This is the impression I got after testing the RSS reader shipped with the
pre-release n900. (maemo5)

The main window of the RSS application can be hardly improved. Here there are
some tips to enhace the usability.

- left pannel must be more finger friendly
  - add a 'planet' view on top of the subscribed RSSs feeds.
  - toggle with no possible manual panning (fixed size)
  - kinetic scrolling on left panel too
  - bigger icons
  - two line width to store the name
  - no horizontal scrolling (maybe '..' dots if doesnt fit)
  - long press to get info about the RSS (drop (i) icon from the botton bar)
  - long press to remove feeds
  - multiple selection?

- search bar shouldnt be there all the time.
  - search results are confusing, you loss the context of the previous
displayed data
  - allow to search on all?
  - i would find cleaner to have the 'search' option in the application menu
(title click).

- rss view should be able to get the full height of the screen
  - allow to rotate the application (portrait view is better for reading
non-aligned texts
  - toggle body text of RSS (smarter view).
  - planet view (display ALL RSS feeds in a single view sorting them by date)
  - what's 'sort' action for? (appears in the context menu when long pressing
the right panel)
  - use internal html renderer to display (In settings)

- sharing links
  - There is no 'share' option in the RSS application
  - Would be nice to send RSS links via mail, sms, twitter, identi.ca,
del.icio.us ...
Comment 1 Andre Klapper maemo.org 2009-10-26 15:12:31 UTC
Hi,
please always file only one issue per report.

I currently consider this a duplicate of bug 5625, for stuff not covered by bug
5625 feel free to file separate tickets.

*** This bug has been marked as a duplicate of bug 5625 ***
Comment 2 pancake (reporter) 2009-10-26 17:59:05 UTC
I cannot understand how can you change the ticket as 'resolved' when only one
of the 20 items I have described are dupplicated.

I will open one ticket for each issue, but this will be a mess to manage.
Comment 3 Andre Klapper maemo.org 2009-10-26 18:03:46 UTC
Hi,

(In reply to comment #2)
> I cannot understand how can you change the ticket as 'resolved' when only one
> of the 20 items I have described are dupplicated.

because this report is currently unmaintainable... If you are happier with
changing the resolution from DUPLICATE to INVALID I'm fine with that too.
(For future reference please also set the Version and Hardware field. Thanks a
lot!)