Bug 5797 - Stop music player when unplugging the earphones
: Stop music player when unplugging the earphones
Status: RESOLVED WORKSFORME
Product: Media player
General
: 5.0/(1.2009.41-10)
: All Linux
: Low enhancement with 38 votes (vote)
: ---
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-26 14:16 UTC by pancake
Modified: 2010-04-16 13:52 UTC (History)
16 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description pancake (reporter) 2009-10-26 14:16:18 UTC
This is just an usability tip. No idea where's the best place to post it, so
here's a bug report.

Let's put an example situation

  - you are listening to music while walking to your destination
  - you reach the destination (a silent library)
  - you unplug the earphones to store them in your bag

What's happening?

  - everybody is now listening your music

Expected behaviour:

  - player should pause the music playback until the user press play again.

This behaviour is better because you can stop the music in a simple phisical
movement instead of driving between menus and icons. which is somewhat
difficult in most of situations you face when you need to stop the music to
heard somewhat else.
Comment 1 Daniel Martin Yerga 2009-10-26 14:37:29 UTC
Just a comment: this is working for me everyday, the last time was 20 minutes
ago. Well, it doesn't pause the music but it mutes. 

I'm using a Nokia earphones from a N95. 
I haven't the ones that comes with the N900, so I can't test with them.
Comment 2 Andre Klapper maemo.org 2009-10-26 15:16:29 UTC
Hi,
please file enhancement request with severity==enhancement and set the correct
version. Thanks a lot!
Comment 3 pancake (reporter) 2009-10-26 19:40:49 UTC
I'm using a standard earphones, and in my case the music is not muted/paused or
whatever.

I'm using the firmware that comes with the prerelease one maemo5 (1.2009.41-10)
Comment 4 Andre Klapper maemo.org 2009-10-26 21:06:52 UTC
At least here (44-1) the music is played aloud:

1. Start Media Player > Shuffle (all) songs
2. Plug headphones (AKG K 512)
3. See headphones icon in statusbar
4. Wait for 30 secs
5. Unplug headphones
==> Music is played aloud

1. Plug headphones (AKG K 512)
2. See headphones icon in statusbar
3. Start Media Player > Shuffle (all) songs
4. Wait for 30 secs
5. Unplug headphones
==> Music is played aloud
Comment 5 Andre Klapper maemo.org 2009-10-26 21:55:56 UTC
Now after reading bug 5744 and finding out about that behaviour this might
become a WONTFIX.
Comment 6 Alex 2009-11-26 20:30:25 UTC
(In reply to comment #5)
> Now after reading bug 5744 and finding out about that behaviour this might
> become a WONTFIX.
> 

Do you mean because that behavior presents a workaround? Setting your phone
volume to 0 to create the effect of pausing the media player is far from ideal.
Comment 7 Keywan Najafi Tonekaboni 2009-11-27 01:47:46 UTC
I would recommend a WONTFIX here, because of another use case:

I come to home while listening music through headphones. I plug out the
headphones and put the device on the table to continue listening music, while
doing something (cleaning the kitchen, change clothes ... ;) )

I like the idea of turning off media player easy, but I think this is more a
power user request. 

I started a brainstorm idea about hardware keys which control media player.
This would be a easy solution usable for power users as mainstream users as
well. 

http://maemo.org/community/brainstorm/view/hardware-keys_should_control_media-player-even_when_locked
(unfortunately they messed it up, by choosing a strange solution)
Comment 8 Ville Reijonen 2009-12-09 10:00:30 UTC
For OS2008 (N800, N810), there exists Headphone daemon to do exactly what this
enchantment request is for, probably it will be ported in some point. See.
http://maemo.org/downloads/product/OS2008/headphoned/
Comment 9 rEv9 2009-12-09 15:23:10 UTC
This is irritating for me as well. Not only does this happen with the in ear
plugs, but with my bluetooth headset too. When I turn off my headset/disconnect
it from the device the music is redirected to the speakers on my device rather
than pause it.
Comment 10 Tim Ashman 2009-12-09 16:21:52 UTC
Do not do this please unless you give the users the ability in settings to turn
the feature back off.  I routinely switch between headphones and speakers while
listening and would not feel this was an improvement if I had to restart what I
was already listening to everytime I did this.
Comment 11 Tuoyo Ejueyitchie 2009-12-11 02:31:18 UTC
I am not sure how this affects phone calls.  If you are listening to music with
headphones and then you get a call and you disconnect the headphones to take
the call at the end of the call with the music immediately resume from the
speakers?  If so I think it is essential this is fixed because of those not
using headphones with built in speakers.
Comment 12 Andre Klapper maemo.org 2010-01-04 12:49:30 UTC
*** Bug 6965 has been marked as a duplicate of this bug. ***
Comment 13 Paul van Tilburg 2010-01-04 15:29:37 UTC
It could also pop up a dialog to just ask "Do you want me to play through the
speakers now?" which the options: Yes/No/Always/Never. The dialog should
automatically disappear when the headphones are plugged in again.

Question remains how to change the behaviour after pressing Always or Never at
a later point.
Comment 14 Alexander 2010-01-05 00:47:46 UTC
SonyEricsson mobile phones pause playback when headphones are unplugged and
asks if you want to continue playing through the speakers. There are only
Yes/No options.
Comment 15 Clayton 2010-01-05 00:55:45 UTC
(In reply to comment #13)

Always off/on would be excellent, the option to change it could be added to the
media player settings menu (next to fm transmitter, etc) for example.

I've had my battery drained countless times because I migrated from an iPhone,
so I'm used to unplugging headphones when I'm finished listening to music, and
expecting it to quit playback. The headphone/speaker volume differences helps
in solving the embarrassment of loud music blaring when they are unplugged,
however since it keeps playing in the background I find it a major nuisance to
have to manually stop playback each time.
Comment 16 Tim Watt 2010-01-05 03:29:11 UTC
I would like to add a semantic correction "Pause" music player when unplugging
the earphones.
Comment 17 Andre Klapper maemo.org 2010-01-05 13:42:27 UTC
As it seems that there are several potential "solutions" for this (don't do it,
do it, ask the user for stop vs continue, ask the user for stop vs pause vs
continue), I kindly ask you to move this to Brainstorm instead.
Comment 18 Andre Klapper maemo.org 2010-01-05 13:42:46 UTC
The scope of bugs.maemo.org are bugs and only very specific and no-brainer
enhancement requests. This report contains a feature request that is too
generic for bugs.maemo.org. Please post this problem and propose your
solution in Maemo Brainstorm instead:
  http://maemo.org/community/brainstorm/

More information: http://wiki.maemo.org/Maemo_brainstorm
Comment 19 Neil MacLeod maemo.org 2010-01-12 10:16:38 UTC
http://maemo.org/community/brainstorm/ isn't working, the page fails to load
with the following error:

Fatal error: Maximum execution time of 30 seconds exceeded in
/mnt/netapp/pear/midcom/lib/midcom/core/privilege.php on line 651

I disagree that this should be resolved in Brainstorm - the solution is obvious
and has been proposed in comment #13, it would work to everyone's satisfaction.

Please implement it. Pushing this bug out to Brainstorm effectively kills what
is a total no-brainer enhancement.
Comment 20 Clayton 2010-01-12 10:18:45 UTC
(In reply to comment #19)
> Pushing this bug out to Brainstorm effectively kills what
> is a total no-brainer enhancement.
> 

I agree, if it doesn't kill it, it at least delays it MUCH longer than it
should. Comment #13 proposes a very reasonable compromise.
Comment 21 rEv9 2010-01-12 23:10:25 UTC
I have already commented on this, but this have begin to really, really annoy
me. 
Earlier today: I went home from work with the bus. Sitting there listening to
music with my bluetooth headphones, the sound suddenly stopped playing. I
listened to a radio stream so I'll just sat there and waited for the stream to
buffer up, as I thought it would. 
Well, it didn't.  
The bus was so packed that it didn't want to pick up the phone from my jacket
to disconnect-connect/stop-play/whatever to fix it, as it would be a hassle. A
few seconds later, the full bus was listening to this annoying sang that the
radio had put one while my bluetooth headphones had disconnected(?!) and the
N900 was now broadcasting this song to everyone on my bus! A while, that seems
to never end, later I had picked up the phone and turned the player off while
all these people stared at me. The bluetooth headphones automatically
reconnected a few seconds later, but that's not what this bug is all about... 
This shouldn't happen - and should be fixed or added as an option, period.
Comment 22 Neil MacLeod maemo.org 2010-01-12 23:17:50 UTC
Aye, we've all been there... can be very embarrassing. :(

Just as a suggestion, anyone voting for this might want to add a comment "+1
for comment 13" to remove any ambiguity about the solution they're voting for.
I know it might be considered bug spam, but it may remove any doubt that this
is a no brainer and there is a majority decision on the solution.

Of course if I'm wrong and you favour an alternative solution then my apologies
and post away. :)
Comment 23 David Ward 2010-01-13 02:01:40 UTC
+1 https://bugs.maemo.org/show_bug.cgi?id=5797#c13
Comment 24 Andre Klapper maemo.org 2010-01-13 11:53:44 UTC
Reopening as per comment 13 and comment 22.
Comment 25 kv4nbee 2010-01-13 12:13:07 UTC
(In reply to comment #23)
> +1 https://bugs.maemo.org/show_bug.cgi?id=5797#c13
> 

+1
Comment 26 kv4nbee 2010-01-13 12:15:05 UTC
(In reply to comment #23)
> +1 https://bugs.maemo.org/show_bug.cgi?id=5797#c13
> 

+1
Comment 27 Andre Klapper maemo.org 2010-01-13 12:16:23 UTC
Guys, please stop posting uesless "me too" or "+1" comments that spam my inbox.
Vote instead, votes are taken as votes for comment 13.
Comment 28 Tom Waelti 2010-01-14 12:33:37 UTC
Thomas Perl has updated his "headphoned" for fremantle.
It's now available for testing:
http://maemo.org/packages/view/headphoned/
Comment 29 EC 2010-01-18 10:46:06 UTC
(In reply to comment #28)
> Thomas Perl has updated his "headphoned" for fremantle.
> It's now available for testing:
> http://maemo.org/packages/view/headphoned/

This app works well just with wired headphones, it doesn't work with Bluetooth
stereo headsets and that's a pity because I only use Bluetooth for listening to
my music. I need a bettere solution that that.
Comment 30 Uwe Kaminski 2010-04-16 11:21:34 UTC
(In reply to comment #29)
> (In reply to comment #28)
> > Thomas Perl has updated his "headphoned" for fremantle.
> > It's now available for testing:
> > http://maemo.org/packages/view/headphoned/
> 
> This app works well just with wired headphones, it doesn't work with Bluetooth
> stereo headsets and that's a pity because I only use Bluetooth for listening to
> my music. I need a bettere solution that that. 

In the meantime the current version of this application works very well also
with bluetooth headsets. The application is part of maemo extras so this bug
can be closed as fixed.
Comment 31 Vladimir Oka 2010-04-16 11:27:50 UTC
(In reply to comment #30)
> > ...
> > This app works well just with wired headphones, it doesn't work with Bluetooth
> > stereo headsets and that's a pity because I only use Bluetooth for listening to
> > my music. I need a bettere solution that that. 
> 
> In the meantime the current version of this application works very well also
> with bluetooth headsets. The application is part of maemo extras so this bug
> can be closed as fixed.
> 

Providing an application to work around an issue cannot be considered a fix for
the original problem. There may be a project decision not to fix the issue at
all, but then the bug should go to WONTFIX state. I don't think I can change
bug states, but someone should do this properly.
Comment 32 Andre Klapper maemo.org 2010-04-16 13:52:38 UTC
WORKSFORME as per comment 30.