Bug 5791 - Unable to set alternate APN
: Unable to set alternate APN
Status: RESOLVED WONTFIX
Product: Connectivity
ICD
: 5.0/(1.2009.41-10)
: N900 Maemo
: Low enhancement with 44 votes (vote)
: ---
Assigned To: unassigned
: icd-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-26 10:45 UTC by Matteo Nerozzi
Modified: 2012-03-24 11:41 UTC (History)
17 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Matteo Nerozzi (reporter) 2009-10-26 10:45:48 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
 - Menu
 - Control Panel
 - Network settings
 - Connections
 - New

EXPECTED OUTCOME:
You are able to configure a new UMTS - GPRS connection

ACTUAL OUTCOME:
You can only set a new wi-fi connection.

REPRODUCIBILITY:
(always/sometimes/once)
always

EXTRA SOFTWARE INSTALLED:
none

OTHER COMMENTS:
Use case: Vodafone IT has 2 differents APN with 2 different price plan and
cost.
          I can't configure the two different UMTS connectios.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US)
AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.27 Safari/532.0
Comment 1 Andre Klapper maemo.org 2009-10-26 16:48:10 UTC
Hi,
if "Settings > Phone > Network selection" is set to "Manual", does this change
anything?
Comment 2 Matteo Nerozzi (reporter) 2009-10-26 17:34:35 UTC
Hi to you.

I tryed to change the "settings > Phone > Network selection " into "manual" and
I select my telephone operator. 
But i want to configure two ( or more ) APN so going into "settings > Network
settings > Connections > NEW " I'm not able to configure a new internet
connection, I'm only able to create a new wi-fi connection or to modify the
only existing umts connection.

So ... nothing change.
Comment 3 Klaus Anderson nokia 2009-11-02 15:12:47 UTC
(In reply to comment #2)
> But i want to configure two ( or more ) APN so going into "settings > Network
> settings > Connections > NEW " I'm not able to configure a new internet
> connection, I'm only able to create a new wi-fi connection or to modify the
> only existing umts connection.

yes, this is the case. What is the reason that you want to have two different
APNs configured on your device?
Comment 4 Andre Klapper maemo.org 2009-11-02 15:22:13 UTC
(In reply to comment #3)
> yes, this is the case. What is the reason that you want to have two different
> APNs configured on your device?

See comment 0, "Other comments".
Comment 5 Aniello Del Sorbo 2009-11-02 15:23:56 UTC
You might have different data offers from the same provider and you may want to
switch between them.
But it's enough to have one offer that requires an APN different from the
default one and you hit the issue.
For example the standard Tre Italia APN is "tre.it" while the APN for the offer
"Naviga3" is "naviga.tre.it".
Once you run out of megabytes included in the offer you pay as you go. That
price may be more expensive than the default APN and the user would want to
revert to the default APN.

It may not be high priority, but it would be normal (IMHO) to offer the user a
choice of creating a new Connection for the alternate APNs and let him switch.

Aniello
Comment 6 Neven Stanivuk 2009-12-06 03:30:21 UTC
I got a pre-production N900 for a test, and this limitation (bug) among other
smaller issues is THE most frustrating thing about Maemo 5, and a show stopper
for me and my colleagues to order our own N900. 
We also need to switch between 2 APN-s, corporate access, and standard Internet
connection, and this device is making us retype the configuration each time we
need to switch. That's just too much inconvenience.

regards,
n.
Comment 7 Edgardo Calabrese 2009-12-06 07:00:34 UTC
> For example the standard Tre Italia APN is "tre.it" while the APN for the offer
> "Naviga3" is "naviga.tre.it".

While still working for backward compatibility, "naviga.tre.it" is not used
anymore (well, not used since year 2007).

Just use tre.it even for the "naviga tre" data option.

Btw the "one apn only" is still annoying, and there is a wide scenario when the
multiple apn choice can be handy
Comment 8 Andre Klapper maemo.org 2009-12-06 08:55:46 UTC
(In reply to comment #6)
> I got a pre-production N900 for a test, and this limitation (bug)

Please learn that the missing kitchensink in the N900 is not "a bug", but a
missing feature. Calling this issue a bug is just wrong. Thanks.
Comment 9 cyppaxtxa 2009-12-07 11:08:01 UTC
(In reply to comment #8)
> (In reply to comment #6)
> > I got a pre-production N900 for a test, and this limitation (bug)
> 
> Please learn that the missing kitchensink in the N900 is not "a bug", but a
> missing feature. Calling this issue a bug is just wrong. Thanks.
> 

Same issue with Russian MTs. There is a dedicated APN for corporate access and
standard internet.mts.ru for regular internet access. Manually retyping APN
each time is really annoying.
Comment 10 Neven Stanivuk 2009-12-07 23:53:42 UTC
(In reply to comment #8)
> (In reply to comment #6)
> > I got a pre-production N900 for a test, and this limitation (bug)
> Please learn that the missing kitchensink in the N900 is not "a bug", but a
> missing feature. Calling this issue a bug is just wrong. Thanks.

Kitchensink is there, it just sucks the water only one time, then you need to
use the plunger. :-)
Comment 11 janne.koivukoski 2009-12-15 19:59:30 UTC
Actually I can set alternate APN, but I have to set it up manually. It should
be like symbian that you can have several APN:s and those should be stored so
that you can use those after SIM-ard change
Comment 12 him 2009-12-21 11:04:25 UTC
need 2 APN for business and for private use
Comment 13 Daniel Martin Yerga 2009-12-23 18:13:07 UTC
*** Bug 7262 has been marked as a duplicate of this bug. ***
Comment 14 I/O 2009-12-23 21:23:55 UTC
(In reply to comment #12)
> need 2 APN for business and for private use
> 

I too.
Comment 15 Andre Klapper maemo.org 2009-12-28 14:22:52 UTC
Please NEVER add unhelpful "me too" comments to Bugzilla.
This is a bugtracker, not a forum. Feel free to vote though, and/or go to
talk.maemo.org for chatting. Thanks.
Comment 16 Nick Leppänen Larsson 2010-01-03 18:10:51 UTC
Workaround for people who are not afraid to use the commandline:

gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/type --type string
"GPRS"
gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/name --type string
"NEWAPNNAME"
gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/gprs_accesspointname
--type string "internet.example.com"
gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/ipv4_type --type
string AUTO
gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/sim_imsi --type
string YOURSIMIMSI

to get the SIMIMSI:
gconftool -R /system/osso/connectivity/IAP |grep sim_imsi

Not sure if all the above commands are neccessary, but after running that you
can edit "NEWAPNNAME" in the settings
Comment 17 janne.koivukoski 2010-01-03 19:20:58 UTC
Thanks to this workaround. It works for me.
Those type string texts must be at the same row. When copied direct from here
you get errors because of missing text.

This is superb before new firmware.
Comment 18 Micke Nordin 2010-01-06 15:47:54 UTC
(In reply to comment #16)
> Workaround for people who are not afraid to use the commandline:
> 
> gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/type --type string
> "GPRS"
> gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/name --type string
> "NEWAPNNAME"
> gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/gprs_accesspointname
> --type string "internet.example.com"
> gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/ipv4_type --type
> string AUTO
> gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/sim_imsi --type
> string YOURSIMIMSI
> 
> to get the SIMIMSI:
> gconftool -R /system/osso/connectivity/IAP |grep sim_imsi
> 
> Not sure if all the above commands are neccessary, but after running that you
> can edit "NEWAPNNAME" in the settings
> 

This worked for me too, I just wanted to let everyone know that if you want to
remove an APN set in this manner you can do this:

gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/type --type string
none
gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/name --type string
none 
gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/gprs_accesspointname
--type string none
gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/ipv4_type --type
string none
gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/sim_imsi --type
string none

Cheers,

Micke
Comment 19 Stian Jordet 2010-01-07 23:19:23 UTC
This is of course also needed to make the mms efforts possible.
Comment 20 jasaw81 2010-01-20 05:56:36 UTC
(In reply to comment #18)
> (In reply to comment #16)
> > Workaround for people who are not afraid to use the commandline:
> > 
> > gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/type --type string
> > "GPRS"
> > gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/name --type string
> > "NEWAPNNAME"
> > gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/gprs_accesspointname
> > --type string "internet.example.com"
> > gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/ipv4_type --type
> > string AUTO
> > gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/sim_imsi --type
> > string YOURSIMIMSI
> > 
> > to get the SIMIMSI:
> > gconftool -R /system/osso/connectivity/IAP |grep sim_imsi
> > 
> > Not sure if all the above commands are neccessary, but after running that you
> > can edit "NEWAPNNAME" in the settings
> > 
> 
> This worked for me too, I just wanted to let everyone know that if you want to
> remove an APN set in this manner you can do this:
> 
> gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/type --type string
> none
> gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/name --type string
> none 
> gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/gprs_accesspointname
> --type string none
> gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/ipv4_type --type
> string none
> gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/sim_imsi --type
> string none
> 
> Cheers,
> 
> Micke
> 

To remove the NEWAPNNAME completely, you can do:
gconftool-2 --recursive-unset /system/osso/connectivity/IAP/NEWAPNNAME

To check if NEWAPNNAME is still there:
gconftool -R /system/osso/connectivity/IAP
Comment 21 Andre Klapper maemo.org 2012-03-24 11:41:18 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )