Bug 5768 - (int-134847) Inconsistent layout on similar Sharing/VOIP applets
(int-134847)
: Inconsistent layout on similar Sharing/VOIP applets
Status: CLOSED FIXED
Product: Settings and Maintenance
Control panel
: 5.0/(1.2009.42-11)
: N900 Windows
: Low minor (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: control-panel-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-25 03:08 UTC by Gary Birkett
Modified: 2010-03-16 19:28 UTC (History)
2 users (show)

See Also:


Attachments
sharing accounts (52.65 KB, image/png)
2009-10-25 03:11 UTC, Gary Birkett
Details
voip and IM accounts (52.80 KB, image/png)
2009-10-25 03:12 UTC, Gary Birkett
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Gary Birkett (reporter) 2009-10-25 03:08:25 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM:

Inconsistent layout on 2 similar control panel applets.
Open up the control panel applets for:
"VOIP and IM accounts" and "Sharing accounts"
With no accounts configured in either.

EXPECTED OUTCOME:

The UI screens would be expected to be consistent and match each others layout.

ACTUAL OUTCOME:

There are 4 differences on the screens.

http://liqbase.net/Screenshot-20091025-003313.png
http://liqbase.net/Screenshot-20091025-003249.png

Height of the dialogue is different for each, though the screens contain
similar data in a list format.

Positioning of the "no accounts" label is inconsistent and non centred.

Formatting on the "no accounts" and "(no accounts created)" differs.

Width of the "New" button changes between the screens.

not sure which layout format is correct.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

N/A

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.5)
Gecko/2008120122 Firefox/3.0.5
Comment 1 Gary Birkett (reporter) 2009-10-25 03:11:44 UTC
Created an attachment (id=1495) [details]
sharing accounts
Comment 2 Gary Birkett (reporter) 2009-10-25 03:12:09 UTC
Created an attachment (id=1496) [details]
voip and IM accounts
Comment 3 Andre Klapper maemo.org 2009-10-27 15:50:53 UTC
Thanks for reporting this.
Confirming on 44-1.
Comment 4 Andre Klapper maemo.org 2009-11-03 11:37:12 UTC
This has been fixed in package
rtcom-accounts-ui 4.95-3+0m5
which is part of the internal build version
2009.45-7
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 5 Andre Klapper maemo.org 2010-01-14 12:26:49 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 6 Venomrush 2010-03-16 19:28:40 UTC
Verifying fixed in PR1.1