Bug 5750 - Scrollbar doesn't appear in bookmarks view if opened, closed, and later reopened from task launcher
: Scrollbar doesn't appear in bookmarks view if opened, closed, and later reope...
Status: RESOLVED WONTFIX
Product: Browser
Bookmarks
: 5.0/(1.2009.41-10)
: All Maemo
: Low minor with 2 votes (vote)
: ---
Assigned To: unassigned
: browser-bookmarks-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-23 16:58 UTC by timeless
Modified: 2009-11-19 17:23 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description timeless (reporter) 2009-10-23 16:58:53 UTC
SOFTWARE VERSION:
1.2009.41-10
Nokia N900 - Maemo Summit loaner program (verified by Marius Gedminas on
#maemo)

PRECONDITIONS:
Your main bookmarks screen must have at least 7 items, I have precisely 7
items.

STEPS TO REPRODUCE THE PROBLEM:
1. go to the desktop
2. tap the top left corner
3. if you reach the task switcher, close all browser windows, and then tap the
top left corner to reach the task launcher
4. tap the globe (Web, Browser, whatever it's called in your translation)
5. WATCH the right edge of your screen, you should see a gray bar fade away
6. tap a bookmark (preferably for a page that loads quickly)
7. if you haven't turned off the option for "open pages in full screen", tap
the bottom right corner of the window to show the toolbar
8. tap the left most (bookmarks) button on the toolbar
9. WATCH the right edge of your screen, you should see a gray bar fade away
10. tap the top right corner of your screen (this should take you back to your
web browser)
11. tap the left most (bookmarks) button on the toolbar
12. WATCH the right edge of your screen, you should see a gray bar fade away
13. tap the top right corner of your screen (this should take you back to your
web browser)
14. tap the top right corner of your screen (this should close the web browser)
15. close the bookmarks (Web) view
16. if you reach the task switcher, tap the top left corner to reach the task
17. tap the globe (Web, Browser, whatever it's called in your translation)
18. WATCH the right edge of your screen, you should see a gray bar fade away
19. tap the top right corner of your screen (this should close Bookmarks "Web")
20. if you reach the task switcher, tap the top left corner to reach the task
launcher
21. tap the globe (Web, Browser, whatever it's called in your translation)
22. WATCH the right edge of your screen, you should see a gray bar fade away

EXPECTED OUTCOME:
The scroll indicator should appear at each of steps: 5, 9, 12, 18, 22

ACTUAL OUTCOME:
The scroll indicator only appears at steps: 5, 9, 12

REPRODUCIBILITY:
always with 7 main bookmark items

OTHER COMMENTS:
<mgedmin> heh, now I can't retrace my steps from 1 since the bar never shows up

The user experience here is bad, because it means that you won't notice that
bookmarks are scrollable if you open browser once on monday, use a bookmark,
close browser, and then open it again on friday (without the n900 running out
of power / turning off).
Comment 1 Andre Klapper maemo.org 2009-10-26 21:29:50 UTC
Does not even work for #12 in 44-1.

What makes this a bug? I can imagine that when focussing the window for a
second time the scrolling indicator is not displayed in general. Same e.g. in
the Phone settings when having them opened and switching forth and back to
another running app.
Also see bug 5426.
Comment 2 timeless (reporter) 2009-10-26 23:21:12 UTC
scroll indicators exist to tell a user that something is scrollable.

users are not supposed to memorize window states, that defeats the purpose of
having a computer.

users shouldn't have to ask themselves "is this the first time I opened a thing
from this other thing in this session?" nor should they have to experiment
"hrm, lack of scrollbars doesn't mean this thing isn't scrollable, let me check
and see if it is".

note that if you have a folder in bookmarks (with sufficient bookmarks, i have
11 in a folder named "Google"), it /seems/ like each time you open the folder
you'll see a scroll indicator for the folder. but going back doesn't show you a
scroll indicator.

that isn't consistent with the "if they've already seen it" logic.

Already having seen something within a 24 hour period is not logical (or 1000
hours if the devices manage to survive that long).
Comment 3 Andre Klapper maemo.org 2009-11-19 17:23:32 UTC
WONTFIX as bug 5426 basically covers the same argumentation by UI designers.
If you want to discuss this with UI designers feel free to file an internal
ticket.