Bug 5745 - (int-141019) Typing in newly opened window brings up contact search
(int-141019)
: Typing in newly opened window brings up contact search
Status: VERIFIED FIXED
Product: Desktop platform
Home
: 5.0/(1.2009.42-11)
: N900 Maemo
: Low normal with 1 vote (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: home-bugs
:
:
:
: 5825
  Show dependency tree
 
Reported: 2009-10-23 15:42 UTC by Donn Morrison
Modified: 2010-01-14 12:28 UTC (History)
9 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Donn Morrison (reporter) 2009-10-23 15:42:53 UTC
STEPS TO REPRODUCE THE PROBLEM:

1. Go to the application launcher
2. Tap Others
3. Launch X-Terminal
4. Immediately upon seeing the window appear, start typing a command such as
"top" (the shell prompt may not yet be visible)

EXPECTED OUTCOME:

The characters should be buffered and sent to the terminal when the shell
prompt appears.

ACTUAL OUTCOME:

The desktop seems to grab the characters typed (even though the current window
appears to be the newly launched application) and the contact search is
launched with the characters entered as the search string.

REPRODUCIBILITY:

always (if you're fast enough)

OTHER COMMENTS:

I'm using X-Terminal as an example, but this seems to happen with any
application launched, e.g. Photos, Notes, etc.

I didn't really know where to file this bug, so I settled on Contacts, although
something more related to the desktop might be more appropriate.
Comment 1 Marius Gedminas 2009-10-26 13:25:24 UTC
Happens to me with firmware 1.2009.41-10.
Comment 2 Cornelius Hald 2009-10-26 16:56:57 UTC
Happened to me too.

I think this happens while the startup screen shot is shown and the real
application window is not there yet. Probably hildon-desktop is showing this
startup screen shot and thus still is the active application to receive key
input. Just a guess, though.
Comment 3 Andre Klapper maemo.org 2009-10-26 21:52:19 UTC
(In reply to comment #2)
> I think this happens while the startup screen shot is shown and the real
> application window is not there yet. Probably hildon-desktop is showing this
> startup screen shot and thus still is the active application to receive key
> input. Just a guess, though.

Exactly... I wonder whether this startup screen thingy will remain or not...
Wasn't there a mailing list thread about this somewhere?
Comment 4 Andre Klapper maemo.org 2009-10-27 14:50:53 UTC
Fixed in internal week 43 build.
Any public update released with or after this build version (x.2009.43-y) will
include the fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 5 Zach Goldberg 2009-10-27 15:58:13 UTC
Out of curiosity, what is the fix?  Do the keypresses now go to /dev/null if
the application isn't ready or are they queued up inside the application?
Comment 6 Andre Klapper maemo.org 2009-10-27 16:23:42 UTC
Sorry, no idea, I don't have access to that. Looks like the code of
hildon-tasklauncher is not yet available in maemo.gitorious.org either...
Comment 7 Carsten Munk maemo.org 2009-11-16 17:53:33 UTC
Bugfix is probably within the publically developed component hildon-desktop,
version 1:2.2.105-1.

Component can be found at
http://maemo.gitorious.org/fremantle-hildon-desktop/hildon-desktop.
Comment 8 Lucas Maneos 2009-11-16 18:22:34 UTC
*** Bug 6209 has been marked as a duplicate of this bug. ***
Comment 9 Gordon Williams 2009-11-17 14:23:39 UTC
(In reply to comment #5)
> Out of curiosity, what is the fix?  Do the keypresses now go to /dev/null if
> the application isn't ready or are they queued up inside the application?

Yes, keypresses are ignored. If we start queueing them, we'd probably have to
end up queueing + synthesizing mouse events too, and it all gets a bit complex.
Comment 10 Andre Klapper maemo.org 2009-12-30 00:04:39 UTC
*** Bug 7457 has been marked as a duplicate of this bug. ***
Comment 11 Daniel Martin Yerga 2010-01-01 22:30:41 UTC
Verified in non-public PR1.1 version (2.2009.51-1).
Comment 12 Andre Klapper maemo.org 2010-01-14 12:28:50 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.