Bug 5743 - (int-150638) Show ALL installed applications in application menu; get rid of "More..."
(int-150638)
: Show ALL installed applications in application menu; get rid of "More..."
Status: RESOLVED FIXED
Product: Desktop platform
Application Menu
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low enhancement with 11 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: task-navigator-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-23 14:52 UTC by Sanjeev Visvanatha
Modified: 2010-03-15 20:53 UTC (History)
7 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Sanjeev Visvanatha (reporter) 2009-10-23 14:52:04 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
-tap the application menu in the upper left corner.  In the bottom right corner
is an icon labelled "More..."

EXPECTED OUTCOME:
-tap the application menu in the upper left corner.  Use finger scrolling
(up-finger motion) to see more applications that can be launched.  Can scroll
though in one view all the applications on the device.  Jumping pages can be
accomplished by side swipe motions.

ACTUAL OUTCOME:
- must tap the "More..." button to see more applications.  Once in the "More"
area, can scroll up and down on that page, but then need to tap outside to get
to the main page.

REPRODUCIBILITY:
(always/sometimes/once)
always

EXTRA SOFTWARE INSTALLED:
None that affects this

OTHER COMMENTS:
The use of the "More..." button seems to be inconsistent with the rest of the
UI.  If multi-page support is required, perhaps sideways swipes of the screen
can act as a page-up or page-down.  As a user, I would expect to be able to
scroll the entire list of apps in the main view.  


User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8)
Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4
Comment 1 Urho Konttori 2009-11-05 22:46:33 UTC
I'm not entirely against this idea to be honest.
Comment 2 Tim Watt 2009-12-23 23:43:00 UTC
it would be nice to create categories too.
Comment 3 Urho Konttori 2009-12-26 11:05:32 UTC
fixed in pr1.2. there wont be any categories. afaik this is not integrated yet.
so i wont mark it as fixed. but i could be wrong about the timing. it might  be
alerady integrated.
Comment 4 Andre Klapper maemo.org 2009-12-28 14:04:18 UTC
For categories also see bug 3822
Comment 5 Marc Ordinas i Llopis 2010-01-04 21:05:51 UTC
(In reply to comment #2)
> it would be nice to create categories too. 
> 

Categories can still be created by editing the menu files, the change to a flat
menu is just a configuration file change.
Comment 6 Andra┼ż 'ruskie' Levstik 2010-01-10 23:39:11 UTC
Sorry for the bugspam but is this configurable or not? And if so where?
Comment 7 Andre Klapper maemo.org 2010-01-11 00:59:59 UTC
(In reply to comment #6)
> Sorry for the bugspam but is this configurable or not?

This will not be configurable through the User Interface, but by editing
corresponding files on the device. Also see
http://talk.maemo.org/showpost.php?p=442281&postcount=5
Comment 8 Andre Klapper maemo.org 2010-01-29 22:39:44 UTC
This has been fixed in the internal build version
2010.04-11
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 9 Urho Konttori 2010-02-20 22:49:28 UTC
We agreed to do this after deciding to also allow reordering of the menu. This
makes user able to put the most important items in the top, and thus,
hopefully, next to never, have to scroll down at all.
Comment 10 Andre Klapper maemo.org 2010-03-15 20:53:51 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).