Bug 5699 - (int-143995) WLAN regulatory domain changes to US when no position data available
(int-143995)
: WLAN regulatory domain changes to US when no position data available
Status: RESOLVED WONTFIX
Product: Connectivity
WiFi
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified normal with 11 votes (vote)
: ---
Assigned To: unassigned
: wifi-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-22 07:37 UTC by Lucas Maneos
Modified: 2012-01-31 03:50 UTC (History)
9 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Lucas Maneos (reporter) 2009-10-22 07:37:44 UTC
SOFTWARE VERSION:
1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Disable GPS and Network positioning in Settings -> Location.
2. Switch to offline mode.
3. Switch to online mode.
4. Connect to a wireless network.
5. run "dmesg|grep Reg"

Actual location is UK.

EXPECTED OUTCOME:
I'm not quite sure whether tying it to location is a good idea, but at least
in the absence of actual position data the regulatory domain should remain
unchanged.

ACTUAL OUTCOME:
[64042.694946] cfg80211: Regulatory domain changed to country: US

REPRODUCIBILITY:
Always.

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
Step 1 isn't necessary, but helps test this quickly.  With all location options
enabled the regulatory domain oscillates back and forth between US and EU
throughout the day:

Nokia-N900-41-10:~# grep Regu /var/log/syslog
Oct 21 11:33:50 Nokia-N900-41-10 kernel: [    2.438140] cfg80211: Regulatory
domain: US
Oct 21 11:33:50 Nokia-N900-41-10 kernel: [    2.438476] cfg80211: Regulatory
domain changed to country: US
Oct 21 11:34:34 Nokia-N900-41-10 kernel: [   53.368164] cfg80211: Regulatory
domain changed to country: EU
Oct 21 12:17:39 Nokia-N900-41-10 kernel: [ 2636.309326] cfg80211: Regulatory
domain changed to country: US
Oct 21 12:18:25 Nokia-N900-41-10 kernel: [ 2682.791229] cfg80211: Regulatory
domain changed to country: EU
Oct 21 18:07:58 Nokia-N900-41-10 kernel: [23656.791351] cfg80211: Regulatory
domain changed to country: US
Oct 21 18:48:10 Nokia-N900-41-10 kernel: [26068.868743] cfg80211: Regulatory
domain changed to country: US
Oct 21 18:50:55 Nokia-N900-41-10 kernel: [26233.131774] cfg80211: Regulatory
domain changed to country: EU
Oct 21 19:23:00 Nokia-N900-41-10 kernel: [28157.979797] cfg80211: Regulatory
domain changed to country: EU
Oct 21 23:13:18 Nokia-N900-41-10 kernel: [41976.198822] cfg80211: Regulatory
domain changed to country: US
Oct 21 23:13:29 Nokia-N900-41-10 kernel: [41987.774505] cfg80211: Regulatory
domain changed to country: EU
Oct 22 05:13:01 Nokia-N900-41-10 kernel: [63559.798736] cfg80211: Regulatory
domain changed to country: US
Oct 22 05:13:06 Nokia-N900-41-10 kernel: [63564.128997] cfg80211: Regulatory
domain changed to country: EU
Oct 22 05:15:00 Nokia-N900-41-10 kernel: [63678.010223] cfg80211: Regulatory
domain changed to country: EU
Oct 22 05:16:06 Nokia-N900-41-10 kernel: [63744.620330] cfg80211: Regulatory
domain changed to country: US
Oct 22 05:17:42 Nokia-N900-41-10 kernel: [63840.027038] cfg80211: Regulatory
domain changed to country: US
Oct 22 05:21:04 Nokia-N900-41-10 kernel: [64042.694946] cfg80211: Regulatory
domain changed to country: US

(I didn't invent a revolutionary mode of transatlantic travel, honest)

This can be very frustrating if one of your APs is on a channel > 11.
Comment 1 Andre Klapper maemo.org 2009-10-23 14:56:12 UTC
Forwarding the internal comments:

"If we cannot determine the location we must default to US since all devices
must conform to FCC requirements.
In this case location info is just delayed and thus not yet available when
wlancond checks it after device mode changes from offline mode to normal mode. 
In practice only problem is that device does not get connected automatically to
WLAN (if channel is 12 or 13) immediately after mode change.
No problem during next automatic scanning or if user does a manual scanning.
The problem is valid, but there is no feasible fix for it ==> WONTFIX."
Comment 2 Lucas Maneos (reporter) 2009-10-23 15:38:45 UTC
(In reply to comment #1)
> In practice only problem is that device does not get connected automatically
> to WLAN (if channel is 12 or 13) immediately after mode change.
> No problem during next automatic scanning or if user does a manual scanning.

Hm, that seems a bit buggy... Mine had been stuck to US since yesterday,
despite having had several "Fine accuracy" location fixes and cycling
offline/online mode a few times.  After a reboot it switched to EU 79" later.

What are the conditions that trigger a domain change exactly?
Comment 3 Andre Klapper maemo.org 2009-10-23 16:20:29 UTC
(In reply to comment #2)
> What are the conditions that trigger a domain change exactly?

Wlancond get's DBUS signal from changed domain and then on the next connection
the domain is changed to correct one.
Comment 4 Oliver Wagner 2009-12-13 15:56:35 UTC
I think I am also seeing this effect. 

I'm using the N900 as an internet tablet, indoor only, without a SIM card, so
location data will never be available. Unless I'm missing something, there is
currently nothing I can do to make it realize it's in the EU? (this seriously
affects overall usability of the device in my case, therefore I've voted for
this bug, even if it's "WONTFIX" right now)

The device has regional settings, which are set to "Germany" in my case. Could
the WLAN driver perhaps use this as a fallback when no other location
information is available?
Comment 5 Lucas Maneos (reporter) 2010-03-06 08:04:56 UTC
*** Bug 9424 has been marked as a duplicate of this bug. ***
Comment 6 Wouter Cloetens 2010-03-15 00:57:06 UTC
Note that _scanning_ for channel 12 through 14 isn't harmful.

Well-configured access points emit regulatory domain information in their
beacon frames; country code, min/max channel, max transmit power. See 802.11d:
http://en.wikipedia.org/wiki/IEEE_802.11d-2001

That's what you should be using, if available, to learn the regulatory domain,
in precedence to the user's setting or the positioning information.
Comment 7 Lucas Maneos (reporter) 2010-03-18 09:18:08 UTC
*** Bug 9517 has been marked as a duplicate of this bug. ***
Comment 8 Lucas Maneos (reporter) 2010-03-18 09:39:50 UTC
As the duplicate bugs show, this is tied exclusively to the location determined
by the cellular network.  My own tests show that without a SIM installed the
domain stays set to US even with a "fine" GPS fix in effect and several
repeated WLAN scans.  This is both with an Amsterdam summit and a UK retail
device.

Additionally, even with a valid SIM installed the domain gets reset to US
whenever the cellular registration is lost (such as going into a building with
poor radio coverage).

Reopening as I'm fairly sure the current behaviour can be improved without
violating any foreign country violations (I suppose we should consider
ourselves lucky that Spain and France aligned with EU policy or we would be
stuck with channels 10 & 11 only).  Actually, according to
http://en.wikipedia.org/wiki/List_of_WLAN_channels, even in the US channels
12-13 can be used legally in low-power conditions.

I don't want to speculate randomly though, can we have a pointer to the
relevant FCC requirements so we can have an informed conversation about this?
Comment 9 Andre Klapper maemo.org 2010-03-26 14:31:49 UTC
Forwarding internal comment:


(In reply to comment #6)
> Note that _scanning_ for channel 12 through 14 isn't harmful.

That's not true, we are doing active scanning which means that we send probe
requests on each channel.

> Well-configured access points emit regulatory domain information in their
> beacon frames; country code, min/max channel, max transmit power. See 802.11d:
> http://en.wikipedia.org/wiki/IEEE_802.11d-2001
> That's what you should be using, if available, to learn the regulatory domain,
> in precedence to the user's setting or the positioning information."

The keyword is "Well-configured". What if the AP is not well configured? Many
people don't know how to configure their access points.
Comment 10 Wouter Cloetens 2010-03-26 15:01:32 UTC
(In reply to comment #9)
> (In reply to comment #6)
> > Note that _scanning_ for channel 12 through 14 isn't harmful.
> 
> That's not true, we are doing active scanning which means that we send probe
> requests on each channel.

Fair enough.

> > Well-configured access points emit regulatory domain information in their
> > beacon frames; country code, min/max channel, max transmit power. See 802.11d:
> > http://en.wikipedia.org/wiki/IEEE_802.11d-2001
> > That's what you should be using, if available, to learn the regulatory domain,
> > in precedence to the user's setting or the positioning information."
> 
> The keyword is "Well-configured". What if the AP is not well configured? Many
> people don't know how to configure their access points.

People don't configure the regulatory domain or country code of their access
points. AP vendors do, which is why they have different firmware for different
regions sometimes.

Disclaimer: I'm a software architect of a gateway stack that contains an AP
with millions of units deployed.

Even if you don't derive your domain from the beacon frames (it was just a
suggestion), this bug is unacceptable. I'm in Europe, and I cannot use channel
13 on my N900. That is just plain wrong, period.
Comment 11 Oliver Wagner 2010-03-26 15:31:51 UTC
There are a lot of mobile devices without SIM cards or GPS receivers (e.g.
portable media players) which, when bought in Europe, support WLAN channels 12
and 13. I can take those devices to the US easily. How do the manufacturers of
such devices comply to FCC regulations?
Comment 12 Lucas Maneos (reporter) 2010-03-27 09:50:46 UTC
This is quite disappointing, I was hoping to have some dialog, or at least a
pointer to some document that mandates tying the domain to the cellular
registration (personally I doubt such exists, but thankfully it's not my job to
keep track of relevant regulations around the globe).

I'm not even sure what this policy is trying to accomplish besides annoying
non-US users. It's quite possible to set the domain from userland outside
wlancond (pretty much the same way one would do it on a softMAC laptop), we
just have to jump through a few hoops to do it and keep fighting wlancond
whenever it gets the wrond idea.
Comment 13 mgr.d2d 2010-10-17 05:45:33 UTC
This bug needs to be re-activated and fixed. The reason given for its existence
seem reasonable as legal protection for Nokia by defaulting to  the minimum,
but it is ultimately the user who is legally responsible and who must have the
final control.

To not have a user method to override the automatic regulatory domain setting
arbitrarily cripples a *purchased* facility. It also does not allow for future
changes in such.

A case illustrates this:
A wifi signal is permanently, legally, fixed on wifi channel 13 to avoid
interference. A Nokia N900 mobile phone worked reliably using this channel. If
the SIM card is removed this channel cannot be seen. The phone is used for an
important VoIP telephone service but is now unusable simply because another
completely independent service is disabled. This is intolerable, and possibly
illegal here.

My suggestion for a fix is that Nokia produce and release a small app., GUI or
CLI, that changes the default regulatory domain to the user's choice. A
suppressible notification when outside this region could also be incorporated.
Comment 14 Lucas Maneos (reporter) 2010-10-18 18:59:52 UTC
(In reply to comment #13)
> My suggestion for a fix is that Nokia produce and release a small app., GUI or
> CLI, that changes the default regulatory domain to the user's choice.

FYI if you're happy with a CLI solution, "iw set reg <country>" worked mostly
fine when I was using it with PR1.1 (I just rebuilt the debian package).  The
only issue IIRC was wlancond having a different idea of the domain and
resetting it from time to time between associations.
Comment 15 Linus Lüssing 2011-01-22 03:48:54 UTC
(In reply to comment #4)
> I think I am also seeing this effect. 
> 
> I'm using the N900 as an internet tablet, indoor only, without a SIM card, so
> location data will never be available. Unless I'm missing something, there is
> currently nothing I can do to make it realize it's in the EU? (this seriously
> affects overall usability of the device in my case, therefore I've voted for
> this bug, even if it's "WONTFIX" right now)
> 
> The device has regional settings, which are set to "Germany" in my case. Could
> the WLAN driver perhaps use this as a fallback when no other location
> information is available?

Hi there,

One of the main reasons I got the N900 was to be able to use VoIP in different
locations. Therefore, I don't have a SIM card in it either. The flat I recently
moved to offers a WiFi internet connection, which I payed in advance for.
However, now I have to notice that the AP here is running on channel 13, I have
no configuration access to it and I seriously did not expect that the N900
might have problems with that...

Pfeh, this whole regdomain stuff sucks.

Cheers, Linus
Comment 16 Andreas Bauer 2011-08-09 23:38:48 UTC
Today I removed the SIM card from one of my N900 devices and re-installed the
firmware. I own three (3) of them at this time. The first thing that happened
was that I did not get a connection to my AP.

Hit this bug.

Had to Re-Inserted a SIM card again (Nokia this is supposed to NOT be a mobile
phone right? Why do I then have to insert one to get "tablet" connectivity?)

Next the firmware sent out a SMS and subscribed me to "My Nokia" without having
any chance to avoid that. Is that legally allowed?

Got SMS back "Welcome ... blah blah"

Checked the other two bugs in VPN and VoIP connectivity that I have contributed
to in here, same deal. WONTFIX.

There are more bugs which file under "WONTFIX" because the platform already
abandoned. 

My Nokia my a**

Having spent over € 1000 and heavily invested into this platform, this is my
request to Nokia: fix these bugs or release the source code.

Rant over.