Bug 5694 - (int-141640) Application Manager moves to background after start when quickly clicking
(int-141640)
: Application Manager moves to background after start when quickly clicking
Status: RESOLVED FIXED
Product: Desktop platform
Home
: 5.0/(1.2009.42-11)
: N900 Maemo
: Low normal with 3 votes (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: home-bugs
:
: moreinfo
:
: 5825
  Show dependency tree
 
Reported: 2009-10-21 23:10 UTC by Tim Samoff
Modified: 2010-03-04 09:59 UTC (History)
5 users (show)

See Also:


Attachments
Screenshot of funky business (67.42 KB, image/jpeg)
2009-10-23 03:46 UTC, Tim Samoff
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Tim Samoff (reporter) maemo.org 2009-10-21 23:10:17 UTC
SOFTWARE VERSION:
41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Launch App. manager
2. Quickly tap one of the option buttons as soon the application opens

EXPECTED OUTCOME:
Either nothing, or the application remains visible.

ACTUAL OUTCOME:
Application disappears for a couple of seconds (back to desktop), after which,
it reappears. I've even gotten it to perform its actions (e.g., refreshing the
packages) over the desktop rather than within the application UI, but I can't
reproduce that consistently.

REPRODUCIBILITY:
Always.
Comment 1 thomas 2009-10-22 11:49:33 UTC
i was about to report this issue as well. i can always reproduce the "fast tap
- throw back to desktop - reappear again" but have not stumbled upon performing
actions over the desktop.
Comment 2 Andre Klapper maemo.org 2009-10-22 22:18:00 UTC
I've also seen this in 41-10, but cannot see it anymore in 43-9...
I think I've even seen a internal bug report about that a week ago but of
course cannot find it anymore, grumble...

I'm going to set this to moreinfo. I *think* that it is FIXED, if you have
progress to the latest builds would be cool to confirm, otherwise I'll check
again in a week or so.
Comment 3 Tim Samoff (reporter) maemo.org 2009-10-23 03:46:35 UTC
Created an attachment (id=1491) [details]
Screenshot of funky business

I understand this is this most likely fixed in the upcoming firmware, but I
thought I'd attach an example of the HAM functioning over the desktop (and
more).
Comment 4 Daniel Martin Yerga 2009-10-23 16:08:37 UTC
Yes, I have seen this too. But it isn't a problem in the application manager.
It happens to other applications using the "screenshot cheat" (view mailing
list for information), at the moment: XTerminal and Settings. 
In the App Manager is more visible because the start is slower.

Let's to hope this is fixed.
Comment 5 Andre Klapper maemo.org 2009-11-01 17:34:19 UTC
*** Bug 5967 has been marked as a duplicate of this bug. ***
Comment 6 Dieter Plaetinck 2009-11-01 23:38:24 UTC
note that you don't necessarily need to "quickly click" anything. you can also
let the app load, and then just hit a key on the keyboard, it will go in the
background, do a contacts search and then come back
Comment 7 Urho Konttori 2009-11-05 22:45:00 UTC
During the screenshot transition, in the first update version (so, current
master), we are consuming click events until control is given to the
application itself. So, should be already fixed. Feel free to verify as such
when the update is delivered to your door. 

Andre. Feel free to verify this on the PR1.1 release and close.
Comment 8 Andre Klapper maemo.org 2009-11-09 15:53:25 UTC
(In reply to comment #7)
> Andre. Feel free to verify this on the PR1.1 release and close. 

Internal ticket (see Alias) has not yet been released/verified internally...
Comment 9 Andre Klapper maemo.org 2009-11-10 12:15:30 UTC
This has been fixed in package
hildon-desktop 1:2.2.114-1+0m5
which is part of the internal build version
2009.46-5 
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 10 Lucas Maneos 2009-11-19 11:07:56 UTC
*** Bug 6243 has been marked as a duplicate of this bug. ***
Comment 11 Andre Klapper maemo.org 2010-01-14 12:28:45 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 12 Tim Samoff (reporter) maemo.org 2010-01-14 15:47:36 UTC
I can still make this happen in PR1.1 (actually, it happens for all sorts of
apps during startup).
Comment 13 Sanjeev Visvanatha 2010-01-15 03:10:21 UTC
I noticed it on 1.2009.42-11.002.
With 2.2009.51-1.002, it appears fixed for the app manager.
Comment 14 Andre Klapper maemo.org 2010-02-02 21:49:31 UTC
(In reply to comment #12)
> I can still make this happen in PR1.1 (actually, it happens for all sorts of
> apps during startup).

Tim, where exactly do you click? I'm still unable to reproduce this...
Comment 15 Urho Konttori 2010-03-04 09:59:25 UTC
definitely fixed in pr1.1.1 and 1.2.