Bug 5676 - (int-141200) Audio does not sync with video (and is ultimately unsyncable)
(int-141200)
: Audio does not sync with video (and is ultimately unsyncable)
Status: CLOSED FIXED
Product: Images and Camera
Camera
: 5.0/(1.2009.42-11)
: N900 Maemo
: High critical with 1 vote (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: camera-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-21 20:38 UTC by Tim Samoff
Modified: 2010-03-02 14:07 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tim Samoff (reporter) maemo.org 2009-10-21 20:38:46 UTC
SOFTWARE VERSION:
41-10

STEPS TO REPRODUCE THE PROBLEM:
1. Start camera app and set to record video
2. Record video of someone talking

EXPECTED OUTCOME:
Audio syncs with video.

ACTUAL OUTCOME:
Audio does not sync with video (see links below).

REPRODUCIBILITY:
Always.

OTHER COMMENTS:
* http://samoff.com/random/20091021_003-orig_compressed.mp4 is the original
video compressed to a smaller size to conserve space.

* http://samoff.com/random/20091021_003-synced_compressed.mp4 was edited in
Adobe Premiere. I moved the audio -10 frames in order to sync the "slate" audio
with the video. As you can see, this didn't fix the issue -- which seems to be
some sort of variable frame-rate bug.

* Both videos are still 25fps and no other alterations have been made.
Comment 1 Andre Klapper maemo.org 2009-10-28 12:43:59 UTC
Fixed in package
gst-plugins-bad0.10 0.10.14-git265-0maemo3+0m5
which is part of the internal build version
2009-44.4
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 2 Andre Klapper maemo.org 2010-01-14 12:27:44 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 3 Tim Samoff (reporter) maemo.org 2010-01-14 15:43:30 UTC
I can confirm that this WORKSFORME in PR1.1.
Comment 4 Venomrush 2010-03-01 22:33:35 UTC
Verifying as well, I no longer see this issue since PR1.1
Tim, please close this bug :)