Bug 5670 - (int143814/int-220717) Generic "Unable to connect to one or more accounts" message unhelpful
(int143814/int-220717)
: Generic "Unable to connect to one or more accounts" message unhelpful
Status: RESOLVED FIXED
Product: Chat & Call & SMS
Presence
: 5.0:(20.2010.36-2)
: All Linux
: Low normal with 24 votes (vote)
: Harmattan
Assigned To: rtcomm@maemo.org
: presence-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-21 16:40 UTC by Andre Klapper
Modified: 2011-04-14 14:58 UTC (History)
9 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Andre Klapper (reporter) maemo.org 2009-10-21 16:40:34 UTC
SOFTWARE VERSION:
43-9

PRECONDITIONS:
* Email accounts: work IMAP and GMail IMAP
* IM accounts: Skype, MSN, ICQ, Google Talk

STEPS TO REPRODUCE THE PROBLEM:
Have problems connecting to one or more accounts (sorry, I don't know the
reason, but it happens quite often here)

EXPECTED OUTCOME:
1. Explain WHAT service refers to. IM accounts?
   Email accounts checked in the background?
2. Bonus points: Helpful error message explaining which of my accounts have 
   this problem, e.g. "Unable to connect to account(s):\nfoo@example.com 
   (Email), bar@example.com (MSN)" or something similar, so I could either 
   try fixing settings, or at least be aware of which service currently 
   does not work (==I am unable to receive messages for this communication 
   channel).

ACTUAL OUTCOME:
Vague, generic, unhelpful popup message that pops up every two minutes, lights
up my screen, and drains my battery.
I don't even have an idea whether this refers to IM accounts or Email accounts
(checked in the background).

REPRODUCIBILITY:
always
Comment 1 crolix 2009-12-07 18:55:10 UTC
Happens to me too occasionally after a network connection change, such as when
the Wi-Fi connection is gone and the phone switches to 3G. I have an N900 and
use Google Talk, Skype and MSN (to be able to use MSN I installed
account-plugin-haze).

When this happens, one of my accounts gets stuck with a "Network error", while
the other two connect successfully. I noticed that it's usually my Skype or MSN
account that gets stuck. All my accounts work fine if I connect from a PC.
Switching to different Wi-Fi networks or 3G, or simply waiting, doesn't help.
The account with the network error never recovers.

I did find a workaround for this: whenever this happens I simply reboot my
phone and it always works fine after this.
Comment 2 Mikhail Zabaluev nokia 2009-12-07 19:10:34 UTC
(In reply to comment #1)
> When this happens, one of my accounts gets stuck with a "Network error", while
> the other two connect successfully. I noticed that it's usually my Skype or MSN
> account that gets stuck. All my accounts work fine if I connect from a PC.
> Switching to different Wi-Fi networks or 3G, or simply waiting, doesn't help.
> The account with the network error never recovers.
> 
> I did find a workaround for this: whenever this happens I simply reboot my
> phone and it always works fine after this.

The problem with Skype is known, and we're trying to track it down. It's really
more serious than just the message being unhelpful. You could file another bug
to get progress on that issue; it won't be tracked here. Same for the MSN
issue.
Comment 3 crolix 2009-12-08 01:07:35 UTC
(In reply to comment #2)
> The problem with Skype is known, and we're trying to track it down. It's really
> more serious than just the message being unhelpful. You could file another bug
> to get progress on that issue; it won't be tracked here. Same for the MSN
> issue.

Thanks, I created bug 6696 for this. Progress on this issue would be
appreciated.
Comment 4 amorek13 2009-12-08 03:02:41 UTC
it happens do me also with connection change it in accout plugin haze i did a
bug sometime ago but one of the modes said he will contact the the guy who
wrote it but never heard anything
Comment 5 amorek13 2009-12-08 03:06:30 UTC
it happened to me also with connection change its in acconut plugin haze i did
a bug sometime ago but one of the modes said he will contact the the guy who
wrote it but never heard anything
Comment 6 Andre Klapper (reporter) maemo.org 2009-12-09 23:30:45 UTC
(In reply to comment #5)
> it happened to me also with connection change its in acconut plugin haze i did
> a bug sometime ago but one of the modes said he will contact the the guy who
> wrote it but never heard anything 

Unrelated to the bug report itself here which is only about the vague error
message, not about reconnection problems themselves.

For future reference, always provide exact links.
Also note that accounts-plugin-haze is not officially supported and not handled
in bugs.maemo.org.
Comment 7 Andrew 2010-01-06 16:25:03 UTC
My AIM account is no longer able to connect, it just constantly gets this
error.
Comment 8 Uwe Kaminski 2010-01-06 16:37:18 UTC
(In reply to comment #7)
> My AIM account is no longer able to connect, it just constantly gets this
> error.

Please fill a separate bug for this. It's important to have an extra bug
entries for every bug to make it easier to see what's fixed and what is still
open. Thanks!
Comment 9 Uwe Kaminski 2010-01-06 16:42:01 UTC
Accidentally closed the bug.
Comment 10 UGN 2010-02-15 22:43:45 UTC
i have a same problem. i am using only Yahoo messenger, but this message always
appears when connected to 3G. But this message appeared once even i connected
with Wi-Fi. i tried Crolix's advise. i restarted my phone, but the problem is
still there. i don't know what to do? its so annoying. Will it be fixed by
future firmwares? Somebody help me please
Comment 11 JMC 2010-06-02 06:27:39 UTC
MSN, AIM, and Gmail continues to disconnect. Sometimes it will reconnect, but
usually I need to reboot. I've tried to disable and re-enable the accounts, and
also changing my wifi connection, but to no avail.
Comment 12 Sony K. Philip 2010-08-13 12:50:39 UTC
Looks like a duplicate of <a
href=https://bugs.maemo.org/show_bug.cgi?id=6696>Bug 6696</a>
Comment 13 Andre Klapper (reporter) maemo.org 2011-04-14 14:58:20 UTC
This issue has been FIXED for Harmattan (the software version after Maemo5).
According to Nokia this is a WONTFIX for Maemo5.