Bug 5628 - FN-lock and Ctrl+Backspace breaks input for used application
: FN-lock and Ctrl+Backspace breaks input for used application
Status: VERIFIED FIXED
Product: Desktop platform
Input method framework
: 5.0/(1.2009.41-10)
: N900 Maemo
: Low normal (vote)
: 5.0/(2.2009.51-1)
Assigned To: Joaquim Rocha
: input-method-framework-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-10-20 16:00 UTC by Marko Vertainen
Modified: 2010-01-14 12:28 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Marko Vertainen (reporter) 2009-10-20 16:00:58 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)

1.2009.41-10

STEPS TO REPRODUCE THE PROBLEM:

1. Open up some application with input area e.g. notes.
2. Double tap FN-key on HW keyboard (blue arrow).
3. Go to task switcher using keyboard shortcut (Sym + Backspace).
4. Go back to application you were using.
5. Try to write something -> nothing happens.

EXPECTED OUTCOME:

Writing works.

ACTUAL OUTCOME:

When returning back to application keyboard doesn't work before pressing
SYM-key and closing symbols window.

REPRODUCIBILITY:
(always/sometimes/once)

always

EXTRA SOFTWARE INSTALLED:

Many from extras testing.

OTHER COMMENTS:

I noticed this first while writing an email and looking some information from
one image. It took some time from me before I understood what was happening.
This seems to be system wide problem but I'm not sure if it belongs to input
method framework or application switcher.
Comment 1 Lucas Maneos 2009-10-20 16:37:28 UTC
Confirming, problem is exactly as described.  Thanks!
Comment 2 Joaquim Rocha 2009-10-20 16:42:29 UTC
Hi Marko,

It's funny, we've corrected this bug last week :)

It was a nasty one from the user's perspective. Thank you for reporting.
Comment 3 Andre Klapper maemo.org 2009-11-12 18:02:10 UTC
Hi Joaquim,

(In reply to comment #2)
> It's funny, we've corrected this bug last week :)

Which exact week was this released/verified internally?
Any internal six digits number? :-)
Comment 4 Andre Klapper maemo.org 2010-01-14 12:28:42 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.